Subscriber Unable to connect with Publisher

Unanswered Question
Apr 21st, 2010
User Badges:

Hi guys.


Somebody already get this error on installing Subcriber?


CUCM 7.1.3a


The publisher name is correct

The security password is correct

Don't have DNS

Have licenses to 2 nodes

I already tried cable between the servers


Thanks


Peterson

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (6 ratings)
Loading.
allan.thomas Wed, 04/21/2010 - 12:18
User Badges:
  • Blue, 1500 points or more

Hi,


Could please kindly elaborate on what you mean by the fact that the Subscriber is unable to connect with the Publisher?


Ordinarily when you build the subcriber, part of the process ensures that the subscriber has reachablility with the Publisher otherwise the installation would fail.


Regards

Allan.

David Hailey Wed, 04/21/2010 - 12:18
User Badges:
  • Purple, 4500 points or more

Please post the exact error you are getting.


If this is during installation, the likely error is related to NTP status on the Publisher.  If the Publisher is not sync'd to a valid NTP source, then then Subscriber will not be able to sync with the hardware clock on the Pub.


However, without knowing the exact error - no one on the forums can be of much help.


Hailey

pgcristovam Wed, 04/21/2010 - 12:30
User Badges:

Hi


On Publisher


Services are running

On System -> Server, added Subscriber ip address



Put DVD on Subscriber and install.


This server is publisher node? No

hostname pub: xxxx

ip address: xxxx

security pass: xxxx

confirm secur pass: xxxx


click ok


Ntp syncronizing.... OK


show error


Unable connect if publisher


confirm the name ccmpub

confirm the ip address

confirm the security pass

the ccmpub is with correct ip address?

ccmpub is powered?


This is errors


Thanks

David Hailey Wed, 04/21/2010 - 12:34
User Badges:
  • Purple, 4500 points or more

Ok, that's what I thought. The subscriber cannot sync it's hardware clock with the Publisher. Are you using NTP for time source on the Publisher? If so, go to the command line and type "utils ntp status" and post the output.


Hailey


Please rate helpful posts!

pgcristovam Wed, 04/21/2010 - 12:57
User Badges:

admin:show ntp status


Executed command unsuccessfully
No valid command entered
admin:util
admin:utils ntp status
ntpd (pid 29404) is running...


     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*127.127.1.0     LOCAL(0)        10 l   47   64  377    0.000    0.000   0.002



synchronised to local net at stratum 11
   time correct to within 12 ms
   polling server every 1024 s


Current time in UTC is : Wed Apr 21 19:59:58 UTC 2010
Current time in America/Sao_Paulo is : Wed Apr 21 16:59:58 BRT 2010
admin:

David Hailey Wed, 04/21/2010 - 13:23
User Badges:
  • Purple, 4500 points or more

So, you are not using NTP - instead, you are using the local hardware clock on the Publisher. NTP is recommended; however, I believe it must be added during installation or it will require a reinstall. That may have changed - I can easily double check. However, the issue you are having is that the Subscriber is unable to synchronize it's time to the hardware clock of the Publisher. This could be a bug or a hardware issue or just bad luck but in either case, you cannot install a Subscriber unless it can sync to the Pub. Time works like this (example is you use NTP):


Publisher is built. You specify an NTP source which happens to be an ISR router with address 10.10.10.10.


Before you install the Subscriber, you check the ntp status of the Publisher and it will list a local lookback first and the NTP server second. The NTP server should have a star next to it and indicate it is synchronized to the external source.


When you install the Subscriber, it will sync with the Pub which is synced to NTP.


Hailey


Please rate helpful posts!

pgcristovam Wed, 04/21/2010 - 13:33
User Badges:

On CUCM 7.x the NTP is recommended and not mandatory like CUCM 8.

I have 2811 router, i think it cannot configured as ntp server.


Thanks


Peterson

David Hailey Wed, 04/21/2010 - 13:37
User Badges:
  • Purple, 4500 points or more

You're right, it's recommended - but highly recommended.  I have a 2811 router in my lab and it is configured as an NTP source for the CUCM cluster I have there.


Also, is this a hardware installation or a VMWare installation?  If this is a VMWare installation - this is a very common issue.


Hailey


Please rate helpful posts!

pgcristovam Wed, 04/21/2010 - 14:20
User Badges:

Hi


Is a hardware installation on customer.

Can you send me you router 2811 configuration? I will configure the 2811 like NTP server on CUCM.


Thanks


Peterson

David Hailey Wed, 04/21/2010 - 16:41
User Badges:
  • Purple, 4500 points or more

ntp source


You will need to look at the install guide to confirm but I'm fairly certain this is correct. If you already built the Publisher without NTP, you cannot enable it after the fact. It must be done during installation. To enable it after the fact requires a rebuild of the system.


Hailey


Please rate helpful posts!

aalamgir Sun, 03/10/2013 - 10:50
User Badges:

Talking about VMware, Just add subscriber IP address in publisher CUCM & it would sync its time with publisher during installation.

aalamgir Sun, 03/10/2013 - 11:05
User Badges:

Talking about VMware, Just add subscriber IP address in publisher CUCM  & it would sync its time with publisher during installation. Or you may say that "  Register Subscriber in Publisher" while giving its IP address under System ==> Server==> add new.

Actions

This Discussion