Cisco Mobile 8.0 for iPhone

Unanswered Question
Apr 22nd, 2010

Hi,

I just downloaded the new client for iPhone. I've read it supposed to work without CUMA

However, I didn't succeed to register the device on my CCM (7.1(3)).

I created a Basic Sip device with digest auth. and associated with the username.

Unfortunately, i have an error message during wizard setup " DEVICE CONFIGURATION NOT FOUND"

The software is asking for:

DEVICE ID: I've put the SEPXXXXXXXXXXXX

TFTP SERVER: CUCM@

SIP DIGEST USERNAME: I'v put the dn

SIP DIGEST PASSWORD: I'v put the dn

Any idea ?


THX

Fabian

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.4 (5 ratings)
f.giordano Thu, 04/22/2010 - 05:50

Hi David,

Unfortunately, this is not as easy as other Sip client...

There's specific config with cop file and iPhone creation on the CCM...

Fabian

htluo Thu, 04/22/2010 - 05:51

I haven't tried mobile client on iPhone yet.  So I might be wrong.  But for other phones (Nokia, Blackberry, WinMobile), you cannot just create "basic sip device".  You'll have to create a UMC device (Cisco Unified Mobile Communicator).

See:

http://www.cisco.com/en/US/docs/voice_ip_comm/cuma/7_0/english/install/guide/cuma_70_IAG_03_CCM.html#wp1247330

Michael

http://htluo.blogspot.com

David Hailey Thu, 04/22/2010 - 05:59

Yeah, first thing I noticed is your device name needs to be UPC...

I sometimes forget the iPhone cliet is a mobility client and not a strict softphone client...but I respond to a lot of posts so occasionally, I'm off-base.

Hailey

f.giordano Thu, 04/22/2010 - 06:02

The admin guide indicates that's the DeviceName has to begin with "TCT" and then maximum of 15 characters...

David Hailey Thu, 04/22/2010 - 06:06

I just realized that Michael posted a different doc than you. He posted a CUMA doc referring to UMC. Yours appears to be iPhone config-specific.

htluo Thu, 04/22/2010 - 14:28

Ok, got it figure out.

As usual, Cisco did a great job to confuse people.

Cisco Mobile 8.0 is NOT the next version of Cisco Mobile 7.1.  They are two different products.  ie. You shouldn't delete 7.1 and install 8.0.  If you want all the features, you have to install both 7.1 and 8.0.  They are totally different!  Why they use the same name?  Well, it's the wise decision made by some genius. 

Cisco Mobile 8.0 is a "dual mode" phone (IP and GSM).  While Cisco Mobile 7.1 is the "mobile communicator" (UMC).

I'm testing it right now.  More to come.

Michael

htluo Thu, 04/22/2010 - 17:39

Ok.  Got it work on CUCM 7.1.5:

1) Created a dual-mode phone for iPhone with TCT prefix (e.g. TCTJOHNDOE).

2) On Cisco Mobile 8 logon screen, enter the following information:

DEVICE ID: TCTJOHNDOE

TFTP SERVER: 192.168.1.10

192.168.1.10 is the IP address of CUCM TFTP.

Michael

http://htluo.blogspot.com

f.giordano Thu, 04/22/2010 - 23:49

Ok. I guess it should be my CCM version (7.1.3.20000-2). I'm currently upgrading to 7.1.5, and will let you know.

Thanks

Fabian

htluo Fri, 04/23/2010 - 04:57

On 7.1.3 you need to install the COP file.  Otherwise, you won't see the "Dual-mode phone for iPhone" device type.

Michael

f.giordano Fri, 04/23/2010 - 05:14

I followed the entire procedure. it doesn't work even with the cop file...

I just upgrade to 7.1(5) without changing the CCM config and my iPhone registered instantly...

So it might be something wrong with version                           7.1.3.20000-.

I'll test the features this PM.

fabian

f.giordano Fri, 04/23/2010 - 08:02

Ok I did the test, everything is working fine except handoff too...

Fabian

walshliam Sun, 04/25/2010 - 20:02

Did you reboot the Cluster after installing the COP file? 7.13 works if you reboot after instaling the cop file.

f.giordano Mon, 04/26/2010 - 00:02

No, I didn't restart the cluster since it's not mentionned in the release note...

I restarted CallManager, TFTP and Tomcat Services.

Fabian

jrgates@burns-w... Tue, 04/27/2010 - 09:24

Do you have to reboot or just restart the Call Manager Service?  I'm getting ready to

try it on 7.1.3.

walshliam Tue, 04/27/2010 - 10:20

We rebooted our cluster as per the document. We tried just restarting TomCat and TFTP but the Voice portion of the client would not work. We scheduled a time to reboot the cluster which got the app up and running. Restarting teh Call manager service may have achieved the same result, but we didn't bother.

Step 11 Reboot all Cisco Unified Communications Manager servers at a time of low usage.

Shaun Bender Sat, 07/31/2010 - 21:33

Michael,

Are you using Application Dialing Rules, if so how did you make it work?

Thanks,

Shaun

benjaminwatt Sun, 08/01/2010 - 06:12

Hi Shaun,

I'm using Application Dialling Rules with Cisco Mobile 8.0. You can't go too far wrong if you follow the instructions in the Administration Guide, and upload the file that it mentions you need to get hold of, to your TFTP server. I modified mine and gave it a more meaningful name before I placed it on there.

As long as you restart the TFTP service, and specifiy the full address to the XML file in 'Application Dial Rules URL' it should just work.

Shaun Bender Sun, 08/01/2010 - 08:37

Hi Ben,

This is what is interesting, I already installed/restarted for that COP file.  The contents of that file show:

I didn't think I need to actually put the "Application Dial Rules URL" --- only if I was using a different name/location for that file.

benjaminwatt Sun, 08/01/2010 - 09:39

Actually, yes - sorry, if you don't rename the file you're not supposed to need to put anything in that field, I just chose to rename mine to make it more meaningful.

But the file as you've discovered is pretty empty to begin with, so if you upload it as is it won't do anything.

My rules so far are just set to add a 9 at the beginning of longer numbers (11 digits with area code, 6 without) so that if I choose to call a contact from my iPhone contacts it will work. Similarly, as our extension numbers are the last four digits of the company numbers, I remove the prior digits so that if again I use an iPhone work contact it just dials the extension number rather than the full number. And then finally, if any other numbers begin with +44 (the UK dial code), I take that off and replace it with numbers our phone system will recognise.

Yours will vary depending on what numbers your phone system will cope with, and what form the numbers in your user's iphones are likely to take, but if it helps, I have (where I've replaced our company number's initial digits with 1234567):


   
   
   
   

Shaun Bender Sun, 08/01/2010 - 10:16

Ben,

Thanks for the info .. now this is getting pretty "odd".

I can't overwrite that file nor upload a new file, even after shutting down the tFTP service.

I thought I could just add the rule via:

Call Routing > Dial Rules > Application Dial Rules

benjaminwatt Sun, 08/01/2010 - 14:40

Cisco Mobile 8.0 appears to ignore the Application Dial Rules in Call Routing > Dial Rules, so you do need to create your own in that AppDialRules.xml file. Besides, there may be some rules you'd only want to apply to mobile users.

You only need to restart the TFTP service after you've uploaded the file, are you uploading it in the 'TFTP File Management' section of the OS Administration site? Can't think of any reason why this wouldn't work, if you rename it to something else does it work? Or if you delete the current one?

Shaun Bender Sun, 08/01/2010 - 15:20

Hi Ben,

Pretty strange, I couldn't upload anything unto the CUPC directory or make any modifications to those files.

However, I just uploaded "CiscoMobile-APR.xml" to "/" and now Cisco Mobile is dialing perfect.

I do notice when clicking on an existing contact's phone number the display shows "5 + the 10 digit number", i.e. 51112223333, when it's dialing the number.

However, if I just dial the number manually, the "5" is then removed, and the "formatting of the number" looks good. i.e. looks like (111) 222-3333.

Just minor details..... at least it is working now, thanks for you assistance.

Now if the Caller ID on the SIP trunks would look good---then it would be time for a beer.

Thanks again.

Luis_Yrigoyen Sun, 10/17/2010 - 19:47

Ben,

     I have it all working except for the directory.  I've uploaded the cop file and I've verified that the directory CUPC exists in the TFTP and that the two xml files are in there.

Now, I guess I need to enter the path for this file(s) in my dual phone config; right?

what's the path? My files are in the default location.

thanks

Darren Parkinson Mon, 04/26/2010 - 05:25

I managed to get it working ok with CM 7.1(3) after loading the COP file -- one quick question though...

On the configuration for the Cisco Mobile 8.0 application, there is an option to enable "Contact Pictures" -- I'm guessing this doesn't work on this version?  Anyone else had that working?

Thanks.

f.giordano Mon, 04/26/2010 - 05:31

Hi,

This feature will be enable when the field "LDAP Photo Location" will be supported.

And it's not in this version...

Fabian

cradescu Wed, 05/05/2010 - 04:59

Hi all,


I have a little problem with Cisco Mobile 8.0.
I followed Admin Guide and Cisco Mobile 8.0 FAQ documents at the following links:

http://www.cisco.com/en/US/docs/voice_ip_comm/cumc/cisco_mobile/iPhone/8_0/Cisco_Mobile_iPhone_8x_Admin_Guide.html#wp176679
http://www.cisco.com/en/US/docs/voice_ip_comm/cumc/cisco_mobile/iPhone/8_0/FAQs/English/Cisco_Mobile_8_chapter1.html

Everything is ok except the fact I can not transfer an active call from my 9971 desk phone to the iPhone. I can place a call on hold on the iPhone and resume it on my 9971, but I cannot do the same action in reverse. More of this, I discovered that when a call is active/on hold on my primary phone 9971, If I then launch the Cisco Mobile 8.0 client on iPhone I can see the option to move the call to my iPhone client. If the Cisco Mobile 8.0 client is already opened it can not see the call on hold on the DeskPhone.

Did anybody test this?I don't know if is a bug or I am configuring something wrong.In the FAQ doc Cisco stated:

"
Q.
If I'm on a call using my desk phone, can I move the call to my iPhone?

A.

Every time you open Cisco Mobile 8.0 on your iPhone, it automatically detects active calls on your desk phone.

Tap Yes to move the call from your desk phone to your iPhone. If you choose not to pick up the call, but then later change your mind, just put the call on hold using your desk phone. Cisco Mobile 8.0 will automatically detect the call for you again.
"


Many thanks in advance,

Cristian

walshliam Wed, 05/05/2010 - 05:42

I think this is how it is supposed to work. I have mine working the

same way. Active calls can be taken by the iPhone when the app is

launched, but you cannot pass calls back and forth without shutting

down the app and relaunching. This will hopefully be a feature thy

improve in the next release.

Sent from my iPhone.

On 2010-05-05, at 7:59 AM, cradescu

f.giordano Wed, 05/05/2010 - 05:49

Same behaviour for me too.

If I launch the app during an active call on my deskphone, it asks me to get the call on the iPhone.

If I say No and later during the call on the deskphone I decide to hold again, the app still ask me if I want to get the call...

But you're right if the deskphone place the call when the App is already launched, there's no way to get it on the iPhone.

I'm pretty sure it's the right way it supposed to work and it will be fix soon (I hope )

++

Fabian

walshliam Wed, 05/05/2010 - 07:34

It would also be a nice feature if you could take an active call on your iphone and move it to your CM8 client.

Lia

Liam Walsh - Network and Telecom Support

Information Technology Services

London Health Sciences Centre and St. Joseph's Health Care, London

(519) 685-8280

m

>>> "f.giordano" 5/5/2010 8:49 AM >>>

walshliam,

A new message was posted in the Discussion thread "Cisco Mobile 8.0 for iPhone":

https://supportforums.cisco.com/message/3066718#3066718

Author : f.giordano

Profile : https://supportforums.cisco.com/people/f.giordano

Message:

cradescu Wed, 05/05/2010 - 07:42

Thanks for your answers.

Yes, would be nice but this is in fact a transfer from your GSM number to your office number(DID) and should be supported by your GSM provider.

Rajesh Revuru Wed, 05/12/2010 - 12:43

Guys:

I followed instructions in the Administration Guide, and i get an error "No Lines detected for device". I have case open with Cisco TAC, and they asked me to try at Corporate Wi-Fi, and i did and still no luck.

Anyone has any ideas

Rajesh Revuru Wed, 05/12/2010 - 13:27

Never mind folks, i got it, i had to restart the CUCM and got it working. Pretty interesting

jrgates@burns-w... Tue, 06/01/2010 - 05:50

I was able to get this working like a champ through Wi-Fi any one have any issues getting it to connect through an ASA?  I can't get it to connect.

Thanks,

Gates

brett.shaffer Tue, 08/03/2010 - 07:36

Very nice application - we have this working via Wi-Fi and VPN without issues. Is there any talk regarding intergration with Unity? Currently Unity Connection is the only messaging platform available.

drjoaquin Fri, 08/13/2010 - 15:26

I have done everything it says to do in the admin guide and I still cant get this thing to connect...

.ahhhh    I can ping it so I know its connected to the corp WiFi.  (we have 7.1.3)  I have the iPhone template...and configured it like normal in CUCM.  I set up the line and associated the device to the end user.  Although when I try to add a New Mobile Identitity profie, i get this...(Add failed. [10107] Remote Destination cannot be added because there is no associated EndUser for this dual-mode phone, Remote Destination Profile or MobileSmartClient)  It is driving me crazy because the device is associated with the end user. 

Any assistance would be appriciated

Dale

htluo Fri, 08/13/2010 - 15:50

1) Go to CUCM > User Management > End User.  Find the user.  Make sure "Enable Mobility" checkbox was checked.

2) Go to CUCM > Device > Phone.  Find your iPhone.  You should be able to choose the user from "Mobility User ID" drop-down list.

Michael

http://htluo.blogspot.com

drjoaquin Fri, 08/13/2010 - 16:01

Too funny i found the check box before i got our post.  Anyway thats done but the iPhone still does not connect.  The only thing the iPhone asks for is the device name (TCT4931) 4931 being the user ext.  and i have it pointed to our Sub.  I tried the sub and pub with no luck.  I dont know what i'm missing?  Btw; i did not check the voice mail part in the mobility box set up box.

drjoaquin Fri, 08/13/2010 - 16:08

I mean I didnt check Enable Mobile Voice Access but now its checked.  Still no joy

benjaminwatt Fri, 08/13/2010 - 16:21

I'd recommend keeping the config as simple as possible to begin with, I found that the first time you're setting this all up it's surprisingly easy to break everything with a rogue setting somewhere when everything has been working so well up to that point.

Short of you posting us screenshots of your iPhone device setup in CUCM, along with the End User, you could always just scrap the TCT iPhone device and create a new one from scratch, follow the admin guide again, and don't continue onto anything featured from 'Setting Up Transfer of Active Calls Between Cisco Mobile 8.0 and the Desk Phone' onwards until you have the basic phone functionality working.

mikeyes5 Sat, 09/18/2010 - 21:43

Having trouble getting this to work on 7.1.3.

Have installed the add-on and rebooted the pub and sub.

Am trying to connect through VPN and Pix firewall.  Not sure if the PIX is causing the issue or not.

Those that got it to work on 7.1.3 were you on the same LAN as CM server or were you outside and through a firewall?

Thanks

Actions

Login or Register to take actions

This Discussion

Posted April 22, 2010 at 1:27 AM
Stats:
Replies:60 Avg. Rating:4.4
Views:52508 Votes:0
Shares:1
Tags: No tags.

Discussions Leaderboard