Pass CallerID

Unanswered Question
Apr 22nd, 2010
User Badges:

Hi All,


I'm stumped on a caller ID  issue where a new setup is not receiving callerID on the Cisco phones from external PSTN calls through an H.323 VG.  When I call from a US cell phone to the VG in China, I get this from the debug:


Apr 22 2010 21:07:43.509 SHG: [0/1/0] get_fxo_caller_id:Caller ID receive failed.  parseCallerIDString:no data


The running-config shows this POTs line setup as:


voice-port 0/1/0
supervisory disconnect dualtone mid-call
no battery-reversal
cptone CN
timeouts call-disconnect 1
timeouts wait-release 1
caller-id enable
!

My initial thought is the China Telco is not passing CallerID, but the tech on that end double verified with them and unplugged a POTs line from the VG and into a phone and validated that claim.  My new thought is possibly having to do with the number of digits as when I call it's 15 digits in length, wheras when the tech calls from his cell phone, it's a more moderate number.  Could this be a possibility?  Is there another place I should have settings enabled to pass CallerID in the VG or should the lines display what's passed by default?


Thanks in Advance for Assistance!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Thu, 04/22/2010 - 06:43
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Caller-ID can be a playful animal... there are lots of different ways of signaling it, and different points at which it can be signaled. Entering the cptone should (I believe) set some default, but either it doesn't, or there are too many standards in each country (i.e. per service provider/telco kit type).


In the UK we have to add 'caller-id alerting dsp-pre-alloc' as it's signaled out very early.


There are a bunch of other methods you can try :


http://www.cisco.com/en/US/docs/ios/voice/command/reference/vr_c4.html#w...


I would try some, remembering to shut/no shut the voice port in between calls to ensure that it takes effect. Maybe start with the pre-alloc command as above...


Regards


Aaron

Actions

This Discussion