ASA5520 Memory Upgrade

Unanswered Question
Apr 22nd, 2010

Just bought an ASA5520, opened the box to upgrade the memory to 2 GB to support 8.3, and discovered that the unit only has 1 memory module connector.  I thought all the ASA5520 units came with 4 slots?  There are hole patterns for the other 3 slots, but nothing installed on the circuit board.  As it is, the most I can load the unit with is 1 GB (ASA5520-MEM-1GB), but there are not any suggested 2 GB modules.  If my console output didn't show ASA5520, I'd wonder if I didn't have a 5510 board installed in a 5520 chassis.  Any one else seen anything like this?  These are so hard to find right now, that I hate to have to return it to my reseller, as I don't think I can get a replacement for a couple of months.  Any possible 3rd party memory fixes for this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
pkampana Thu, 04/22/2010 - 14:22

Only older 5510's had 4 slots.

The rest should have only 1 slot.

For memory replacement you will just need to load the new memory on the existing slot.

To be honest there was one more case that I heard a 5520 having 4 slots.

For the 3rd party memory...it is not officially recommended.

I hope it helps.

PK

skint Sun, 04/25/2010 - 03:01

Hi,

Just verify that the RAM currently installed is STEC variety and then find the specs.  I assume that the 5520 and 5510 are using the same bus, so it probably needs PC2700 registered ECC non-buffered RAM CL 2.5. 

This is my bet on what's installed with ASA5520-MEM-1GB and this STEC RAM or equivalent should work as the ASA5520-MEM-2GB replacement:

http://www.stec-inc.com/products/industrial/data_sheets/61000-03730-104.pdf

Make your own call on the 3rd party components.

http://www.cisco.com/en/US/prod/prod_warranty09186a00800b5594.html

-skint

kfolkman Mon, 04/26/2010 - 11:49

Well, it appears that the 5510 and 5520 have different buses.  From what I can see, the ASA5520 and ASA5540 share the same bus and memory requirements.  Got some approved Cisco memory in today, but the unit will still not boot.  Not sure where to go next.

ericb_summit Mon, 08/09/2010 - 07:21

Are you sure the 5520's take ECC RAM?  I looked up the model number of the RAM that I removed the 2 x 256MB RAM that was previously in my ASA5520 with 4 slots.  It was not ECC.  I read furthermore that the 5505's won't boot with ECC RAM; not sure if this holds for the 5520.

Upon further research, I found 2GB PC3200 RAM CL 2.5 actually exist, but only ECC.  I could not find non ECC 2GB DDR PC3200 CL 2.5 in one stick.

Anyways, our cisco certified partner claims to be able to source Cisco approved RAM that is 2GB in 1 stick.  This fascinates me because I couldn't find mention anywhere that a single stick of 2GB is a supported config for ASA 5520.  If the RAM comes in, and it works, I will post back the model number so that the rest of you may benefit.

aossipov Mon, 08/09/2010 - 08:44

Hello Eric,

Please note that the only certified ASA5520 memory upgrade kit configuration is two 1GB DIMMs (Cisco part number ASA5520-MEM-2GB). I strongly discourage you from using any third-party upgrade kits as we had seen them cause problems in production environments.

Andrew

edsge teenstra Thu, 01/30/2014 - 06:09

Hey Kyle

How are you doing man ?

Long time not spoken to you..

We have this issue also .. have you found more information about this ?

Found this :

http://etherealmind.com/asa-5520-and-asa-5540-with-only-one-dimm-memory-socket-counterfeit-hardware/

But i check the serial number and ity comes up as a ASA5520-BUN-K9 and made in mexico so i cannot imagen it is counterfeit.

Hope i hear from you !

TTYL

kfwoodhouse Wed, 06/23/2010 - 15:21

Has anyone else seen this?  I too have this problem.  I have a few ASA5520's here and it seems some of them have 4 memory slots and some have 1 memory slot.  All Cisco documentation says this unit has 4 memory slots and even 1 TAC engineer i talked to said the unit should have 4 slots.

I think its possible there is a new logic board design on some of these units and maybe TAC isnt aware of it yet or something.

Either way im not sure how im supposed to install the 2GB memory kit into this unit with only 1 memory slot as the kit is 2 sticks of 1GB.

kfolkman im in the same boat as you so if you figure it out please let me know.

Thanks,

kfolkman Thu, 06/24/2010 - 13:56

Kyle,

We ended up returning the unit and getting another from a different vendor that had four slots, so the upgrade went without difficulty.  I have heard that any ASA5520 units shipped after the first of May this year should all have 4 slots, but there is still some inventory out there in sealed boxes that you won't know about until you open them.  Had a friend with a similar experience with ASA5505 units and memory upgrades, as well.  He couldn't get the memory upgrade to work there either, and he has since informed me that Cisco TAC confirmed a couple of bugs relating to memory issues in 8.3, but that nothing is yet described or confirmed by Cisco.

pkampana Thu, 06/24/2010 - 14:53

As halijenn suggested I believe this is worth opening a TAC case to get it further investigated.

PK

kfolkman Wed, 07/14/2010 - 09:00

Since we got a replacement unit that had all four DIMM sockets, we have not contacted TAC, and probably will not about this issue.  I'd love to have the time to pursue this, but any ASA5520 units manufactured after April 1 of this year apparently do not have a problem as all DIMM slots have sockets for memory, so you can use the 512 MB modules and get to 2 GB that way.  That's what we finally ended up with, and it works fine now.  If for any reason yo have an older unit that hasn't yet been upgraded to the new revision OS, you should probably contact TAC after first determining if your unit has less than four DIMM sockets before the upgrade.

aossipov Wed, 07/14/2010 - 11:27

To close the loop on this, the only shipping configuration of all ASA5520 and ASA5540 units is with 4 DIMM slots (regardless of the manufacturing date). Only some ASA5510 units may have a single DIMM slot.

Andrew

Jerome Tissieres Wed, 07/14/2010 - 13:31

Sorry but I have two ASA5520 with exactly that problem. There's the place and the pins for 4

slots but only one physical slot. Here's a picture ;

I'll open a TAC case asap.

Jerome

kfolkman Wed, 07/14/2010 - 13:39

This is exactly the same configuration I had on two differnet ASA5520 units, without all the sockets installed.  Luckily we were able to return those units to our reseller and get one that had all four sockets.  The party line may be that all the 5520 units shipped with four sockets, but I've had conversations with at least three other users with a similar problem.  I do know that someone told me that the problem was corrected in all shipments after April 1 of this year, to coincide with the release of 8.3.

Jerome Tissieres Tue, 08/10/2010 - 02:06

For the moment, I diden't open the TAC case because I was off.

I'll do it pretty soon.

Best,

Jerome

kfwoodhouse Thu, 07/15/2010 - 10:39

Ya that looks like the one i have too.  I actually have two 5540's like this and two 5520's.

Cant find the purchase history on them so i dont think i have smartnet on them.  I was just kinda hoping that a field notice might pop up eventually giving some background on maybe this being a batch of serials that were manufactured with the wrong design.

If anyone finds any new info let me know.  Thx,

ckelly@hsutx.edu Tue, 07/20/2010 - 09:11

I have two 5520s that are about to (try) and get 2G installed.  They are about 2 yrs old, so I'll report here when I get one open and get a look-see.  There's two DIMMs in the upgrade boxes, so it'll be nice if there are sufficient slots.

Message was edited by: ckelly@hsutx.edu Looks like our units are 2006 vintage and they have the required DIMM slots. 

ericb_summit Wed, 08/04/2010 - 14:18

We are in the same boat.  One of our ASA 5520 has 4 DIMM slots, one has 1 slot.  sh ver and sh module is exactly the same between the 2 units.

We have an open TAC case in which the resolution is to upgrade to 8.3.  We'll escalate this issue there to see where it leads.  Glad we are not the only ones with this funny surprise.

Thanks

Magnus Mortensen Wed, 08/04/2010 - 20:46

Eric,

     If you have that SR # handy where you ran into the memory slot issue, please go ahead and PM me the number. For everyone else, please open an SR if you run into this issue so we may look into these further.

Thanks as always!

     Magnus

CentralReservations Wed, 03/30/2011 - 04:50

Hi Magnus,

I've just tried to upgrade my ASA 5520 to 2GB and found out that the hardware only has one DIMM slot available.

This device was purchased in Feb 2009, so the warranty is expired - there is no SMARTnet on this item either at the moment.

Can you tell me what I can do please? I need to use the 8.3+ software on this device for Windows 7 SSL VPN.

daristau Fri, 07/01/2011 - 05:35

has there been any clarification on this issue ?  i.e. range of serial numbers that may be affected.

I'm working on an ASA memory upgrade project, have more then a dozen 5520's out in the field,

I want to kno wwhat I am getting into, before the customer is is the middle of an outage.

maybe TAC might know if I opened a case with them?

mirober2 Fri, 07/01/2011 - 05:57

Hello,

Yes, please do open a TAC case for this issue.

-Mike

mirober2 Fri, 07/01/2011 - 09:39

Hello,

Just to clarify my previous post, all 5520s should have 4 DIMM slots. You would only need to open a TAC case if you encounter a 5520 that has only 1 DIMM slot, not as a proactive measure for each device.

Hope that helps.

-Mike

CentralReservations Mon, 07/04/2011 - 02:47

Mike, I have a 5520 here that is out of contract (ie. no SMARTnet)

I want to upgrade to 8.3 on it and I contacted TAC to verify that if I was to purchase SMARTnet for it that it would be replaced.

TAC was not able to tell me that if SMARTnet was purchased whether it would be replaced, and had no idea about 5520s with only 2 DIMM slots.

Can you clarify (officially) what the solution is for me?

aossipov Fri, 08/05/2011 - 10:31

Hello Shane,

As mentioned earlier, the only shipping configuration of all ASA5520 and ASA5540 units manufactured by Cisco is with  4 DIMM slots (regardless of the manufacturing date). Only some ASA5510  units may have a single DIMM slot. At this point, the best course of action would be to involve your Cisco partner/reseller.

Thanks!

Andrew

CentralReservations Wed, 08/10/2011 - 01:52

Andrew, while that may be the official line - it is an untruth. I and others here have legitimately bought Cisco equipment which seems to have a manufacturing defect.

I am simply asking how I can get this remedied. As it is the reseller is no more (economic issues) and this unit is out of warranty and has no Smartnet.

TAC won't talk to me without Smartnet and I cannot justify purchasing Smartnet on this unit to my management if I cannot be sure it will be replaced so that I can run 8.3!

So I'm looking for a way to confirm that this unit - which DOES exist - will be replaced.

As far as I'm concerned I've got a lemon here, a unit which was missold, and now Cisco are claiming that you couldn't have sold me this as your spec is different. This attitude is what I would expect from a shyster at a flea market - not Cisco.

@kfolkman - I agree that this is a Cisco problem - but if they won't accept that it is an actual problem then what can I do?

kfolkman Fri, 08/05/2011 - 12:55

Andrew, you've given that answer before, but the reality is much different.  I've seen three different AS5520 units with only one DIMM slot, and several others in this thread have also seen them.  Don't call the reseller, they bought these non-conforming units from Cisco, and TAC should work out replacement of the units that were note built to spec.  Don't perpetuate a myth and don't pass the buck.  This is a Cisco problem, not a reseller or end user problem.

kfolkman Fri, 08/05/2011 - 13:04

Shane,

Smartnet or not, Cisco put non-conforming units out in the field, and has a responsibility to help you deal with that.  As we can see here, some folks at Cisco are still in denial, almost 16 months since I first raised this issue.  However, TAC being what it is, prepare yourself for a bumpy ride.  Good luck.

ericb_summit Fri, 08/05/2011 - 13:28

If you bought this from an all-mighty cisco certified reseller, then they should help you.  I had this problem, and the reason I was told that cisco couldn't help me, was that I didn't buy it from a certified reseller.  In the end, with some convincing, my hardware was replaced by the reseller.  This new one is kosher, right number of memory slots.  I think that the hardware I previously had was some funny business, like a 5510 board in a 5520 chassis.

Jay Johnston Wed, 12/07/2011 - 11:20

Cisco's response to this issue is posted in the Release note of CSCtg55418. Please note that this issue is not a hardware, software, or manufacturing defect.

Text from the Release-note:

Since the release of Cisco ASA software version 8.3(1) and the related recommendation

to upgrade the RAM in all Cisco ASA-5520s and/or ASA-5540s, some Cisco ASA customers

have contacted the TAC reporting devices with only one DIMM socket.

Working with these customers, Cisco conducted a detailed investigation and identified the

affected devices as Cisco ASA-5510s that were modified post-manufacture to look like

Cisco ASA-5520s or Cisco ASA-5540s.  Cisco has always manufactured these products

with either 4 or 2 DIMM sockets, so these modifications were completed without our consent and

outside of our control.  Cisco takes this situation very seriously and through our

Brand Protection team is sharing these findings with the appropriate authorities.

Cisco's commitment will always be to quality products and supporting our customers. 

That is why we also offer service and support contracts for products purchased from authorized Cisco partners.

If your device was purchased from an authorized Cisco partner, it will be supported. 

In other cases we encourage you to contact the original point of purchase to determine next steps.

mhennenzo Tue, 12/20/2011 - 05:27

Could I have a link to this Release Note?  I would be the proof i need to convince a manager that we were scammed by his reseller.

Actions

Login or Register to take actions

This Discussion

Posted April 22, 2010 at 9:16 AM
Stats:
Replies:36 Avg. Rating:5
Views:27540 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 7,861
2 6,140
3 3,170
4 1,473
5 1,446