Help with AP1131 and 2960G

Unanswered Question
Apr 22nd, 2010

Trying to physically separate my DMZ from my LAN.  Currently my FW routes my DMZ traffic, port on FW is currently connected to a port on my core stack in a dedicated vlan and so-on.  I bought a 2960G to hang off the firewall and when I attempted to connect my AP to it the port will not come up no matter what I try.  I can connect a printer to the switch and it comes up fine (same DMZ vlan).  Same thing with any port in that vlan, but the AP wont come up.


I tried setting the speed to 100, duplex to half but no luck. Tried turning off/on spanning-tree portfast and no luck either.  Tried switch the cable and no luck there.  The AP comes up fine on my core 3750 and the only difference that I can see between that and my 2960 is the 3750 is not gig.

AP:

interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 160 in

c2960

interface GigabitEthernet0/2
switchport access vlan 11
switchport mode access
speed 100

3750

interface FastEthernet2/0/46
description AP-01 DMZ
switchport access vlan 11
switchport mode access

Any idea what the problem is?  It has got to be something easy.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
droeun141 Wed, 04/28/2010 - 07:16

Not sure if it supports auto-MDIX - have you tried a crossover cable?

dpatten78 Wed, 04/28/2010 - 08:04

Finally a reply, no I haven't.  But you would think it would support auto-mdix because I can disable/enable mdix.

glen.grant Wed, 04/28/2010 - 09:14

  In order to use auto mdix the port speed must be set as auto otherwise it will not work.  On the 2960 set the speed and duplex to auto and also on the AP otherwise you will have a duplex mismatch. You harcoded the speed on the 2960 which what is causing it not to come up , otherwise get a crossover cable and it doesn't matter.

dpatten78 Wed, 04/28/2010 - 10:09

Glen,

Speed and duplex are auto out of the box.   Meaning before I even tried different settings both ports were set to auto (almost positive will retest to be sure) and the link wouldn't come up with a straigh through cable to the 2960.  The link has been up between the 1131 and 3750 for 2+ years now and everything is set to auto there.

Crossover cable will solve my problem then?  IE you need a crossover between a gig switch and an 1131?  But don't need one between a 10/100 switch and a 1131?

Leo Laohoo Wed, 04/28/2010 - 15:15

The 2960 supports TDR.  I recommend you use this function to test the cable accurately.

dpatten78 Mon, 05/03/2010 - 10:37

No love.  Duplex/speed both to auto on the 2960 and the AP with a crossover cable and the link would not come up.

TDR tests with cat5/crossover showed the same results:

NET-ANN-SW-11#show cable-diagnostics tdr interface gigabitEthernet 0/4
TDR test last run on: March 01 00:15:02

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi0/4     auto  Pair A     39   +/- 2  meters N/A         Impedance Mismatched
                Pair B     28   +/- 2  meters N/A         Impedance Mismatched
                Pair C     N/A                N/A         Normal
                Pair D     N/A                N/A         Normal
NET-ANN-SW-11#

Leo Laohoo Mon, 05/03/2010 - 15:19

Impedance Mismatched

I've never seen this error message before.    But it's good news.  It could mean that your cable(s) is/are the culprit.
jimmysands73_2 Mon, 05/03/2010 - 17:02

Found error status here:

http://conft.com/en/US/docs/switches/lan/catalyst6500/ios/12.2ZY/command/reference/show1.pdf

Pair status displayed is one of the following:

Terminated—The link is up.

Shorted—A short is detected on the cable.

Open—An opening is detected on the cable.

Not Completed—The test on the port failed.

Not Supported—The test on the port is not supported.

Broken—The pair is bad—either open or shorted.

ImpedanceMis—Impedance mismatched.

InProgress—Diagnostic test is in progress.

No big help here. 

Did you ever get it solved?  Just curious.....

Leo Laohoo Mon, 05/03/2010 - 17:22

Hey Jimmy,

Thanks for that (+5).  I had a look and it's for a 6500.  The "Terminated" can also be "Normal" ... I guess.

dpatten78 Fri, 05/07/2010 - 07:06

No I never was able to get it working.  Didnt matter what I did the link would not come up on the 2950G.

You would think cisco > cisco it would work but it just won't.

Impedence mismatach was no help whatsoever.

I was going to run the TDR from the 3750 and see what it tells me while the AP is connected to it but you can only run TDR from gig interfaces.  Ugh.  The AP is connected to 100mb interface. 

Actions

This Discussion