output service-policy not working as expected

Unanswered Question
Apr 22nd, 2010

I setup a traffic shaping/QoS policy to limit outbound SMTP traffic to 17% of the bandwidth of our T1 and to also divy up some other traffic into roughly equal parts.  However it doesn't seem to be working as planned.  Remote users of RDP protocol were complaining of slow response from the terminal servers although I have tried to set aside 25% of the BW for RDP class of traffic.  Please see attached bandwidth graph of the T1 and also the output of "show service-policy" to see what I mean.  The graph shows the T1 pegged for almost two hours and the "show service policy" shows the SMTP class apparently getting all the BW.  What am I doing wrong?  Should I be policing instead?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Giuseppe Larosa Fri, 04/23/2010 - 00:05

Hello Diego,

I guess web traffic is in class default of child policy

I would suggest the following changes:

remove bandwidth 30 under class-default  under child policy it is not necessary to set it or set it to just 1 percent

enable WRED and set low thresholds ( in packets number) this should help in limiting web traffic TCP aggressive behaviuor by dropping packets of different sessions

start by just enabling WRED with

random-detect

For the elasticity of CBWFQ when other traffic classes are not sending packets the web traffic can be high but it has to be constrained when other traffic classes start to send

Hope to help

Giuseppe

DIEGO ALONSO Fri, 04/23/2010 - 04:47

Giuseppe,

I will certainly research WRED to see how it works.  You mention setting it with low thresholds but what it low?  10, 100, 1,000 packets?  Also yes, web traffic falls into the default class but it is the SMTP class that I believe is giving me trouble.  Did you mean to say SMTP?  Or am I wrong about SMTP causing the problem and should I be looking at the class default and web traffic as my main problem?

Thanks,

Diego

Actions

This Discussion