its-CISCO.2.0.2.0.tcl script on Cisco 2800 problem

Unanswered Question
Apr 22nd, 2010

Dear all,

I have a problem with its-CISCO.2.0.2.0.tcl script. I downloaded this file from Cisco and run on my Cisco 2800 voice gateway. The problems are:

- I can not hear prompt. I take a inbound call from PSTN, it connect but no prompt.

- I press 0 for operator but it takes about 10 seconds to connect to operator number. It's too long, right? How can I fix it?

Here are some outputs of configuration, flash: content and debug voice application script:


Configuration:

!
voice class custom-cptone vn
dualtone disconnect
  frequency 425 425
  cadence 500 500 continuous
!
voice-card 0
!
application
service inbound_ivr flash:its-CISCO.2.0.2.0.tcl
  param aa-pilot 499
  paramspace english index 0
  paramspace english language en
  paramspace english location flash:
  param operator 4100
  paramspace english prefix en

!

!
voice-port 0/3/0
supervisory disconnect dualtone mid-call
supervisory custom-cptone vn
supervisory dualtone-detect-params 1
no battery-reversal
timeouts call-disconnect 1
timeouts ringing 5
caller-id enable

!

!
dial-peer voice 29 pots
description PSTN number 7722086
service inbound_ivr
destination-pattern .T
progress_ind setup enable 3
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
direct-inward-dial
port 0/3/0
forward-digits all

!

dial-peer voice 4 voip
description ***** Inbound to HAN *****
destination-pattern 4...
modem passthrough nse codec g711alaw redundancy
session target ipv4:172.28.83.2
dtmf-relay rtp-nte
codec g711ulaw
no vad

FLASH:

Directory of flash:/

    1  -rw-    59846440                    <no date>  c2800nm-adventerprisek9_ivs-mz.124-24.T.bin
    2  -rw-      198423                    <no date>  track2v.au
   22  -rw-        5962                    <no date>  welcome5.tcl
   23  -rw-        7464                    <no date>  oscv4_final.tcl
   24  -rw-     1016832                    <no date>  app-b-acd-3.0.0.2-ReadMe.txt
   25  -rw-       30421                    <no date>  app-b-acd-3.0.0.2.tcl
   26  -rw-       55599                    <no date>  app-b-acd-aa-3.0.0.2.tcl
   27  -rw-       75650                    <no date>  en_bacd_allagentsbusy.au
   28  -rw-       83291                    <no date>  en_bacd_disconnect.au
   29  -rw-       63055                    <no date>  en_bacd_enter_dest.au
   30  -rw-       37952                    <no date>  en_bacd_invalidoption.au
   31  -rw-      496521                    <no date>  en_bacd_music_on_hold.au
   32  -rw-      123446                    <no date>  en_bacd_options_menu.au
   33  -rw-       42978                    <no date>  en_bacd_welcome.au
   34  -rw-       42978                    <no date>  _bacd_welcome.au
   36  -rw-        5962                    <no date>  welcome_hcm.tcl
   39  -rw-        7156                    <no date>  its-CISCO.2.0.2.0.tcl
   40  -rw-      198423                    <no date>  _welcome.au
   42  -rw-      198423                    <no date>  en_welcome.au

debug voice application script

*Apr 23 05:51:10.711: //106//TCL :/tcl_PutsObjCmd: proc act_Setup
*Apr 23 05:51:10.711:
*Apr 23 05:51:10.711: //106//TCL :/tcl_PutsObjCmd:
proc init_perCallvars
*Apr 23 05:51:10.711:
*Apr 23 05:51:10.711: //106//TCL :/tcl_PutsObjCmd:
ANI
*Apr 23 05:51:10.711:
*Apr 23 05:51:10.711: //106//TCL :/tcl_PutsObjCmd:
DNIS
*Apr 23 05:51:10.711:
*Apr 23 05:51:10.711: //106//TCL :/tcl_PutsObjCmd:
No DNIS

*Apr 23 05:51:10.711:       <----------------------------------------------- I press 0 here
*Apr 23 05:51:33.891: //106//TCL :/tcl_PutsObjCmd: 
proc act_GotDest <----------------------------------------------------- connect to operator number here.
*Apr 23 05:51:33.891:
*Apr 23 05:51:45.243: //106//TCL :/tcl_PutsObjCmd:
Connection success
*Apr 23 05:51:45.243:

Could you please tell me how to fix it? Thank you very much.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
william_chua Fri, 04/23/2010 - 00:08

I have this TCL application working before.

Try configuring a simple inbound dial-peer like shown below:

dial-peer voice 29 pots

     service inbound_ivr

     incoming called number 7722086

     port 0/3/0

hiepnguyenho Fri, 04/23/2010 - 02:27

Thanks William. Last time when you run this application script, how did you name the prompt file. I mean en_welcome.au or _welcome.au? Is there any more param to be configured for this?

william_chua Fri, 04/23/2010 - 02:41

i did not rename any prompts. I just uncompressed the tar file to the flash of the router.

hiepnguyenho Sat, 04/24/2010 - 04:17

I find my problem is:

- I press 0 while the prompt is playing and it takes 10 seconds to connect to the operator.

- I press 0 after the prompt and it connect to the operator immediately.

So my question is what if my prompt is long and a person from PSTN want to press 0 before the prompt end. Is there any way to modify the script to do it?

Actions

This Discussion