why I could not log in when I upgrade CSM from 3.01 to 3.3

Unanswered Question
Apr 23rd, 2010

Yesterday I tried to upgrade CSM from 3.0.1 to 3.3. I did not uninstall old version first, and then installed new version 3.3 directly. I did not find any error messages during this maintenance. Before we upgraded it, we use Radius server to authenticate user for login. But right now, it did not work with the radius account. Also it failed with admin account. Please give me teo cents about it. Thx!

BTW, I just tried to reset the password of admin based on Cisco's doc, it still did not work

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Panos Kampanakis Fri, 04/23/2010 - 12:15

To up[grade to 3.3 you need "CiscoWorks Common Services 3.2 is required forSecurity Manager 3.3 to work. You install Common Services automaticallywhen you install Security Manager server software.". So, if you were using Common services earlier than 3.2 with CSM 3.0 then this is not supported.

I would suggest a clean install of 3.3 as explained here http://www.cisco.com/en/US/docs/security/security_management/cisco_security_manager/security_manager/3.3/installation/guide/instl_wrapper.html

But you will not have the DB backup with your devices unless you have kept one.

I hope it helps.


HWangLoyalty_2 Fri, 04/23/2010 - 13:08

Thanks for your response.

But I did not understand. If Cisco documentation alreday mentioned "CiscoWorks Common Services 3.2 is required forSecurity Manager 3.3 to work. You install Common Services automatically when you install Security Manager server software". I think the current version of CS alreday is 3.2. I also remembered the option of CM3.2 is clicked. You mean CS could not be upgraded automatically since it is eariler than 3.2. Pls let me know:)

BTW, the old environment is CSM 3.11 rather than 3.0.1. Also the old version of CS is 3.0.5

Panos Kampanakis Fri, 04/23/2010 - 13:14

Let me make it more clear

http://www.cisco.com/en/US/docs/security/security_management/cisco_security_manager/security_manager/3.3/installation/guide/upgrade.html#wp1080990 sayis "Security Manager 3.3 will support upgrades from older releases (major, minor, and maintenance releases). You can upgrade to Security Manager 3.3 from Security Manager 3.1.1 (including SP1, SP2 and SP3), 3.2, 3.2.1 (including SP1 and SP2), and 3.2.2 (including SP1 and SP2)."

I believe that explains that a jump from CSM 3.0 to 3.3 is not supported.

I hope it helps.


HWangLoyalty_2 Fri, 04/23/2010 - 13:19

You are right. But the old version of CSM is 3.1.1. Cisco should support to upgrade 3.3 from 3.1.1.So I think CS3.2 alreday is in the system

version 3.0.1 I mentioned before is my typo. Sorry about it!


This Discussion