Real basic stuff.

Answered Question
Apr 23rd, 2010
User Badges:

While configuring an 871W via SDM I realized there is a field missing (or at least I missed it if it's there): there's no place to plug in default WAN gateway. There's a field for the static IP and two more for DNS, but nothing for gateway IP. The little Netgear router we use now,and it's Linksys predecessor, both require these three things for internet access. The router works fine for local traffic. But, without internet access this router becomes pretty much useless. Obviously, I am not a Cisco expert. What am I missing? I would love to make use of this router.

Correct Answer by Jon Marshall about 7 years 1 month ago

seanmcdunn wrote:


While configuring an 871W via SDM I realized there is a field missing (or at least I missed it if it's there): there's no place to plug in default WAN gateway. There's a field for the static IP and two more for DNS, but nothing for gateway IP. The little Netgear router we use now,and it's Linksys predecessor, both require these three things for internet access. The router works fine for local traffic. But, without internet access this router becomes pretty much useless. Obviously, I am not a Cisco expert. What am I missing? I would love to make use of this router.


Ken


On a Cisco router you simply add a default route to the configuration eg.


871(config)# ip route 0.0.0.0 0.0.0.0


where ISP next-hop is what you are referring to as the gateway IP.


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Jon Marshall Fri, 04/23/2010 - 14:10
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

seanmcdunn wrote:


While configuring an 871W via SDM I realized there is a field missing (or at least I missed it if it's there): there's no place to plug in default WAN gateway. There's a field for the static IP and two more for DNS, but nothing for gateway IP. The little Netgear router we use now,and it's Linksys predecessor, both require these three things for internet access. The router works fine for local traffic. But, without internet access this router becomes pretty much useless. Obviously, I am not a Cisco expert. What am I missing? I would love to make use of this router.


Ken


On a Cisco router you simply add a default route to the configuration eg.


871(config)# ip route 0.0.0.0 0.0.0.0


where ISP next-hop is what you are referring to as the gateway IP.


Jon

seanmcdunn Fri, 04/23/2010 - 14:52
User Badges:

Thank you very much. It worked 100%. I have to say though that Cisco makes it seem a bit ominous to edit the configuration. I was warned I should not do so unless I am an expert. Anyway, why don't they just add a field to the GUI where one can type this info in?

Thanks, again.

Sean

Jon Marshall Fri, 04/23/2010 - 14:55
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

seanmcdunn wrote:


Thank you very much. It worked 100%. I have to say though that Cisco makes it seem a bit ominous to edit the configuration. I was warned I should not do so unless I am an expert. Anyway, why don't they just add a field to the GUI where one can type this info in?

Thanks, again.

Sean


Sean


Glad it worked.


You don't have to be an expert to use the CLI, in fact it's a lot easier to use once you get used to it.


Jon

seanmcdunn Fri, 04/23/2010 - 18:57
User Badges:

I jumped the gun a little bit. I have a little more work to do with this router. As soon as I made the change to the router, the machine I was accessing SDM from had internet access. So, I moved everyone else from our Netgear router to the Cisco. Oddly enough, even though everyone had a working local connection (they all had access to local resources), no one else except myself had internet access. The basic settings for internet access have to be correct (otherwise I wouldn't have been able to do so). So, I'll have to poke it a bit to see what's missing. You know, it would be nice if the router actually came with a real manual. This one came with some basic instructions regarding where to plug what and safety issues, as well as the SDM CD. In the meantime, the little $60 Netgear has to pull our weight.

It's all a learning process.

Again, thank you for your help.

Jon Marshall Sat, 04/24/2010 - 01:51
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sean


It could be NAT settings on your router. If you post the config we can have a look. As for a manual, see attached configuration doc.


Jon

Attachment: 
seanmcdunn Thu, 04/29/2010 - 16:45
User Badges:

OK, well, I actually had two connections up with internet access with no modifications to the configuration other than what was already suggested. Now, these were connected directly to the Cisco router. I'm thinking I may run into some issues connecting the rest of our office which will be connecting to the router via an unmanaged switch. At any rate I'm posting the running config.

BTW--even with only two connections running through this router, access was slow as molasses. Employees already look at me sideways because we have connectivity issues with the router we're using now. They'd kill me if access were consistently this slow.

ericn8484_2 Sat, 04/24/2010 - 07:21
User Badges:

We use the Cisco 871's for some of our remote users. They are correct that you need to configure NAT overload for more than one individual to access the internet. Here is an example of how to configure this via command line:


Interface FastEthernet4

description Internet Interface

ip address dhcp

ip nat outside      


Interface Vlan1

description Local Network

ip address 192.168.0.1 255.255.255.0

ip nat inside          


access-list 1 permit 192.168.0.0 0.0.0.255  


ip nat inside source list 1 interface FastEthernet4 overload

Actions

This Discussion