Unable to import settings with new firmware

Unanswered Question
Apr 24th, 2010

Hello. I just recently updated the firmware in my SA-520W to version 1.1.42, but I can't import my previous configuration. The previous firmware version was 1.0.15, and I've saved my configuration via network to my computer. But after I updated it was reversed to the default settings, and when I tried to import my config file, the appliance rebooted, but still with the default setting.

Did the data format change between versions, or is the old config just incompatible with the new firmware? Is it safe to expect that future firmware updates will import previous config files? Did anyone else experience this problem?

best regards, Artur

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
biraja Sat, 04/24/2010 - 21:32

Hi Artur,

This is a problem when switching from any version less than or equal to 1..0.39.

This is not seen when upgrading from 1.1.21 and in future, this will not be an issue.

Please see below text from the release note.

CAUTION If you are upgrading to this image from an earlier released image, the configuration

changes between these images are not compatible. You will have to reconfigure

the router following the upgrade.

NOTE When upgrading from version 1.0.15, 1.0.17, or 1.0.39, the firmware will reset the

router to its factory default and you will need to back up the configuration. When

upgrading from 1.1.21, these steps are not required.

Thanks,

Biraja