Multilink PPP No Ping

Answered Question
Apr 24th, 2010

                        Hello Guys,

                                        I setup a Multilink connection between 2 router but I can not ping between them. Do I need to provide a clock rate on the Serial interfaces of the Multilink interface or something? Please Advise??? The config for both routers are below.

hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
ip address 172.16.1.1 255.255.255.252
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/2
no ip address
shutdown
!
interface Serial0/3
no ip address
shutdown
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
ip address 172.16.1.2 255.255.255.252
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Serial0/2
no ip address
shutdown
!
interface Serial0/3
no ip address
shutdown
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

R1#sh int s0/0
Serial0/0 is up, line protocol is down
  Hardware is PowerQUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP REQsent, multilink Closed, loopback not set
  Keepalive set (10 sec)
  Last input 00:21:20, output 00:00:02, output hang never
  Last clearing of "show interface" counters 00:37:40
  Input queue: 103/75/152/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     225 packets input, 6810 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     479 packets output, 11971 bytes, 0 underruns
     0 output errors, 0 collisions, 71 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


R1#sh int s0/1
Serial0/1 is up, line protocol is down
  Hardware is PowerQUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Listen, multilink Closed, loopback not set
  Keepalive set (10 sec)
  Last input 00:21:51, output 00:00:06, output hang never
  Last clearing of "show interface" counters 00:38:10
  Input queue: 96/75/160/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     230 packets input, 6860 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     484 packets output, 12062 bytes, 0 underruns
     0 output errors, 0 collisions, 72 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#sh int multilink 1
Multilink1 is down, line protocol is down
  Hardware is multilink group interface
  Internet address is 172.16.1.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, multilink Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:38:40, output never, output hang never
  Last clearing of "show interface" counters 00:38:56
  Input queue: 28/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5 packets input, 52 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     34 packets output, 6156 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

R2#sh int s0/0
Serial0/0 is up, line protocol is down
  Hardware is PowerQUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Listen, multilink Closed, loopback not set
  Keepalive set (10 sec)
  Last input 00:23:12, output 00:00:04, output hang never
  Last clearing of "show interface" counters 00:39:27
  Input queue: 110/75/172/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     218 packets input, 6178 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     500 packets output, 13100 bytes, 0 underruns
     0 output errors, 0 collisions, 75 interface resets
     0 output buffer failures, 0 output buffers swapped out

R2#sh int s0/1
Serial0/1 is up, line protocol is down
  Hardware is PowerQUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP REQsent, multilink Closed, loopback not set
  Keepalive set (10 sec)
  Last input 00:24:24, output 00:00:01, output hang never
  Last clearing of "show interface" counters 00:40:37
  Input queue: 101/75/190/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     222 packets input, 6246 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     513 packets output, 13633 bytes, 0 underruns
     0 output errors, 0 collisions, 76 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2#sh int multilink1
Multilink1 is down, line protocol is down
  Hardware is multilink group interface
  Internet address is 172.16.1.2/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, multilink Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:40:52, output never, output hang never
  Last clearing of "show interface" counters 00:41:10
  Input queue: 28/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 38 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     34 packets output, 7632 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 7 months ago

Hello Ike,

you need to set the clock on the serial interfaces, the command is accepted on the DCE side of the cable and this can be checked with sh controller serial x/y.

A multilink bundle is an OSI layer 2 concept, giving a clock is OSI layer1 for synchronous serials where synchronous means both sides need a common clock to sample the rx stream.

When in a lab with back to back configuration we need to configure one router as OSI Layer 1 DCE with clock rate command command

Hope to help

Giuseppe

Correct Answer by Federico Coto F... about 6 years 7 months ago

Check which interface shows you as DCE.

sh controller multilink  -->  not sure if it works

sh controller serial

The thing is that you should provide the clock rate to the DCE side (being the multilink interface I think, but please verify with the above commands)

Otherwise, set the clock rate on the serial interfaces.

Federico.

Correct Answer by Federico Coto F... about 6 years 7 months ago

Hi,

If this is a real environment where your routers are connected to an ISP through a WAN, then your routers are DTE devices and therefore don't need a clockrate on the serial interfaces.

If this is a lab setup, then one end has to provide the clock rate which is the DCE.

You can check this with the ''sh controllers serialx/x'' command.

Federico.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Federico Coto F... Sat, 04/24/2010 - 09:23

Hi,

If this is a real environment where your routers are connected to an ISP through a WAN, then your routers are DTE devices and therefore don't need a clockrate on the serial interfaces.

If this is a lab setup, then one end has to provide the clock rate which is the DCE.

You can check this with the ''sh controllers serialx/x'' command.

Federico.

Charlie Mayes Sat, 04/24/2010 - 09:47

                            This is a lab and I am not sure if I need to put the clock rate on the Multilink interface or the Serial Interface? Which one do I set the Clock rate one?

Correct Answer
Federico Coto F... Sat, 04/24/2010 - 09:50

Check which interface shows you as DCE.

sh controller multilink  -->  not sure if it works

sh controller serial

The thing is that you should provide the clock rate to the DCE side (being the multilink interface I think, but please verify with the above commands)

Otherwise, set the clock rate on the serial interfaces.

Federico.

Correct Answer
Giuseppe Larosa Sat, 04/24/2010 - 15:07

Hello Ike,

you need to set the clock on the serial interfaces, the command is accepted on the DCE side of the cable and this can be checked with sh controller serial x/y.

A multilink bundle is an OSI layer 2 concept, giving a clock is OSI layer1 for synchronous serials where synchronous means both sides need a common clock to sample the rx stream.

When in a lab with back to back configuration we need to configure one router as OSI Layer 1 DCE with clock rate command command

Hope to help

Giuseppe

Charlie Mayes Sat, 04/24/2010 - 17:36

                       Thank you so much. Everything you said was exactly right. The GNS3 emulation software I was using was faulty. I decided to stop being lazy and connect my real routers and everything I had done worked perfectly.

Federico Coto F... Sat, 04/24/2010 - 17:40

You are correct.

I have noticed that using GNS3, there is no need to specify the clock rate command on the serial DCE interfaces.

On GNS3 you can connect two routers back-to-back and do not mind about the DTE-DCE relationship.

Obviously as you saw, this is not correct with real equipment.

Federico.

Actions

This Discussion

Related Content