Cisco 7937G Phone not Registering

Answered Question
Apr 26th, 2010

My cisco 7939 phone is not registering on my CUCM6.0.1, I have installed the device update for 6.0 and the lastest device firmware for 7937G yet, i cannot find the new firmware in the firmware load information and the device default/phone button template for 7937G is also not available.

The implication of this is that the phone is not registering even when it eventually get registered with my SRST Router i cannot use it for voice conferencing because i dont have a suitable phone template fot it.

Any suggestion on way forward will be appreciated.

Regards,

I have this problem too.
0 votes
Correct Answer by rob.huffman about 6 years 9 months ago

Hi there,

The  7937G is supported in CCM 6.0(1) with the Device Pack  (cmterm-devicepack6.0.1.2111-1 or later ) listed below. Once these upgrades are done the  7937 will be added to the available "Add a new Phone" selections (and  Device Defaults Page). Don't forget that when installing a new Device pack a cluster-wide reboot is required

Compatible Cisco Unified CallManager Release -  7937G

4.1(3)SR5

ciscocm.4-1-DevPack-59  or later

4.2(3)SR2

ciscocm.4-2-3-DevPack-36 or later

4.3(1)

ciscocm.4-3-1-DevPack-16  or later

5.1(2)

cmterm-devicepack5.1.2.3111-1 or later

5.1(3)

cmterm-devicepack5.1.3.1104  or later

6.0(1)

cmterm-devicepack6.0.1.2111-1 or later

6.1

No device pack  required, native support

From the Cisco Unified IP Conference Station 7937G  Firmware Version 1.1(1) - ReadMe;

http://download-sj.cisco.com/cisco/voice/ip-7900ser/cmterm-7937-sccp.1-1-1-readme.htm

Hope  this helps!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
rob.huffman Mon, 04/26/2010 - 05:39

Hi there,

The  7937G is supported in CCM 6.0(1) with the Device Pack  (cmterm-devicepack6.0.1.2111-1 or later ) listed below. Once these upgrades are done the  7937 will be added to the available "Add a new Phone" selections (and  Device Defaults Page). Don't forget that when installing a new Device pack a cluster-wide reboot is required

Compatible Cisco Unified CallManager Release -  7937G

4.1(3)SR5

ciscocm.4-1-DevPack-59  or later

4.2(3)SR2

ciscocm.4-2-3-DevPack-36 or later

4.3(1)

ciscocm.4-3-1-DevPack-16  or later

5.1(2)

cmterm-devicepack5.1.2.3111-1 or later

5.1(3)

cmterm-devicepack5.1.3.1104  or later

6.0(1)

cmterm-devicepack6.0.1.2111-1 or later

6.1

No device pack  required, native support

From the Cisco Unified IP Conference Station 7937G  Firmware Version 1.1(1) - ReadMe;

http://download-sj.cisco.com/cisco/voice/ip-7900ser/cmterm-7937-sccp.1-1-1-readme.htm

Hope  this helps!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

mcoroghidaf Tue, 04/27/2010 - 00:08

Hi,

I had to go for a lower version of the device upgrade pack and after that the phones registered.

i now noticed another issue they now switch between my SRST Router and CUCM!

any idea how to solve this?

any response will be appreciated.

Regards,

Dafe Oroghi.

Amol Mittal Tue, 04/27/2010 - 01:06

Kindly ensure that Cisco 7937 registers in access VLAN unlike all other Cisco phones which register in voice VLAN. If you have configured the corresponding switchport in voice vlan, configure it in access vlan.

HTH

mcoroghidaf Tue, 04/27/2010 - 05:29

Hi,

I did a debug on the phone and dicovered that it is showing an error 'can't resolve 'server' name' so, what i did is to enter the server name in the url and after that all the 7937G phones registered to the call manager.

Thanks for the contribution!

I most say i appreciate all the contributions.

regards,

dafe.

f.cestari Mon, 05/02/2011 - 18:15

Hi,

        i'm with the same issue. I verified the network configuration from IP Station and all IPs address (cm1, cm2, srst, ip, mask, default gatway, id vlan, tftp, dns1, dns2, domain name) are right. I would  to know wich server do you configured manualy.

Thank you.

mcoroghidaf Tue, 05/03/2011 - 06:13

Hi f.cestari,

The issues were much and its quite some time but the solution as far

as the 7937 phones were concerned are: 1. at some point the

callmanager does firmware doesnot have support for the model so we had

to download the image and upload it to the cm.

2. The IP address on one of the 7937 was conflicting with the SVI IP

address of the voice VLAN.

3. Misteriously one of the phones was not talking to the tftp server

configured in the option 150, so we had to manually configure the ip

address in the network settings of the CallManager.

I hope this will be helpful.

Dafe Oroghi.

Actions

This Discussion