CCM 4.2 DOES NOT CONVERT MOH FILE

Answered Question
Apr 26th, 2010
User Badges:

Hi,


I have a problem with the CCM, I have to load a new MoH file, but the CCM does not convert the .wav or .mp3 file to 6 files.


I drop the .wav file in C:\Program Files\Cisco\MOH\DropMOHAudioSourceFilesHere, and the system has to convert to 6 files in the directory:

C:\ProgramFiles\Cisco\TFTPPath\MOH,  but the system doesn´t make ths conversion.


I have restarted the Cisco MOH Audio Translator service and P Voice Media Streaming App service,  and the result is the same.


How can I resolve that problem?


Thanks,

Esteban

Correct Answer by Harmit Singh about 7 years 2 months ago

Hi Estaban,


Glad to hear that worked!


++     If you would like to configure the default user and network MOH to something else, then go to "Service Parameters" again --> Choose the Publisher and "Cisco CallManager" --> Scroll down to "Clusterwise Parameters" --> Change the "Default Network Hold MOH Audio Source ID" and "Default User Hold MOH Audio Source ID" from 1 to the source ID that you want should play.


++     If you would like to configure the user and network MOH for a device pool, it's no longer how it used to be under Device Pool. On all phone configuration pages. The "Network Hold MOH Audio Source ID" and "User Hold MOH  Audio Source ID" settings along with some other have been moved under "Common Device Configuration". In order to configure this, go to Device --> Device Settings --> Common Device Configuration. Make different profiles there and apply them to all phones in different device pools with the help of BAT.


If this helps, please rate.


--

Harmit.

Correct Answer by Harmit Singh about 7 years 2 months ago

Hi Esteban,


Try the following:


++     Go to "Service Parameters" on the CUCM Admin Page.

++     Select the Server as the Publisher and Service as "Cisco IP Voice Media Streaming App".

++     For "Supported MOH Codecs", select all the codecs listed there and hit save.


Test it and let me know how it goes. HTH.


--

Harmit.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Robert Thomas Mon, 04/26/2010 - 09:25
User Badges:
  • Silver, 250 points or more

Esteban,


Please make sure you are copy and pasting the files into the folder. If you drag and drop them, the audio translator service will not detect and translate them.


Cheers,

Esteban Jimenez... Tue, 04/27/2010 - 09:20
User Badges:

Hi,


I have done copy paste of the file and now all it is OK.


Thank you very much for all.


Regards,

Esteban

Esteban Jimenez... Fri, 04/30/2010 - 03:40
User Badges:

Hi,


Thansk for your help. The audio translation service has done correctly the translate of the file in the differents formats. Now in the device I can select the MoH of this file, but when I prove it we don´t listen nothing. If I select other MoH file I can listen it.

Which could be the problem?


Thanks,


Regards,

Esteban

Correct Answer
Harmit Singh Sat, 05/01/2010 - 01:18
User Badges:
  • Cisco Employee,

Hi Esteban,


Try the following:


++     Go to "Service Parameters" on the CUCM Admin Page.

++     Select the Server as the Publisher and Service as "Cisco IP Voice Media Streaming App".

++     For "Supported MOH Codecs", select all the codecs listed there and hit save.


Test it and let me know how it goes. HTH.


--

Harmit.

Esteban Jimenez... Tue, 05/04/2010 - 05:49
User Badges:

Hi,


I make that you told me and now it is working OK.

Thank you very much for your help.


If I select the MoH in a device works OK, but now the customer wants to change the MoH in all the phones of the system. I thought that in the Device Pool configuration I could change it, but there is not a parametre for to make it. I have been searching in cisco documentation but I haven´t found nothing for to make a change in the system.


By default the system has a MoH, where can I configure it??


Thanks one more time.


Regards,

Esteban

Correct Answer
Harmit Singh Tue, 05/04/2010 - 06:17
User Badges:
  • Cisco Employee,

Hi Estaban,


Glad to hear that worked!


++     If you would like to configure the default user and network MOH to something else, then go to "Service Parameters" again --> Choose the Publisher and "Cisco CallManager" --> Scroll down to "Clusterwise Parameters" --> Change the "Default Network Hold MOH Audio Source ID" and "Default User Hold MOH Audio Source ID" from 1 to the source ID that you want should play.


++     If you would like to configure the user and network MOH for a device pool, it's no longer how it used to be under Device Pool. On all phone configuration pages. The "Network Hold MOH Audio Source ID" and "User Hold MOH  Audio Source ID" settings along with some other have been moved under "Common Device Configuration". In order to configure this, go to Device --> Device Settings --> Common Device Configuration. Make different profiles there and apply them to all phones in different device pools with the help of BAT.


If this helps, please rate.


--

Harmit.

Esteban Jimenez... Tue, 05/04/2010 - 09:18
User Badges:

Hi Harmit,


I have done the changes in Sevice Parametres and is working OK. I have test it with the customer and it is ok.


It has been fine work with you.


Thank you very much for all.


Regards

Esteban

Actions

This Discussion