SPA9000 - Only dials first 6 digits then strips the remaining 3 digits

Unanswered Question
Apr 26th, 2010

I'm trying to set up a the spa9000 using the wizzard, but after completing the set the phone system will only dial the first few digits and then strip off the remaining ones. if using an analogue phone it just times out and doesnt work, when using a spa942 or spa944 it will change the prompt on the lcd screen to say that I need to enter more digits, if I then enter them a second time and press the dial button it will dial out then. Very annoying and not really possible to install it for our customer like this.

Any help would be appreacaited.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
icastrov Tue, 04/27/2010 - 01:46


what have you set in the outbound call routing screen in the Wizard? also, what's the dial plan you've set in the phones through the localization screen?



wild_qwerty Tue, 04/27/2010 - 13:28

We pretty much left most of the settings the default value except that we changed the regional settings to New Zealand. If I conect directly to the web interface of the spa900 here are the values

Call Routing Rule: (<:L1,2{1,2,3,4}>9xx.)

Phone Dial Plan: (<*97:vmm>|9xx|[2-9]xxxxxxS0|01xS0|111S0|0[3469] xxxxxxxS0|082210S0|0 [12578] x.S3|0800xxxxxxS0|0900xxxxxxS0|00xx.S3|)

I dial '9' to get an outside line, then a phone number, it only dials the first 6 digits of the number (7 digits if you cound the 9 to get out).

eg: 9 06 769 5341 becomes 9 06 7695

I've tried reseting the spa9000 to factory defaults upgraded the firmware (via the wizard) and re run the wizzard again.

icastrov Wed, 04/28/2010 - 03:30


Problem seems to be with the dial plan in the phones, please modify it as follows:

(<*97:vmm>|9xx|xxxxxxxxxS0|01xS0|111S0|0[3469] xxxxxxxS0|082210S0|0 x.S3|0800xxxxxxS0|0900xxxxxxS0|00xx.S3|xx.)




This Discussion