UCS Service profile error "Not enough vNICs available"

Unanswered Question
Apr 27th, 2010

Hi everybody,

when i finished to setup service profile i always get the same error:

Config failure

Associate state: unassociated

Assigne state: failed

Configuration error: Connection-placement
                            There are not enough resources overall
                            Not enough vNICs available

I got that error whith and without dynamique VNIC.

Is someone got an idea??

thanks

I have this problem too.
2 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Jeremy Waldrop Tue, 04/27/2010 - 03:25

If the profile has more than 2 vNICs and you are trying to associate the profile to a blade that doens't have Palo (UCS VIC M81KR) adapter it will fail. What adapter is in the blade and how many vNICs are defined in the service profile?

Jeremy Waldrop Tue, 04/27/2010 - 04:36

Maybe a hardware issue with blade you are trying to associate the profile with? Do you have another blade you can try? Go to the Equipment tab and make sure that blade has an adapter. I have seen cases where the adapter had to be reset before it was recognized.

RomainJean Tue, 04/27/2010 - 04:45

Actually i've got an issue with the DCE

Interface 1 of that blade, it is not connected to any FabricExtender (i/o mudule) and doesn't want to, even when i reset connectivity.

Maybe a hardware failure.

Thanks

Attachment: 
cpaggen Wed, 04/28/2010 - 11:54

If you have a M71 adapter ("Menlo") then make sure one vnic is "routed" to Fabric A and the other to Fabric B. This is a must for Menlo. Also by looking at the picture you attached make sure you default MAC address pool contains addresses.

RomainJean Thu, 04/29/2010 - 02:16

Hi Christopher,

  • The Blade was only connected to one I/O module. I couldn't change this connection.

Regarding this arcticle, this is the reason why the SP doesn't go active: "Unified Communications Virtualization Deployment Guide On UCS B-Series Blade Servers" (https://supportforums.cisco.com/docs/DOC-6158)

"This is important to note that a service profile that has two vNICs assigned would require a blade in a chassis with two IOMs connected to two fabric interconnects, and that service profile would fail to associate to a blade in a chassis with only a single IOM"

=> I resolved it by "Acknowledge chassis" in the chassis>genérale configuration. After it, the blade was connected with 2 I/O module.

  • About ServiceProfile Network Configuration.

=> I choose an expert configuration mode to add manually 2vNICS. MAC address is mapped with hardware default.

All works fine now !!

Thank you for your help.

I hope this discussion will help someone.

pauguo Tue, 01/11/2011 - 11:34

if you have Palo card with lots VNICs and still have the same issue, you might not have the enough links between IOM and FabricInterconnect, try this:

First of all you need 4 physical links between IOM and FabricIntercon.

then go to left pane -> Equipment tab -> equipment -> right pane -> policy

select "4-link"

right click on your Chassis on left pane (e.g. "chassis 1") and re-knowlege it.

error msg should go away.

sramappa Thu, 04/19/2012 - 02:21

Hi Romain JEAN,

UCS Service profile error "Not enough vNICs available"  Please check the Network settings of the Service profile, in that check the default path for vNIC1 & vNIC2. For each of the vNIC (in this case) Fabric Interconnect path should be different (check the attachment).

Edit the settings as above and associate it later....

vNIC.JPG

Thanks,

Suresh H R

Actions

Login or Register to take actions

This Discussion

Posted April 27, 2010 at 1:37 AM
Stats:
Replies:8 Avg. Rating:
Views:9263 Votes:2
Shares:0
Categories: General UCS Hardware
+

Related Content

Discussions Leaderboard