Fail to generate EoL/EoS Hardware Report

Answered Question
Apr 27th, 2010

Hi All,

I tried to generate EoL/EoS Hardware Report through RME Report Generator. Even with correct cisco.com user name and password and correct proxy server configuration. It just keeps telling me it can't get data from cisco.com. I configured proxy server and port used in Common Service/Security. I tried to check the update for software to verify the proxy setting is correct. It didn't return any error. So the proxy setting has no problem.

Is there anything I missed? Thanks a lot!

Lou

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 8 months ago

Yes, but that is due to a bug I forgot to mention in the doc which is CSCta76147.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
hxmengmetro Tue, 04/27/2010 - 07:39

We are using proxy server to access cisco.com. So that means I need wait until the summer to get the patch for this issue, right?

Thanks a lot!

Joe Clarke Thu, 04/29/2010 - 00:14

Actually, it appears the patches mentioned in my doc do fix the two proxy bugs (despite the lack of documentation to that effect).  I am confirming with development, but if you haven't already downloaded, and installed the patch, go ahead and do so.

hxmengmetro Thu, 04/29/2010 - 05:58

Thanks Joe. I'm applying the patch now. See what will happen. The stopping process is too slow.

hxmengmetro Thu, 04/29/2010 - 06:12

After I successfully apply 4.30 patch to my ciscoworks. I restarted the server and then I got the below error when I tried to access the ciscoworks webpage. Is the patch still doing something? I restarted the daemon manager. It didn't help.

503 Service Temporarily Unavailable

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance  downtime or capacity problems. Please try again later.

Joe Clarke Thu, 04/29/2010 - 12:51

That doesn't make sense.  The patch would not affect the core services unless something catastrophic happened.  After restarting Daemon Manager, post the output of the pdshow command when it finally returns the process list.

hxmengmetro Thu, 04/29/2010 - 13:09

Never mind. That is only slowness. I need wait for some time until the system fully works. I just checked the EoL report. It still doesn't work and tell me the same reason "Unable to get data from Cisco.com. Check Cisco.com connectivity. Try again later". It seems the patch doesn't fix the problem.

Joe Clarke Thu, 04/29/2010 - 15:49

Post the invreports.log and the job log (from the job subdirectory under NMSROOT/files/rme/jobs/inventory/reports/jobs) after running the report job.

Joe Clarke Fri, 04/30/2010 - 11:01

This looks like a database issue.  Enable Inventory Reports debugging under RME > Admin > System Preferences > Application Loglevel Settings, then reproduce the problem, and repost the invreports.log.

Joe Clarke Fri, 04/30/2010 - 15:02

This is showing a connection refused error.  It looks like your proxy is being configured, but there may still be an issue there.  First, make sure that the proxy server settings are 10.1.1.87:8080.  Then, get a sniffer trace of all TCP traffic from the LMS server while running the EOX report.  Post the sniffer trace file when the job fails.

hxmengmetro Tue, 05/04/2010 - 13:46

Sorry for the late. I was able to capture the trace yesterday. Trace file attached.

Thanks. I see the cookie setup thing from the proxy server.

Attachment: 
Joe Clarke Tue, 05/04/2010 - 23:22

I have been doing some testing locally, and found that proxy support is, in fact, still broken.  The PSIRT/EoX code will still attempt to make a direct connection to Cisco.com to download a PSIRT_EOX.properties file.  We are investigating this currently.

hxmengmetro Mon, 11/15/2010 - 14:44

Hi Joe,

We don't need proxy to go to the internet right now. So the job to create a EoS report succeeded. But the attached pdf file doesn't have any record about EoS or EoL. I'm sure some devices in our network are pretty old which should be listed in the report. Do you any thought about this blank report?

Thanks.

Lou

Joe Clarke Mon, 11/15/2010 - 23:10

You should first download the latest copy of the patch as there were some more fixes rolled in.  Next, if you have RME < 4.3 you may be seeing CSCsz19286.  If you are affected by that bug, running the report on a subset devices will download only a subset of the data.  A new copy of the data (for newer devices) will not happen until the timer pops.  The workaround is to wait for the download timer to pop to make sure the full set of EoX data is downloaded.  Alternatively, you can use the offline data files.

http://cdetsweb-prd.cisco.com/apps/goto?identifier=CSCsz19286

Joe Clarke Thu, 12/16/2010 - 14:28

You'll want to update to RME 4.3.1 first.  RME 4.3.1 can be downloaded from Common Services > Software Center > Software Update.

hxmengmetro Thu, 12/16/2010 - 14:48

I tried again but Ciscoworks told me there is no update for the product I selected.

Is there any other way to do that? My LMS version is 3.2. Thanks a lot for your help!

lo.mueller Thu, 04/29/2010 - 22:57
Joe Clarke Thu, 04/29/2010 - 23:00

The files were supposed to be updated every two weeks.  I'll check with development as to why they weren't updated last week.

Actions

This Discussion