Passing ICM Call Variable info to CAD not working

Unanswered Question
Apr 27th, 2010


we are running UCCE 7.2(7) with CAD 7.2(1) SR2 and we seem to be having an issue with the ICM Call Variable information being populated in the CAD.

Up until now, it's been working fine. We have our ICM scripts set ICM Call Variables 1, 2 and 3 and they all appear in the CAD when a call goes to an agent. But, just this morning, I added a new DN, mapped it to a scheduled script, and within that script I set that new DN (just like I've been doing with all the rest so far), set a Call Type, then call 'Go To Script' which is the actual script to handle that specific call.

Dialling that DN plays the correct script, and going into the Sales queue sends me to that agent, but no ICM Call Variable info is showing up.

So far this has been working, but now that I've added a new line, it appears to have stopped, but just for this new line, it still appears to be working for all existing lines.

Any ideas anyone?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
david.macias Tue, 04/27/2010 - 07:51

Make sure you didn't point to another script and make sure the script you intend to run is actually scheduled during that time.  To remove all doubt you could point the new DN to a working call type and test it to try and figure out where the error might be.


JoeMattia Tue, 04/27/2010 - 09:27

I just tried pointing the new DN to another working script, and the ICM Call vars for that working script do not show up now either, but they do if I dial the original DN which calls that same script. Gets confusing doesn't it?

I did come accross this issue in the past, and the way I got around it was to create a new scheduled script which contained a new set of DNs. Once I did that and tested out the new scripts, they all worked ok with the appropriate ICM Call Variables showing up in CAD.

But, unfortunatly I just tried that now as well, and that didn't resolve this.

Do you think we're hitting some type of ICM node limit or something? If so, how can I check?

david.macias Tue, 04/27/2010 - 10:35


Can you try to log in with a CTIOS desktop, NOT CAD?  And see if the same thing happens?  This is very strange and had never heard of anything like it.


JoeMattia Tue, 04/27/2010 - 11:08

Hello David, I've tried using CAD-BE and I get the same results, but I'm not familiar with CTIOS Desktop. Where do I find the executable to run that? Is it automatically installed on the PG server when CAD Services are installed?

david.macias Tue, 04/27/2010 - 11:53


So, we might be going at this the wrong way.  If you want to get your hands dirty you can look at the pg logs to see if the variables are being set and passed on to CTI.  The CTIOS desktop comes in the same CD as the CTIOS server.


JoeMattia Tue, 04/27/2010 - 12:18

Great, I did not know that. I just installed CTIOS Desktop and logged in and the ICM Call Variables 1, 2 and 3 DO in fact show up when running that app, but not when I run CAD.

Does that help in identifying why this is happening? I'll take a look at the PG logs now and see what they show. I'll update this post with the results.

david.macias Tue, 04/27/2010 - 12:32

Now we're getting somewhere, if you're getting the PVs in CTIOS, that means that the CTI server also sees them and should be passing them to CAD.  Think of CAD as CTIOS desktop on steroids.  So, now we need to find out if the PVs are getting to the desktop.  Can you look at the agent CAD logs and see if they are coming through?


PS: I was just thinking about the last time I touched CAD and it's been around 3 years, so please keep that in mind.

JoeMattia Tue, 04/27/2010 - 12:52

The varilables appear to be getting to CAD as per the log entry below:

04/27/10 15:44:29.781  4328  agent  Thd( 264)  CCtiOsSession::OnEvent, (PeripheralID:5006 PeripheralType:23
  ConnectionCallID:33579270 CallType:1 ServiceNumber:5005 ServiceID:5006
  SkillGroupID:5221 SkillGroupPriority:0 NumNamedVariables:2 NumNamedArrays:0
  CampaignID:-1 QueryRuleID:-1 ANI:7700 DNIS:2459 DialedNumber:2459
  CallVariable1:ZP15 TMX Web CallVariable2:CARP_Sales_P50Group
  CallVariable3:Sales RouterCallKeyDay:149500 RouterCallKeyCallID:4564
  EnablementMask:0x3f0001 DeviceID:4342 UniqueObjectID:call.5006.33579270.4342
  CallStatus:2 MessageID:eCallDataUpdateEvent ecc:(user.BargeInVar:N
  CTIClientTimestamp:1272397468)) ICMEnterpriseUniqueID:icm.149500.4564

BUT, they are still not showing up on the CAD display

Unlike David, I work with CAD all the time - although it's a love-hate relationship.

What you need to do is configure a layout. You may use the default layout or define your own. Let's take baby steps and use the default.

Open Desktop Admin and go to Locations -> Call Center -> Enterprise Configuration -> Enterprise Data. Select the default layout from the Layout List and press Edit. Choose the fields you want from the RHS and slide them over to the left. Hit OK, then Apply.

But since it's not working on some and working on others I suggest you have a custom layout and you are failing to set it in your script. So it uses the default and you don't have PV1, PV2 and PV3 there.

Look at the scripts. Do a Find for "CADLayout"



JoeMattia Wed, 04/28/2010 - 08:22


we just have one Layout (default) listed in Enterprise Configuration - Enterprise Data in the Desktop Admin. The fields in this default Layout did not include any of the ICM Call Variables, so we added a few of them (that we set in ICM scripts). Up until now, these have been showing up in CAD when calls to skill groups come through. It's just now that I've added a new DN and ICM script, they are not showing up for that script only. The ICM Call Vars are working for all other DNs in the system, just not this new one.

Just to let you know, we upgraded ICM and CTIOS from 7.1(5) to 7.2(7) just recently, and with that we installed CAD 7.2(1) with SRs 1 and 2.

This is the 1'st time I've added a new line (DN) and ICM script to the system since that upgrade, so could that have something to do with this?

Also, there is a post where someone had this same issue ( and it was suggested that they shutdown and restart the CAD Services to resolve this.

My question is what services are in fact the CAD services? I would like to try that after hours tonight to see if that resolves this issue.

I verified via CAD that I'm running Build

Any other suggestions?


This is getting stranger all the time.

If you did not have any PVs in the default layout, and you have no other layout, I don't know how they were showing up in the first place.

Layout configuration is totally dynamic - you can define new layouts and add variables to layouts and press "Apply" and they work on the next call coming through, or close to it. That's my experience.

Nevertheless, you can stop and restart the CAD Services after hours. I assume you have a duplex install? To shut them all down, you would need to do both sides. You can see them all in services.msc

If you wanted an order to shutdown, I would probably choose:

Cisco Sync Service
Cisco Recording and Statistics Service – RASCAL
Cisco Browser and IPPA Service
Cisco Voip Monitoring Service
Cisco Chat
Cisco Enterprise
Cisco Licensing and Resource Manager Service
Cisco LDAP Monitor Service

But it doesn't matter much. Once they are all shutdown, clean out .log, .idx, .dbg files from Program Files\Cisco\Desktop\logs and start them up in the opposite order.

Just to be sure we are talking about the same thing, post a picture of CAD with the variables on display.



JoeMattia Thu, 04/29/2010 - 07:24

Geoff, David, great news.

I restarted our two duplexed PG servers running CAD Services after hours last night and that did the trick.

After re-testing that new DN this morning, all ICM Call Variables showed up in my CAD successfully.

For some reason, with all of my testing the last few days, the ICM system didn't seem to recognize that new DN that I had recently entered into the system, even though I saw no errors on the Loggers for that DN.

I even forced synchronization of the directory services via Desktop Admin several times yesterday hoping that would resolve it, but it did not.

Well, at least now I know what to do the next time this happens.

Thanks again for all of your suggestions and help with this, I truely appreciate it.



JoeMattia Thu, 04/29/2010 - 07:46

Here is a screen shot of what our agents would see with incoming calls.

We set ICM Variables 1, 2 and 3 in the ICM scripts so that they know which line the calls came in on, and we set other information such as if the caller chose either English or French, Sales or Service, etc.

David, I agree. If this does happen again, I will be opening up a ticket with TAC since it is very strange why this happens.



Somehow I misunderstood what you wrote when you said:

"we just have one Layout (default) listed in Enterprise Configuration - Enterprise Data in the Desktop Admin. The fields in this default Layout did not include any of the ICM Call Variables, so we added a few of them (that we set in ICM scripts). "

I misinterpreted that to mean you did not have these in the layout and just added them. On rereading I now understand that you did this some time back.



david.macias Thu, 04/29/2010 - 07:28


Glad to hear it's working, if it happens again I would open a TAC case as it doesn't seem to be normal behavior.



This Discussion