HSRP API active virtual address x.x.x.x not found

Answered Question
Apr 28th, 2010
User Badges:

I have the below two switches running HSRP on all vlans - sample of one of the vlans - others are configured in the same manner.

On the live network using Stack of 3750 switches, I turned on the 'debug standby events'  and I am getting the below messages of:-



003204: 35w5d: HSRP: Vl40 API active virtual address 10.10.40.56 not found

003205: 35w5d: HSRP: Vl70 API active virtual address 10.10.71.254 found

003206: 35w5d: HSRP: Vl40 API active virtual address 10.10.41.220 not found

003207: 35w5d: HSRP: Vl10 API active virtual address 10.10.10.10 found

003208: 35w5d: HSRP: Vl40 API active virtual address 10.10.41.247 not found

003209: 35w5d: HSRP: Vl50 API active virtual address 10.10.55.254 found

003210: 35w5d: HSRP: Vl40 API active virtual address 10.10.41.242 not found

003211: 35w5d: HSRP: Vl40 API active virtual address 10.10.40.56 not found

003212: 35w5d: HSRP: Vl50 API active virtual address 10.10.55.254 found

003213: 35w5d: HSRP: Vl30 API active virtual address 10.10.30.212 not found

003214: 35w5d: HSRP: Vl40 API active virtual address 10.10.41.216 not found

003215: 35w5d: HSRP: Vl10 API active virtual address 10.10.10.10 found

003216: 35w5d: HSRP: Vl40 API active virtual address 10.10.41.254 found

003217: 35w5d: HSRP: Vl40 API active virtual address 10.10.40.16 not found

003218: 35w5d: HSRP: Vl50 API active virtual address 10.10.55.254 found


further output ommitted...


extract of config



switch 1 - active



interface Vlan40

ip address 10.10.41.252 255.255.254.0

ip helper-address 10.10.10.8

ip helper-address 10.10.10.54

no ip redirects

no ip unreachables

no ip proxy-arp

standby 40 ip 10.10.41.254

standby 40 priority 255

standby 40 preempt



switch 2 - standby


interface Vlan40


ip address 10.10.41.253 255.255.254.0

ip helper-address 10.10.10.8

ip helper-address 10.10.10.54

no ip redirects

no ip unreachables

no ip proxy-arp

standby 40 ip 10.10.41.254

standby 40 priority 254


when I tried to replicate it in lab with 4506 and 4510 switches - the debug standby events does not generate any issues...


can someone pls help me understand what those messages are?

Correct Answer by jorge.calvo about 7 years 2 weeks ago

Hello,


That is an informational message only. In old IOS versions prior to 12.2, HSRP was a process belonging to IP Routing process. Beginning on 12.2 it is now a separate process. When it is needed, IP Routing queries HSRP process to check if the VIP is already in use by HSRP.


The message you receive is generated when IP Routing queries HSRP to check if the VIP is being used by it but it is not being used at the moment.


So, this is a normal situation that should not affect the network functionality.


Regards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
jorge.calvo Thu, 05/13/2010 - 07:39
User Badges:
  • Bronze, 100 points or more

Hello,


That is an informational message only. In old IOS versions prior to 12.2, HSRP was a process belonging to IP Routing process. Beginning on 12.2 it is now a separate process. When it is needed, IP Routing queries HSRP process to check if the VIP is already in use by HSRP.


The message you receive is generated when IP Routing queries HSRP to check if the VIP is being used by it but it is not being used at the moment.


So, this is a normal situation that should not affect the network functionality.


Regards.

Actions

This Discussion