Problem with SIP trunk outgoing

Unanswered Question
Apr 28th, 2010
User Badges:

Hi guys,

I'am using the UC540 and a 525G, i have configured the SIP trunk to call out, the problem is the trunk do not work. The status of the P-associated-URI is NO.

Here are the captures of my configuration. Any one can help me ? Thank you!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cisco_luo Wed, 04/28/2010 - 05:51
User Badges:

Here is the configuration text.

We have created the dial-plan incomming and outgoing.And we have tested the dial-plan( Troubleshoot--Telephony Diagnostic-Dial-plan Test) and it works.

But in the interface of SIP trunk status the value of the P-associated-URI is NO. I think is that cause the problem.

Attachment: 
Maulik Shah Wed, 04/28/2010 - 10:52
User Badges:
  • Silver, 250 points or more

The registered status is NO (not P-Associated URI) - couple of things I can think off


- Can you ping ippi.fr from the UC500?

- It looks like the firewall on the UC500 WAN interface does not have port 5060 opened for the SIP traffic (UDP port 5060) for IP address that ippi.fr resolves to (213.215.45.230). You can see this on CCA by going to Monitor > Firewall and look on the Access-list pane for access-list 104. There is no entry for the IP address for ippi.fr - this can happen if the SIP trunk config was applied when the UC500 had no access to a DNS server to resolve the DNS hostname for the SIP proxy / registrar server. Can you reapply the SIP trunk configuration (set SIP trunk to none and re configure) assuming you have internet connectivity?


By the way - do inbound calls work, I would guess not. One side note - if you can answer the below I can generate an XML file that you can upload into CCA which will you can use to configure the SIP trunk to IPPI instead of the Generic SIP trunk provider:


https://supportforums.cisco.com/docs/DOC-9685

cisco_luo Thu, 04/29/2010 - 01:33
User Badges:

Thank you very much for your answers!

-I can ping ippi.fr from UC540 ,also from the interface of the telephone IP before and after I setting the SIP Trunk as none .And before I disabing the SIP Trunk I find there is a port UDP 5060 opened for the SIP traffic.


Here are the captures from CCA.

bryan.neese Thu, 04/29/2010 - 10:29
User Badges:

I've found that CCA has had a mind-of-it's-own in configuring some of the Generic SIP trunks.  I've had a similar issue where I could recieve calls inbound, ping outbound, but not make an outbound call at all and my registar was broken.  What I finally found was that one of the access-lists was written incorrectly by CCA and I had to fix it in the CLI.  The incorrect was as follows:


access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL

access-list 2 remark SDM_ACL Category=1

access-list 2 permit 66.23.129.253

access-list 2 permit 192.168.10.1

access-list 2 permit 192.168.10.0 0.0.0.255

access-list 2 permit 10.1.1.0 0.0.0.255

access-list 2 permit 10.1.10.0 0.0.0.3

access-list 2 deny   any



Corrected, it looks like this:


access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL

access-list 2 remark SDM_ACL Category=1

access-list 2 permit 66.23.129.253 255.255.255.255

access-list 2 permit 192.168.10.1

access-list 2 permit 192.168.10.0 0.0.0.255

access-list 2 permit 10.1.1.0 0.0.0.255

access-list 2 permit 10.1.10.0 0.0.0.3

access-list 2 deny   any

It doesn't write the subnet mask for the IP address, so it still denies the connection.  I'd check that for your additional IP address that you're resolving to.