Configured a remote spanning session, but the spanning vlan is disabled. How can I enable it?

Unanswered Question
Apr 28th, 2010

I have trouble spanning traffic in my 6509

Here's my monitor configuration:

------------------------------------------------------------------

Session 2

---------
Type                   : Remote Source Session
Source Ports       :
    Both               : Gi1/1
Destination RSPAN VLAN : 83

------------------------------------------------------------------


and I assigned a trunk port at Gi2/1 allowing vlan 83 to another switch.Gi1/1 is up and has traffic going through. However, there's no traffic through Gi2/1 (up as well) at all.

It looks good. However, when I do show vlan id 83, the remote span vlan is shown disabled:

------------------------------------------------------------------------------------------------------------------------------------

show vlan id 83

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
83  RSPAN_VLAN03                     active    Gi2/1, Po1

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
83  enet  100083     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

------------------------------------------------------------------------------------------------------------------------------------

How come the remote span vlan is disabled? and how can I enable it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ganesh Hariharan Wed, 04/28/2010 - 23:22

I have trouble spanning traffic in my 6509

Here's my monitor configuration:

------------------------------------------------------------------

Session 2

---------
Type                   : Remote Source Session
Source Ports       :
    Both               : Gi1/1
Destination RSPAN VLAN : 83

------------------------------------------------------------------


and I assigned a trunk port at Gi2/1 allowing vlan 83 to another switch.Gi1/1 is up and has traffic going through. However, there's no traffic through Gi2/1 (up as well) at all.

It looks good. However, when I do show vlan id 83, the remote span vlan is shown disabled:

------------------------------------------------------------------------------------------------------------------------------------

show vlan id 83

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
83  RSPAN_VLAN03                     active    Gi2/1, Po1

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
83  enet  100083     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

------------------------------------------------------------------------------------------------------------------------------------

How come the remote span vlan is disabled? and how can I enable it?

Hi,

To configure an RSPAN source session, use the same session number for a source and a destination RSPAN VLAN and to configure an RSPAN destination session, use the same session number for a source RSPAN VLAN and a destination port.

Check out the below link for configuring RSPAN in 6500 series switches

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/span.html#wp1043258

Hope to Help !!

Ganesh.H

kahouwong Wed, 04/28/2010 - 23:30

remote spanning was configured correctly as follows

monitor session 1 source vlan 83
monitor session 1 destination interface Gi2/1

but no traffic was mirrored to the destination port

Ganesh Hariharan Thu, 04/29/2010 - 00:15

remote spanning was configured correctly as follows

monitor session 1 source vlan 83
monitor session 1 destination interface Gi2/1

but no traffic was mirrored to the destination port

Can you share the spanning configuration which you have configured in your switch.

Ganesh.H

jpijnaker Fri, 03/13/2015 - 07:35

You need to add the "remote-span" keyword with the vlan configuration of vlan 83.

Actions

This Discussion

Related Content