PBR Question

Unanswered Question
Apr 29th, 2010


I need to associate traffic in a particular VLAN to a certain default gateway.

All traffic on VLAN51 which is in the range (getting their IP Address from the domain controller dhcp) needs to go out a default gateway

I have associated a port on my switch to vlan51 but when I plug a laptop into it I am getting an IP Address of

I will attach my config and maybe someone can see what I have done wrong.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ozzyosbu1 Thu, 04/29/2010 - 07:20


You are getting IP address in the range because there is no DHCP server in VLAN 51 nor the DHCP requests are forwarded to any other DHCP server.

for the hosts in VLAN 51 to get an IP address via DHCP you need to have

1) a DHCP server in the same VLAN


2) have a router in the same VLAN, and an ip helper-adress configured on the routers interface. In addition there should be a DHCP scope defined in the DHCP server that is matching the routers interface IP subnet.

In your case I believe the DHCP server is in VLAN 1, and you are having a scope defined for the in it.

And you want the hosts in VLAN 51 also to share the same scope. but if you try to assign an IP address withing this range to your VLAN 51 interface, probably you will get an erro message saying that the subnet already overlaps with VLAN 1. So one option would be to split the scope to smaller ones, and then assign say for example to VLAN 51, to VLAN 1 etc..

Think over it and see what is most suitable for you.. Also did you turn on "ip routing"  on the 3750

Pronoy Dasgupta Thu, 04/29/2010 - 18:37

Ozzy is right here. You are getting the 169 addresses as part of APIPA... privately assigned IP addresses, and not getting any from the server.

I would presume that connectivity to the server has been established, right? If yes, you would need to take care of the subnetting part as again pointed out by Ozzy. In the midst of it all, do not forget to turn on "service dhcp" on the switch as well.




This Discussion

Related Content