IP Phone looking not finding CCUM

Answered Question
Apr 29th, 2010

Well this is an interesting one, I have a vmware CCUM v6 installed on  192.168.3.202 and I can browse to the web interface OK.

I have a  DHCP server set-up on my ACS server which is 192.168.3.201 which is  giving out both IP's for the Phones and my PC so that is working ok.

I  have set-up option 150 to point to my pc's TFTP server 192.168.3.150 so  I can see TFTP requests coming which is happening.

Problem is  that when I check on the IP phone under Device configuration Callmanager  configuration, call manager 1 is pointing to my tftp server of  192.168.3.150 instead of 192.168.3.202

Does anybody have any idea  why its picked that address up instead of the CCUM address?

Cheers

Martyn

I have this problem too.
0 votes
Correct Answer by dcarhart about 6 years 7 months ago

What was it the ip info on the ccm or the switch

Dave Carhart

On Apr 30, 2010, at 8:33 AM, "martynch1"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dcarhart Thu, 04/29/2010 - 12:09

hi I have a couple of questions.

Why are you using 192.168.3.150 for your TFTP server is this another Call Manager?

I would just turn the TFTP service on  you call manager 192.168.3.202 and then restart your phone

by giving it the DHCP  150 option you are basically telling the phone your call manager is the 3.150

martynch1 Thu, 04/29/2010 - 12:40

Thanks for the reply...

No 3.150 is no another call manager, I will turn on the tftp withing the call manager.

Do I still need the option 150 on the DHCP server?

Thanks again

Martyn

dcarhart Thu, 04/29/2010 - 12:49

Yes you will still need the option 150 in your scope.

Dave

martynch1 Thu, 04/29/2010 - 13:35

Looking back over the options I have tried that was one of them, I thought I had it wrong because my phone does not register.

I have the MAC address in call manager but it does not register, I dont get anything from the phone status apart from TFTP Timeout SEPconf.xml can not be found, the phone has the correct 10. ip address and is in the correct voice VLAN which is 3.

Any ideas what I should be checking to help me fault find?

Martyn

martynch1 Thu, 04/29/2010 - 14:22

OK from the call manager I try and ping 10.50.50.1 I get the following: -

PING 10.50.50.1 (10.50.50.1) 56(84) bytes of data.

--- 10.50.50.1 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

From my Switch I get: -

Switch#ping 10.50.50.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch#

Here is my switch config: -

interface FastEthernet0/15
description *****Call Manager*****
switchport mode access
spanning-tree portfast

interface FastEthernet0/33
description *****Martyn's IP Phone*****
switchport mode access
switchport voice vlan 3
spanning-tree portfast

interface Vlan1
description *****Data*****
ip address 192.168.3.250 255.255.255.0
ip helper-address 192.168.3.201
!
interface Vlan3
description *****Voice*****
ip address 10.50.50.250 255.255.255.0
ip helper-address 192.168.3.201

Hope you can help

Martyn

dcarhart Thu, 04/29/2010 - 18:20

Okay

I'm just going to think this one out loud so please bare with me

So I can ping the phone from the switch but not from the ccm

I first would double check the ccm's ip config to make sure I have the

subnet mask and gateway correct

Also double check the dhcp scopes to make sure your giving the right

gateway and subnet

Then if that is correct I would ping from the switch to the ccm using

the extended ping and the ips of the different vlans as the source

Based on what you said in the last email I'm expecting it to fail when

you put the ip of vlan 3 as your source.

If it fails you have a routing issue on your switch with the vlans and

You need to make sure you have layer 3 routing enabled on the switch

just make sure you have ip routing enabled. On the switch this will

correct that layer 3 issue

Dave Carhart

On Apr 29, 2010, at 5:22 PM, "martynch1"

dcarhart Thu, 04/29/2010 - 18:24

Also on vlan 1 you don't need the helper address on the vlan the dchp

server is in that vlan so you don't have to worry about the broad

casts not making it to the users

Dave Carhart

On Apr 29, 2010, at 5:22 PM, "martynch1"

martynch1 Fri, 04/30/2010 - 05:33

Thanks Dave... Corrected

interface Vlan1
description *****Data*****
ip address 192.168.3.250 255.255.255.0

The post before that.

So  I can ping the phone from the switch but not from the ccm

I first  would double check the ccm's ip config to make sure I have the 

subnet  mask and gateway correct

192.168.3.202

255.255.255.0

192.168.3.254

Also double check the dhcp scopes to make sure  your giving the right 

gateway and subnet

PC Pool

192.168.3.150 - 192.168.3.250

Router 192.168.3.254

Phone Pool

10.50.50.1 - 10.50.50.50

Router 10.50.50.1250

Option 150 192.168.3.202

Then if that  is correct I would ping from the switch to the ccm using 

the  extended ping and the ips of the different vlans as the source

Based on  what you said in the last email I'm expecting it to fail when 

you  put the ip of vlan 3 as your source.

Yes that fails as you thought

If it fails you have a routing issue  on your switch with the vlans and 

You need to make sure you  have layer 3 routing enabled on the switch 

just make sure you  have ip routing enabled. On the switch this will 

correct that  layer 3 issue

Here is my full config, wll not full I'm not listing out all the SwitchPorts

no aaa new-model
vtp domain VTP1
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!        
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 3
name voice-vlan
!
interface FastEthernet0/15
description *****Call Manager*****
switchport mode access
spanning-tree portfast
!
!
interface Vlan1
description *****Data*****
ip address 192.168.3.250 255.255.255.0
!
interface Vlan3
description *****Voice*****
ip address 10.50.50.250 255.255.255.0
ip helper-address 192.168.3.201
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.254
ip http server
!
!
control-plane

My LAN looks connects like the following: -

Cable Modem > ASA (192.168.3.254) > Switch (192.168.3.250) > LAN

Thanks for your continued support.

Correct Answer
dcarhart Fri, 04/30/2010 - 05:44

What was it the ip info on the ccm or the switch

Dave Carhart

On Apr 30, 2010, at 8:33 AM, "martynch1"

martynch1 Fri, 04/30/2010 - 05:51

No, Not working yet, I was just responding to your last post with regards to the IP Helper... I hit reply after instead of continuing the post.

martynch1 Mon, 05/03/2010 - 08:05

Hi Dave, CM default gateway address pointed to my ASA, once I changed

it to the Switch all worked after that.

Cheers Dave for all your help.

Martyn

dcarhart Mon, 05/03/2010 - 11:37

That's great I'm glad it was something simple trying to figure out the

switch end can be a nightmare sometimes

Dave Carhart

On May 3, 2010, at 11:05 AM, "martynch1"

Actions

This Discussion