Connecting Nexus 5000 to VSS

Unanswered Question
Apr 29th, 2010

Hi there.

We use a Catalyst 6500 VSS System as CORE and Nexus 5010 in the Access Layer. (no aggregation layer). So both System can made Port-Channel spanned over two Chassis.

This is the actual Design. Each link is 10G. The speciality is, we only use one Uplink per N5k because we don't need more Bandwith at the moment and we have the redundancy. The VSS System is the STP Root Bridge.

VSS_N5k_Design.jpg

Problem: Reloading Nx1 causes Nx2 to Block the wrong Port when the Nx1 comes up. The Nx2 Spanning Tree bridge assurance blocks the Port marked with a red 'X' for about 30 seconds. This is a real Problem because the Nx1 is not fully ready to this time and so the Systems loose connectivity for 30 seconds. Too long!

The Problem is _not_ to the time when Nx1 is shut down, it is when Nx1 has finished booting and takes the Switchports up.

Nx2 Syslogs:

: 2010 Apr 29 15:40:36 CET: %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port port-channel1  VLAN0109.

: 2010 Apr 29 15:41:11 CET: %STP-2-BRIDGE_ASSURANCE_UNBLOCK: Bridge Assurance unblocking port port-channel1  VLAN0009.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Ganesh Hariharan Fri, 04/30/2010 - 01:19

Hi there.

We use a Catalyst 6500 VSS System as CORE and Nexus 5010 in the Access Layer. (no aggregation layer). So both System can made Port-Channel spanned over two Chassis.

This is the actual Design. Each link is 10G. The speciality is, we only use one Uplink per N5k because we don't need more Bandwith at the moment and we have the redundancy. The VSS System is the STP Root Bridge.

Problem: Reloading Nx1 causes Nx2 to Block the wrong Port when the Nx1 comes up. The Nx2 Spanning Tree bridge assurance blocks the Port marked with a red 'X' for about 30 seconds. This is a real Problem because the Nx1 is not fully ready to this time and so the Systems loose connectivity for 30 seconds. Too long!

The Problem is _not_ to the time when Nx1 is shut down, it is when Nx1 has finished booting and takes the Switchports up.

Nx2 Syslogs:

: 2010 Apr 29 15:40:36 CET: %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port port-channel1  VLAN0109.

: 2010 Apr 29 15:41:11 CET: %STP-2-BRIDGE_ASSURANCE_UNBLOCK: Bridge Assurance unblocking port port-channel1  VLAN0009.

Hi,


Configure NX2 port pirorty high compare to NX1 so that port connected with NX2 will be in forward state rather in blocking.

check out the below link for the same

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/SpanningEnhanced.html

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/MST.html

Hope to help !!

Ganesh.H

Remember to rate the helpful post

Philip Bachmann Fri, 04/30/2010 - 08:13

Thank you for the hint.

We changed the port-priority by changing the cables. Now the uplink to VSS from Nexus is on Port Et1/17 (Po1) and the vPC peer-link is on Ports Et1/19-20 (Po15).

There is no longer a Spanning Tree event when reloading one Nexus Switch. I'm not sure if this was really a problem of the port-priority, it could also be a Bug - because the vpc-peer-links shouldn't participating in STP.

Actions

This Discussion

Related Content