router to switch connectivity

Unanswered Question
Apr 30th, 2010


Here is my L3 switch configuration,


interface FastEthernet0/24

no switchport

ip address 10.99.17.198 255.255.255.252

ip access-group cdrwest in


interface Vlan1

ip address 10.97.112.5 255.255.240.0

!

ip classless

ip route 10.99.0.0 255.255.0.0 10.99.17.197

ip http server

!


ip access-list extended Allow7609

permit ip any any


& what configuration on 7609 Router 1/48 has to be given so that

i can reach their net work 10.97.112.0 Network




& in ospf &Bgp acl i have given as below


router ospf 100

router-id 10.99.1.x

network 10.97.112.0 0.0.15.255 area 0

ip access-list standard bgp-out

permit 10.97.112.0 0.0.15.255




But finally i couldnt reach the network 10.97.112.112, what could

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 04/30/2010 - 08:20

On the 7609 just have a static route such as:



ip route 10.97.112.0 255.255.240.0 10.99.17.198


Then redistribute this static route into BGP or OSPF for upsteam route distribution.


Regards

anandkumar.cisco Sat, 05/01/2010 - 07:18
I have added the route &
Permitted the Redistribution of Static subnets in Ospf & Bgp
Debug Output of Switch is as below
3550_SWITCH#ping 10.99.1.14
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.99.1.14, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
3550_SWITCH#
2d20h: %SYS-3-LOGGER_DROPPED: System dropped 716 console debug messages.
2d20h: datagramsize=96, IP 18187: s=10.97.114.3 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
2d20h: datagramsize=96, IP 19511: s=10.97.119.3 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
2d20h: datagramsize=96, IP 19512: s=10.97.119.3 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
2d20h: datagramsize=96, IP 18188: s=10.97.114.3 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
2d20h: datagramsize=96, IP 1142: s=10.97.116.5 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
2d20h: datagramsize=96, IP 19566: s=10.97.119.3 (Vlan1), d=10.97.127.255, totlen
78, fragment 0, fo 0, rcvd 1
debug output of Router is like below ( where 10.193.222.137 is PC s IP)
2323821: *May  1 13:00:13.008 GMT: IP: tableid=0, s=10.99.1.14 (local), d=10.193
.222.137 (POS2/2/0), routed via FIB
2323822: *May  1 13:00:13.008 GMT: IP: s=10.99.1.14 (local), d=10.193.222.137 (P
OS2/2/0), len 600, output feature, HW Shortcut Installation(63), rtype 1, forus
FALSE, sendself FALSE, mtu 0
2323823: *May  1 13:00:13.008 GMT: IP: s=10.99.1.14 (local), d=10.193.222.137 (P
OS2/2/0), len 600, post-encap feature, HW Shortcut Installation(15), rtype 1, fo
rus FALSE, sendself FALSE, mtu 0
2323824: *May  1 13:00:13.012 GMT: IP: tableid=0, s=10.99.1.14 (local), d=10.193
.222.137 (POS2/2/0), routed via FIB
2323825: *May  1 13:00:13.012 GMT: IP: s=10.99.1.14 (local), d=10.193.222.137 (P
OS2/2/0), len 600, output feature, HW Shortcut Installation(63), rtype 1, forus
FALSE, sendself FALSE, mtu 0
Edison Ortiz Tue, 05/04/2010 - 08:31

Please post the show ip route from all devices in the transit path along with information regarding the source and destination subnets.

Actions

This Discussion