STP Looping issue

Answered Question

Hi

I am troubleshooting a STP looping issue with a iSCSI SAN environment, many servers in the

server farm share the SAN through both SAN side switches (see the diagram attached), I am a cisco guy and these SAN side switches are Procurve, but all flat lan.


Customer think 192.168.130.0/24 and 192.168.131.0/24 lan segments are will not talk to each other.


I think the link between the switches are the issue, but they need that for redundancy isn't it. How can I prevent looping and keep the interswitch link.


or any other solution.

Correct Answer by Reza Sharifi about 6 years 12 months ago

Hi,


You only have one connection between the 2 switches and that should not cause any loop.  Is there a way you can create a vlan on both HP switches and put all the ports in it and see if the problem goes away?

Sorry, not familiar with HP switches.


HTH

Reza

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Reza Sharifi Fri, 04/30/2010 - 19:44
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


Can you explain what the issue is?

What type of Cisco switches you are using and which once are they in your diagram.


Reza

Hi, Thanks for reply


These are HP Procurve switchws, but I am a Cisco guy, both switches in the midle are in question, they are FLAT lan no VLANS. Time to time ports are blocked by STP, and then unblock again. I am wondering the link between two switches are the issue, but I was told they need that for redundancy.


How to get out of the STP blocking issue, Or is there any better design,


MOre or less if I remove the interswitch link problem solved I beleive, but I loose the redundancy isnt it.


Regards

Correct Answer
Reza Sharifi Fri, 04/30/2010 - 20:41
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


You only have one connection between the 2 switches and that should not cause any loop.  Is there a way you can create a vlan on both HP switches and put all the ports in it and see if the problem goes away?

Sorry, not familiar with HP switches.


HTH

Reza

Actions

This Discussion

Related Content