Looped fibre interface showing as ISL trunk

Unanswered Question
Apr 21st, 2010

Hi all,

i have layer 3 switch connected to layer 2 switch .

Layer 3 ports gi 01 and gi02  have gbics and fibre

here is config of ports of layer 2

3548XL#sh run int gi0/1
Building configuration...

Current configuration:
!
interface GigabitEthernet0/1
switchport access vlan 30
end

3548XL#sh int gi0/1
GigabitEthernet0/1 is down, line protocol is down
  Hardware is Gigabit Ethernet, address is 0003.6b7b.5a31 (bia 0003.6b7b.5a31)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex , 1000Mb/s, media type is SX
  output flow-control is off, input flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     7 packets input, 448 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     7 packets output, 448 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
3548XL#

Layer 3 port status

3550SMI# sh run int gi0/1
Building configuration...

Current configuration : 98 bytes
!
interface GigabitEthernet0/1
switchport access vlan 30
switchport mode dynamic desirable
end

3550SMI#sh int gi0/1
GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 000d.28bc.fd99 (bia 000d.28bc.fd99)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX
  input flow-control is off, output flow-control is desired
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
3550SMI#

there is no lights on gbic ports?

any ideas?

thanks

mahesh

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
p.mcgowan Wed, 04/21/2010 - 08:50

looks like a physical problem to me, have you crossed the fibres?

is there a fibre run beween the switches or are they directly connected via fibre patch cable?

have you replaced the fibre patch cable?

mahesh18 Wed, 04/21/2010 - 08:57

Hi

Thanks for reply.

fibre has two ends each end is labelled   as  B  A

B is red

A is blue.

They are directly connected.Ho can i cross them?

what i can check next?

thanks

mahesh

p.mcgowan Thu, 04/22/2010 - 01:29

Hi Mahesh,

the A and B end of the fibre must be crossed so that in switch 1 fibre A is in the left port of the fibre module and fibre B is in the right port.

On the second switch you must do the opposite, fibre B should be in the left port and fibre A should be in the right.

Switch 1 |_A__| |__B__|

Switch 2 |_B__| |__A__|

mahesh18 Thu, 04/22/2010 - 15:04

Hi

Thanks for reply i tried the way  u mentioned  but no lights on fibre ports

Light only comes when i restart the switch on gbic ports then light comes and go  so this indicates that GBIC  are ok and cable might be faulty?

anyother idea

thanks

mahesh

p.mcgowan Fri, 04/23/2010 - 01:28

you could loop the fibre onto the GBIC to test the fibre cable and GBIC.

connect the same fibre into the GBIC so both A ends of the fibre connect to the same GBIC, this should bring up the GBIC connection, if it does then the GBIC and fibre are working fine, do the same with both switches

mahesh18 Sat, 05/01/2010 - 10:33

Hi,

thanks for reply .

i tested the cable it is fine actually i was putting the cable wrong way.

i put it right way and it worked.

also i did loop on 1 gbic  port gi0/2

here is config

3550SMI# sh run int gi0/2
Building configuration...

Current configuration : 98 bytes
!
interface GigabitEthernet0/2
switchport access vlan 30
switchport mode dynamic desirable
end

also i did

3550SMI#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/2       desirable        n-isl          trunking      1************************************************************************************8

do u know why it is showing as trunk type  ISL  ??????????

3550SMI#sh int gi0/2
GigabitEthernet0/2 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000d.28bc.fd9a (bia 000d.28bc.fd9a)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     14435 packets input, 1689928 bytes, 0 no buffer
     Received 14435 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 14435 multicast, 0 pause input
     0 input packets with dribble condition detected
     14435 packets output, 1689928 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
3550SMI#sh spann
3550SMI#sh spanning-tree ?
  WORD               bridge group list, example 1,3-5,7,9
  active             Report on active interfaces only
  backbonefast       Show spanning tree backbonefast status
  blockedports       Show blocked ports
  bridge             Status and configuration of this bridge
  detail             Detailed information
  inconsistentports  Show inconsistent ports
  interface          Spanning Tree interface status and configuration
  mst                Multiple spanning trees
  pathcost           Show Spanning pathcost options
  root               Status and configuration of the root bridge
  summary            Summary of port states
  uplinkfast         Show spanning tree uplinkfast status
  vlan               VLAN Switch Spanning Trees
  |                  Output modifiers
 

3550SMI#sh spanning-tree int
3550SMI#sh spanning-tree interface gi
3550SMI#sh spanning-tree interface gigabitEthernet 0/2

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Back BLK 4         128.26   P2p
VLAN0010            Back BLK 4         128.26   P2p
VLAN0020            Back BLK 4         128.26   P2p
VLAN0030            Back BLK 4         128.26   P2p
3550SMI#

Many thanks

mahesh

Reza Sharifi Sat, 05/01/2010 - 12:36

Hi Mahesh.

3550SMI#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/2       desirable        n-isl          trunking      1************************************************************************************8

do u know why it is showing as trunk type  ISL  ??????????

For 2950s and 3550s that is default. You can change it:

The default mode is dynamic desirable.

Have a look"

http://www.ciscosystems.lt/en/US/docs/switches/lan/catalyst3550/software/release/12.1_11_ea1/command/reference/cli2.html#wp2422818

HTH

Reza

mahesh18 Sat, 05/01/2010 - 13:13

Hi Reza,

the fibre cable to port gi0/2    its both ends are looped to gi0/2 port.

thats my question if cable both same ends are connected to gbic why it shows as trunk ISL?

thanks

mahesh

Reza Sharifi Sat, 05/01/2010 - 13:44

Mahesh,

Because the port was already truncked. Do a "sh run int gi0/2" and see if the interface is truncked

HTH

Reza

Leo Laohoo Sun, 05/02/2010 - 14:30

Try the following command in both switches:

switchport mode trunk
switchport trunk encapsulation dot1q
switchport nonegotiate

Actions

This Discussion