Skype for Sip Incoming Calls Using Skype Name

Unanswered Question
May 2nd, 2010

I can't seem to get incoming calls to go to my UC500 using my Skype Name.  It just says unable to connect.  I looked at the Skype for sip PDF posted, but it only mentions DIDs.  I don't have or need DID's and just want a Skype User to call my Skype Name and it go to my UC500.  Oddly, I haven't seen any documentation on this, but it's really necessary or I may as well use any SIP provider and get the same or better result.

Outgoing calls work fine.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Brandon Svec Sun, 05/02/2010 - 16:42

This should work and it does for me and I am sure many others.  Are you following the instructions from here?  I think this is still beta and as such I have noticed it sometimes takes 15-30 seconds to setup an inbound call to my Skype name.  I am actually only using Skype for sip on another non-Cisco system though so I can't offer configs for you.

FYI, on May 6 Skype is updating the BCP with a new Skype manager that will give you some additional control over your Skype for SIP account.  One of the main features I am looking forward to is that you will be able to use Skype names like DIDs where each Skype name can translate to an extension on your iP-PBX.


ciscojoe837 Sun, 05/02/2010 - 18:50

Hi Brandon,

Yes, I did look at this page...I eventually went back to the BCP setup another Business Account under Calling.  I thought when I setup my account that was my Business Account since that was the account that gave me my SIP User and Password.  I didn't realize it worked that way.

Secondly, I made another mistake earlier on by not applying funds to my Profile (I guess you can have more than one Profile too).  Anyway, the funds were there but calls wouldn't go out because I didn't appy funds the the Profile.  After I did that, the calls went through.

That's great news about the Skype Names translating to extensions.  I just tried another Skype Name and it went to the same extension so that was my next question.  That would be really useful.

Thanks for the post.


aaronc123 Mon, 05/03/2010 - 09:17

This is a problem with the way the SIP message is formated with the extension. Skype and Cisco look at things differently.

From the Skype page:

R-URI:               @pbx_ip
To:                       [email protected]
From:                  [email protected]

The UC is only matching on the To  (Where 000000000 is you skype number) not the referer ....

You can buy E.164 numbers and assign them to an extension .... then the "0s" will be changed and you can match with that ...

I hope this changes soon, as it would help one of my clients a lot, but even the existing way is a big benifit to them.

dliberty82 Mon, 01/10/2011 - 13:32


Did you ever get this working? I have the same issue (CME on 2811 ISR). Outbound works nicely but inbound doesn't.

I also tried setting the "Forward extension" on skype manager, this works randomly but the call always takes way too long to start ringing (if it all).

freshmangobvi Fri, 02/10/2012 - 08:00


I took would love to get this working on my UC540 but no joy - the link above to the PDF document no longer works



freshmangobvi Fri, 02/10/2012 - 09:37


Did you get this working in the end?

ALL: I am open to hiring someone to walk us through this remotely - if anyone is interested, let me know.


martinaicher Tue, 01/20/2015 - 04:30

Hi ciscojoe, please also can you help me. 
Same issue like everybody else describe.





ciscojoe837 Tue, 01/20/2015 - 07:39

I haven't used it in a while ... but what's your specific issue and what unit are you using.


This Discussion

Related Content