Connecting between switches using a layer 3 link

Unanswered Question
May 3rd, 2010
User Badges:

I want to add a new layer 3 switch to my network. It is going to be connected to an existing access/edge switch via a layer 3 link (Not a trunk). How do I get all the vlan's (11, 12 & 13) across to the new switch?


Existing Access Switch Config

=======================
!
interface Gi 0/1
description *** Connected to New Switch ***
no switchport
ip address 192.168.3.10 255.255.255.0
!
interface vlan 11
ip address 10.0.11.1 255.255.255.0
!
interface vlan 12
ip address 10.0.12.1 255.255.255.0
!
interface vlan 13
ip address 10.0.13.1 255.255.255.0
!


New Switch Config

==============
!
interface Gi 0/1
description *** Connected to Access Switch ***
no switchport
ip address 192.168.3.11 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.3.10

Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 05/03/2010 - 05:48
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

jennyjohn wrote:


I want to add a new layer 3 switch to my network. It is going to be connected to an existing access/edge switch via a layer 3 link (Not a trunk). How do I get all the vlan's (11, 12 & 13) across to the new switch?




If the link is a L3 routed link then you need to route between vlans on both switches. You cannot have the same vlan at L2 on both switches because there is no L2 adjacency between the switches.


So your vlans 10,11 & 12 on your existing switch cannot also be on your new switch. You could use the same vlan numbers on your new switch but they would be different vlans ie. a client in vlan 10 on your new switch would not be in the same vlan as a client in vlan 10 on your existing switch.


If you want the same vlans on both switches you need to use a L2 trunk.


Jon

Actions

This Discussion