Setup Backup Device

Answered Question
May 3rd, 2010
User Badges:

hello


I'm trying to setup the back, but when I setup the back device i recived this error: Update failed : Unable to access SFTP server or SFTP server too slow to  respond. Please make sure the login credentials and path are correct.


the path is D:\Cisco

and i test the connection with other sftp, and i able to connect to the sftp server.


in the server name is only the ip address?


thanks

Correct Answer by Jaime Valencia about 7 years 2 months ago

How to backup Unified Communications Manager 7.x

http://www.networkworld.com/community/node/33489


Step 3
-Enter a name for your Backup device name*
-Select the Network Directory option
-For the Server name Enter the IP address of your sftp server
-For the Path name if everything on your Freesftpd server was left as default use / otherwise make the proper changes.


+5 to all you guys that pointed this from the very beginning


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Correct Answer by Jaime Valencia about 7 years 2 months ago

The problem has already been pointed out 5 times per my count. The path IS WRONG.

Let's make thing easier, name your SFTP client.


What you're doing is not working, you're asking for help and advice.

I'd give a try to the suggestions you've received so far.


Read this:

http://articles.techrepublic.com.com/5100-10878_11-5031698.html


TFTP write '/pixcfg.txt'


Means the file will  be written in the root folder, where that is? whever you have pointed your TFTP server.

How does it know it has to write it there? because you don't use the absolute path, you only use the relative path.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (11 ratings)
Loading.
CHRIS CHARLEBOIS Mon, 05/03/2010 - 07:35
User Badges:
  • Silver, 250 points or more

Are you sure there isn't an ACL or firewall that allows traffic from your PC (or other test machine) but not from the CUCM server/subnet?  We are pretty strict about what can and can't access our voice core, and have had to specify access for certain things like back-ups.

William Bell Mon, 05/03/2010 - 07:47
User Badges:
  • Purple, 4500 points or more

What application are we talking about here?


I would check firewall (PC and network) and network ACLs. This is true for all apps.


Also, the D:\Cisco pathname wouldn't work when setting up a backup destination in CUCM/CUPS/etc. (i.e. via DRS-Disaster Recovery). You would need a path like: /Cisco/.


Could you post a screen shot of what you are trying to configure for the path?


From the CUCM/CUPS/CUC/? can you test SFTP via another method (not backup). For those apps that run the Cisco appliance model. Try:


admin:file get tftp Ringlist.xml


Follow the prompts, and see if you can copy the file.


Last thing I can think of was a defect I ran into with CUCM 6.1. If I had a banner setup on my SSH server (e.g. "You are access a secure system...blah blah legal this, legal that...") then I could copy files from the CUCM server (like the example above) but could not back the server up. I had to remove the banner/message of the day completely. I haven't tested with 7.x nor have I tested CUPS/CUC. Just a thought.


If none of this helps, please let us know your version, application, and provide a screen shot of how you are trying to configure the backup.


HTH.


Regards,

Bill

Please remember to rate helpful posts.

David Hailey Mon, 05/03/2010 - 07:51
User Badges:
  • Purple, 4500 points or more

Your SFTP server path would not be D:\Cisco from the CUCM (Linux) perspective.  The path would be the actual SFTP path which typically reads as the Login User and their /home folder.  So example:


Server. 1.1.1.1

User: sftpuser

Password: cisco

Path --> you want backups to go to a folder called "backups" and then a subfolder for the application called "cucm".


Your path would be as follows: /home/sftpuser/backups/cucm/


That's what you need.  If you're attempts to connect using that info (adjusted for your scenario) do not work then you would want to make sure you're not firewalling off the connection (i.e., if you using VMWare you can exclude a lab interface from Windows firewall or make exceptions especially for an interface). Or you want to make sure that there are no ACL's blocking SFTP (port 22) from your server to the SFTP server.


Hailey


Please rate helpful posts!

INFOTEP_OFN Mon, 05/03/2010 - 08:18
User Badges:

Thanks for your answer


but the sftp server is running in windows, the path has to be same, because in windows we don't have home folder.


thanks

David Hailey Mon, 05/03/2010 - 08:22
User Badges:
  • Purple, 4500 points or more

What SFTP server are you running? I run CopSSH on Windows and it still uses the home folder concept - just like FTP and other servers I've used in the past. When you go into the root folder on your Windows server. What is the file structure that you see?

CHRIS CHARLEBOIS Mon, 05/03/2010 - 08:24
User Badges:
  • Silver, 250 points or more

While the server is running Windows, the SFTP protocol is based on Unix protocols and knows nothing about drive lettering.  When configuring the SFTP server on the Windows OS, you might specify D:\Cisco as the root of the SFTP server.  If you did, they the direrctory you would specify on the CUCM would simply be \.

David Hailey Mon, 05/03/2010 - 08:28
User Badges:
  • Purple, 4500 points or more

Yes, your Linux CUCM has no concept of D:\ - hence, if you look in the root installation folder, you'll likely see a file structure (in a Windows) view comparable to what I noted in my example. You can use "/" to simply look at the root of the drive.


Hailey


Please rate helpful posts.

William Bell Mon, 05/03/2010 - 08:28
User Badges:
  • Purple, 4500 points or more

While the SFTP server may be running in windows, the path understood by Windows is not going to be understood by the Cisco application.


Your SFTP server most likely has the concept of a "home" folder, much like the one Hailey was eluding to in an earlier reply. If that home folder is D:\Cisco\ then you will need to set the backup device in the Cisco DRS to use folder path: "/". Forward slash NOT back slash.


If the root of your SFTP server is D:\. This is not advisable, but if it is the case then your path will be /Cisco/.


D:\Cisco will simply not work.


HTH.


Regards,

Bill

INFOTEP_OFN Mon, 05/03/2010 - 08:31
User Badges:

This is the configuration that i have


server name: 10.0.0.40

path:C:\backups\cucm

username:cisco

password:cisco


the sftp is running in windows 7


thanks

William Bell Mon, 05/03/2010 - 08:39
User Badges:
  • Purple, 4500 points or more

Well, this path: C:\backups\cucm


is definitely incorrect. The question remains, what is the "home" for your SFTP server. I thought that Windows 7 included FTPS (secure FTP) but this isn't the same as SFTP.


Paths that could work depending on how you got this configure:


/backups/cucm/ : If the SFTP service you are running is assuming c:\ is the root.


/ : If the SFTP service you are running assumes that c:\backups\cucm is the root.


/cucm/: If the SFTP service you are running assumes that c:\backups\ is the root.


This all assumes you are running a true SFTP service. What service are running? If you are running copSSH or another port of openSSH, then the following may work:


/cygdrive/c/backups/cucm/


You could use a client like putty (psftp.exe specifically) to SFTP to your Windows 7 host and then look at the directory contents. This should clue you in on the root folder.


HTH.


Regards,

Bill

Please remember to rate helpful posts.

INFOTEP_OFN Mon, 05/03/2010 - 09:00
User Badges:

Hello


the root is C:\Program Files (x86)\freeFTPd\ftproot

and the software is freeftpd

David Hailey Mon, 05/03/2010 - 09:02
User Badges:
  • Purple, 4500 points or more

I can't say it anymore, Yancy. The path is wrong. You cannot use a Windows folder path on a Linux device to connect to a Linux-based application like an SFTP server whether it's installed on Windows or not.


Please rate helpful posts (several here).


Hailey

William Bell Mon, 05/03/2010 - 09:04
User Badges:
  • Purple, 4500 points or more

OK then. Your path should be /backups/cucm/


Try that out and see if it works. Going back to my original post, test a basic file copy:


admin:file get tftp Ringlist.xml


Use the /backups/cucm/ path. If it works, you are in business. If not, let us know.


HTH.


Regards,

Bill

Please remember to rate helpful posts.

Correct Answer
Jaime Valencia Mon, 05/03/2010 - 08:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

The problem has already been pointed out 5 times per my count. The path IS WRONG.

Let's make thing easier, name your SFTP client.


What you're doing is not working, you're asking for help and advice.

I'd give a try to the suggestions you've received so far.


Read this:

http://articles.techrepublic.com.com/5100-10878_11-5031698.html


TFTP write '/pixcfg.txt'


Means the file will  be written in the root folder, where that is? whever you have pointed your TFTP server.

How does it know it has to write it there? because you don't use the absolute path, you only use the relative path.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Correct Answer
Jaime Valencia Mon, 05/03/2010 - 09:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

How to backup Unified Communications Manager 7.x

http://www.networkworld.com/community/node/33489


Step 3
-Enter a name for your Backup device name*
-Select the Network Directory option
-For the Server name Enter the IP address of your sftp server
-For the Path name if everything on your Freesftpd server was left as default use / otherwise make the proper changes.


+5 to all you guys that pointed this from the very beginning


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Jamil Hussain Thu, 07/15/2010 - 08:05
User Badges:

Hi All


I am facing the same problem which yancy were facing


i am trying to take the backup using the FTPD but no luck to overcome this problem


i attached the snapshot for my SFTP Server and user settings.


Kindly Assist me to set the proper parameters in SFTP Server and what path to use in CUCM DRS.


Waiting for a favourable reply



thanks.

Attachment: 
Jaime Valencia Thu, 07/15/2010 - 08:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

This has already been covered really throughly in this thread, Have you read and followed the suggestions that have been provided???


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

David Hailey Thu, 07/15/2010 - 16:58
User Badges:
  • Purple, 4500 points or more

It would also be MORE valuable to us to see how you have configured the CUCM DRS settings.  The SFTP settings are personal preference really...so the CUCM is config is what we're interested in.


Hailey

Jamil Hussain Fri, 07/16/2010 - 05:27
User Badges:

Settings for the Backup Device


Server Name : 192.168.80.30


path name : /CUCM/


user name : cisco


password  : cisco


These are my settings on CUCM.

David Hailey Fri, 07/16/2010 - 06:05
User Badges:
  • Purple, 4500 points or more

So, two things.  In your FreeFTPd settings you have the root folder specified as the CUCM folder; however, in a typical setup this is setup as "$HOME\". This is because when a user logs in they are usually directed to their personal home folder.  So, you should take a look at the following link and look at the screenshots particularly for how to set up the SFTP server. 


http://www.freesshd.com/index.php?ctt=overview


So, with the $HOME\ config you would have a structure like this:


Root Folder > Home and sub-folders for each user:  /home/


In your case, /home/cisco/ - here you may want to create the CUCM folder or a backup folder and subfolders depending on preference.  Example:


/home/cisco/cucm/

/home/cisco/backups/cucm/


Either way works, it's up to you.


Then in the CUCM DRF config, the root folder would be /home/cisco/cucm/ OR the equivalent that you came up with that works for you.


Hailey


Please rate helpful posts!

DJCanuck1_2 Wed, 09/22/2010 - 15:54
User Badges:

OK. I have read all the posts and know this is a simple issue, but WTF? I'm running copSSH installed to the root of C: (not Program Files) so the user account set up has a directory of  C:\ICW\home\username. Now I know I don't put the C: in the path name field in DRS, so I've tried:


/

/icw/home/username

/icw/

/home/

/username/

/icw/home/


All fail. I can connect via WinSCP with the username in question and can also telnet to port 22 on the copSSH server. Firewalls are off and no ACLs.


This is either a case of incorrect path syntax, or the RSA key exchange. Whenever I have a new client trying to connect to copSSH, I get the key exchange banner wanting you to accept or update your key for this site. Anyone know how Unity handles the key exchange for a SFTP server it has never connected to before?

Aaron Harrison Thu, 09/23/2010 - 01:07
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Unity will just accept the signature blindly.


Have you tried checking the logs for CopSSH when an attempt comes in?


Aaron

Actions

This Discussion