EIGRP dual default routes from main sites and branch offices selecting a specific path:

Answered Question
May 3rd, 2010

High-level topology layout:

Two main sites and 6 branch locations.

They connect via layer 2 Metro E.

The hardware is Cisco routers 2811 with 4 port Ethernet module.

The requirement is that main site A should provide primary internet for 3 branch locations and main site B should provide primary internet for the other three branch locations and be failovers to each other including the main sites.

The routing protocol is EIGRP.

What is the best approach to configure this?

My thoughts were to use route-maps at each of the branch offices with the set next ip hop parameter.

Main site A and main site B only see each other via the Metro E there is no direct connection between them.

Main Site A IP is 192.168.20.1 and Main site B IP is 192.168.21.1

The route map for Main site A Branches is

route-map pbr1 permit 10

match ip address 101

set ip next-hop 192.168.20.1

!

The route map for Main site B Branches is

route-map pbr1 permit 10

match ip address 101

set ip next-hop 192.168.21.1

I will advertise the default route with EIGRP using the default metrics and values at MAIN site A and Main site B.

If one of the main sites are down the branch offices that were using the main site will use the alternate default route in the routing table.

In the route-map do I need to specific multiple next hops?

Or is one enough and just as long as the other default route is in the routing table it will use it even if the one configured in the next hop is down?

Is there a better way of selecting the default route for the branch offices?

Thanks everyone for your assistance.

Juan

Correct Answer by Jon Marshall about 6 years 9 months ago

Juan



On site A router

============


access-list 10 permit 0.0.0.0 0.0.0.0


router eigrp 10

offset-list 10 out 100    where interface is for sites 4, 5 & 6 eg. vlan 4, vlan 5, vlan 6



On site B router

============


access-list 10 permit 0.0.0.0 0.0.0.0


router eigrp 10

offset-list 10 out 100 where interface is for sites 1, 2, 3 eg. vlan 1, vlan 2, vlan 3


Note you may need to manipulate the offset value in the above (which is 100) to get the results you want. See this doc for more details -


EIGRP offset-list


Jon

Correct Answer by Giuseppe Larosa about 6 years 9 months ago

Hello Juan,

as I've suggested PBR is not necessary there are other ways to influence branch router choice of default route if they have two subinterfaces one pointing to HubA and one HubB.

PBR is implemented efficiently nowdays but simple static routes with object tracking or the use of offset-lists should be more efficient.


You could use PBR if you like it, but you have asked for other possible solutions so I would suggest to consider these suggestions


You could even simply increase delay on subinterface of branch router to achieve the desired effect.


Edit:

as usual the trade off is between solution complexity and forwarding efficiency.


Hope to help

Giuseppe

Correct Answer by Jon Marshall about 6 years 9 months ago

Juan


Then i would do as Giuseppe suggested and use offset-lists rather than PBR which is not really the best solution.


So 6 sites -  Site A is default-route for sites 1 - 3 ,   Site B is default-route for sites 4 - 6


On site A router send the default to all 6 sites. For sites 1 - 3 just send as normal. For sites 4 - 6 add an offset to the route ie. increase it's metric

On site B router send default to all 6 sites. For sites 4 - 6 sends as normal. For sites 1 - 3 add an offset to the route.


You can do this because site A and B have interfaces/subinterfaces for each connection.


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Giuseppe Larosa Mon, 05/03/2010 - 12:02

Hello Juan,


>>

Is  there a better way of selecting the default route for the branch  offices?

All depends from how the metro ethernet service is done: if you could use 802.1Q tags over your metro ethernet cloud you could use two IP subnets one towards HubA and one towards HubB (it looks like it is already so from your addresses 192.168.20.1 and 192.168.21.1) and two logical interfaces on each branch router.

If you do so you could use the offset-list feature to add delay to specific routes received from HubB on the branch subset that should prefer HubA.

the offset-list can add delay only for specific routes received on a specific interface.

see

http://www.cisco.com/en/US/docs/ios/iproute_eigrp/command/reference/ire_i1.html#wp1027258


This can be done but what route to match depends on how you generate the default route, if you were using the default network feature you should match that prefix (that has a special flag ) instead of default route 0.0.0.0


if you have a single broadcast domain and no chances to use 802.1Q tags to create two logical clouds you can still use simple default static routes with specific next-hop to override EIGRP routing instead of PBR.

You could combine this with object tracking


see

http://www.cisco.com/en/US/partner/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html


Hope to help

Giuseppe

juan-ruiz Mon, 05/03/2010 - 12:11

Hi Giuslar,

All of the interfaces on the Metro E will be trunks.

Main site A and B will have interfaces on all of the networks.

The branches will only have the respective interface for the Metro E and in the access layer the user vlans.

Will the route tag approach that I suggested work?

Correct Answer
Jon Marshall Mon, 05/03/2010 - 12:21

Juan


Then i would do as Giuseppe suggested and use offset-lists rather than PBR which is not really the best solution.


So 6 sites -  Site A is default-route for sites 1 - 3 ,   Site B is default-route for sites 4 - 6


On site A router send the default to all 6 sites. For sites 1 - 3 just send as normal. For sites 4 - 6 add an offset to the route ie. increase it's metric

On site B router send default to all 6 sites. For sites 4 - 6 sends as normal. For sites 1 - 3 add an offset to the route.


You can do this because site A and B have interfaces/subinterfaces for each connection.


Jon

juan-ruiz Mon, 05/03/2010 - 12:37

Jon,

As always thanks a lot for your input on my questions and how easy you break the example up.

Can you provide an example?

The router on Site A and Site B has one ethernet interface connected and Vlan interfaces for each of the branches.



SITE A config

access-list 99 permit ip 192.168.21.0/24 Branch 4

access-list 99 permit ip 192.168.22.0/24 Branch 5

access-list 99 permit ip 192.168.23.0/24 Branch 6


router eigpr 1

network 192.168.20.0/24

network 192.168.21.0/24

network 192.168.23.0/24

network 192.168.23.0/24

network 192.168.24.0/24

network 192.168.25.0/24


offset-list 99 out 10

Thanks a lot

Regards,

Juan

Correct Answer
Giuseppe Larosa Mon, 05/03/2010 - 12:21

Hello Juan,

as I've suggested PBR is not necessary there are other ways to influence branch router choice of default route if they have two subinterfaces one pointing to HubA and one HubB.

PBR is implemented efficiently nowdays but simple static routes with object tracking or the use of offset-lists should be more efficient.


You could use PBR if you like it, but you have asked for other possible solutions so I would suggest to consider these suggestions


You could even simply increase delay on subinterface of branch router to achieve the desired effect.


Edit:

as usual the trade off is between solution complexity and forwarding efficiency.


Hope to help

Giuseppe

juan-ruiz Mon, 05/03/2010 - 12:30

Giuslar,

Thanks for your input and I like this approach.

From the main site a I would off-set list to branches 4-6 with a higher metric on the out of the trunk interface.

Could you provide a basic example?

Thanks a lot.

Regards,

Juan

Correct Answer
Jon Marshall Mon, 05/03/2010 - 12:40

Juan



On site A router

============


access-list 10 permit 0.0.0.0 0.0.0.0


router eigrp 10

offset-list 10 out 100    where interface is for sites 4, 5 & 6 eg. vlan 4, vlan 5, vlan 6



On site B router

============


access-list 10 permit 0.0.0.0 0.0.0.0


router eigrp 10

offset-list 10 out 100 where interface is for sites 1, 2, 3 eg. vlan 1, vlan 2, vlan 3


Note you may need to manipulate the offset value in the above (which is 100) to get the results you want. See this doc for more details -


EIGRP offset-list


Jon

juan-ruiz Mon, 05/03/2010 - 12:56

Thanks so much for both of your inputs.

This is great.

Kind regards,

Juan

Actions

This Discussion