Natting on router based on destination

Answered Question
May 3rd, 2010

Hi ,

            I need to perform dynamic natting based on destination ip address , Similary let me know whether i can have multiple dynamic natting in cisco router .

              In my setup i need to use mutiple dynamic nat  becoz client has given access to  the apllication server based on my  NAT IP address pool  ..

pasting u sample config

interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
ip nat inside

!
interface Serial0/0/0
ip address 10.10.10.2 255.255.255.252
ip nat outside
!

!
ip nat pool dev 10.10.10.9 10.10.10.11 netmask 255.255.255.252
ip nat pool prod 10.10.10.12 10.10.10.15 netmask 255.255.255.252
ip nat inside source list 101 pool dev
ip nat inside source list 102 pool prod
ip classless
!
!
access-list 101 permit ip 172.16.1.0 0.0.0.255 host 20.20.20.1
access-list 102 permit ip 172.21.16.0 0.0.0.255 host 30.30.30.1

If am wrong in my commands please write back ..thank you..

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 6 years 7 months ago

Yes you can have multiple NAT pools on IOS and your config looks fine. Have you tested it yet ?

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Mon, 05/03/2010 - 09:52

Yes you can have multiple NAT pools on IOS and your config looks fine. Have you tested it yet ?

Jon

SANTHOSHKUMAR S... Mon, 05/03/2010 - 10:02

Thanx Jon much , I havent tested , prepared config from lab router ..once i have tested i ll let you know ..

  I am always impressive with your answer which u used explain with clear concept n fundas , keep rocking !!!!!!!!!!!!!!!!!!!!

Actions

This Discussion