Single Number Reach and night mode

Unanswered Question
May 3rd, 2010
User Badges:
  • Bronze, 100 points or more

Has anyone noticed any issues with single number reach during the active night mode?


We have a UC520 and SnR for a few users. It works great during normal hours, but when the system is in night mode, a call to the same user's DID (with snr enabled) never calls the cell phone and just rings the extension endlessly. The vm doesn't even pick up ?!


Is this a known issue? anyone else having the problem?



Thanks,

Stacy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kaggenuchc Wed, 08/25/2010 - 10:24
User Badges:

Normally I don't like to open up old discussions on a forum, but I am experiencing the same issue as the original poster.  This is a big issue for the client who uses the system, as this feature was sold to them as part of working solution on the phone system.   I am finding exactly the same problem.  If night mode is turned off, single number reach works properly and transfers the to the users cell phone.  Once night mode is turned on, it will ring endlessly at the extension and never transfer the call to the cell phone.


I have been troubleshooting this over the past week off and on when time permits and no luck.  I have updated to the latest UC540 software pack, and that did not help either.  I attempted to call Cisco SBS support, but I don't have a current valid service contract, and the warranty is up on the system so I cannot get the free support anymore (ugg for 90 days).


If the original poster was able to resolve this issue, I would LOVE to know what steps were taken in fixing this.  I am also using the FXO ports, attached to 4 POTS lines handled by the PSTN.  I don't know if that is relevant, but I know that it has worked properly at a separate office that uses DID's and a PRI circuit.


Thanks in advance to anyone who can provide an insight on this frustrating problem,

Steven DiStefano Wed, 08/25/2010 - 12:52
User Badges:
  • Blue, 1500 points or more

Hi,

what is your NS activation * code?

R U using the default SNR timeout configuration?

What is the CFNA timer of the base station with SNR set to?


Steve

kaggenuchc Wed, 08/25/2010 - 14:04
User Badges:

My activation code is *999 (but it is also enabled through the scheduler during closed business hours)

My phone configuration is as follows: (for security reasons I have removed any information not pertinent to the issue)


ephone-dn  18  dual-line
number 601 no-reg primary
label
description
name
mobility
snr 9xxxxxxx delay 2 timeout 10
night-service bell


ephone  10
device-security-mode none
video
mac-address xxxx.xxxx.xxxx
ephone-template 16
type 7970
button  1:18 2c46,47,48,49 7m298 8m197
night-service bell

As you can tell I am not using CFNA on it at all, I took it off so I could make sure that was not causing a problem during my troubleshooting.  I originally had CFNA configured for 401, which is my voicemail extension. However, because I am using SNR on the FXO ports, it will not return the call so using CFNA is irrelevant.

I can re-create this issue easily, all I have to do is turn on night service manually (or after office hours when it goes on automatically).  If I enter the night service code to turn it off, it works again.  It is not even a random issue, it happens each and every time.

Thank you for your response
Steven DiStefano Thu, 08/26/2010 - 12:44
User Badges:
  • Blue, 1500 points or more

Well, I have reproduced this condition, but may be different from yours...not sure...give me some time to figure out whats happeneing here.


But, let me ask you this....

I noticed your SNR timeout is set to 10 seconds and you have no CFNA destination in there....

CCA pushes 30 seconds, and sets CFNA to voicemail (probably reads what the subscriber is set to).


Here is mine (done with CCA)

ephone-dn  10  octo-line
number 201 no-reg primary
pickup-group 1
label 201
description Mike Scott
name Michael Scott
mobility
snr 203 delay 5 timeout 30 cfwd-noan 399
call-forward busy 399
call-forward noan 399 timeout 20

night-service bell


Can you edit yours to look like this above (Blue and Red) and see if it helps you?

Steven DiStefano Thu, 08/26/2010 - 13:49
User Badges:
  • Blue, 1500 points or more

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

Discussing with the BU Engineers .

So we are concluding (almost) NS should override SNR, but this doesnt explain why when both are present, the base station never forwards to its CFNA destination.

.  

Regarding the design, consider the interaction possibilities, like what if we had a call answered at the SNR phone and then someone locally in UC500 attempted to PICKUP the NS extension since all the BELLS are ringing...

About a year ago, there was an internal defect filed indicating that there was an intraction between these two:

CSCsu52907:

ephone-dn 1 octo
number 5000
mobility
snr 6304 delay 5 timeout 10
night-service bell

Now when this dn is called, phones ring properly and the mobile leg does not get created, but after 10 seconds,
the ephones are getting put on hold still.  Night service should effectively disable SNR call. Note that cfwdw
night-service does override SNR call and hence the forward path is taken properly.



The fix included NS deactivates SNR (or takes precedence)

Our NS CCA GUI offers “NS Bell” or “Call Forwarded number”.  The second is the choice for ringing external phone when NS is on.


Stay tuned as to why when NS is active on a phone with SNR configured, the phones CFNA timer doesnt 'kick in' and take the call as it does when NS is not active.   This we are trying to figure out.

Steven DiStefano Thu, 08/26/2010 - 14:13
User Badges:
  • Blue, 1500 points or more

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

Final Ansewr :-)   : If  night service is enable and the snr is configured , the call-forward noan is disabled. You need to use “call-forward night-service” to redirect the call to voice mail. Or you can remove the snr config from ephone-dn.  If you choose BELL instead, it just rings the bell.  It actually makes some sense since the security guard is making rounds and needs to get to a phone and do a pickup on the ringing bell so you really dont want it forwarding too fast.



Eric LeeShanok Sat, 09/11/2010 - 21:00
User Badges:

Hello Stephen,
Thanks for your reply on this.


With what you are suggesting, this would always forward the incoming call to their voicemail when night service is enabled.


This would defeat the purpose if the user always wanted to receive calls with SNR regardless of the business hours or night service.


With a PRI, this is not a problem with SNR.  This configuration is only happening with FXO's.


Are there any other options to always have SNR active?

antyeung Sun, 09/12/2010 - 22:25
User Badges:
  • Bronze, 100 points or more

Hi Eric,


"This would defeat the purpose if the user always wanted to receive calls  with SNR regardless of the business hours or night service."


The only way to get around this is to not configure night service for the ephone-dn that has SNR configured.


"With a PRI, this is not a problem with SNR.  This configuration is only  happening with FXO's."


Are you saying that when an ephone-dn is configured for night-service and SNR and if the call comes in a PRI the CME places a call out to the SNR number?


Thanks,

Anthony

Eric LeeShanok Sun, 09/12/2010 - 22:55
User Badges:

"This would defeat the purpose if the user always wanted to receive calls  with SNR regardless of the business hours or night service."

The only way to get around this is to not configure night service for the ephone-dn that has SNR configured.


The problem we have run into is when SNR is configured with an FXO and night service is active, there is an endless ring and the voicemail never picks up.

With UC's configured with a PRI, this problem has not come up.

So the answer above is to add "night-service call forward" for the ephone-dn to go to the voicemail.  But, what if we don't want it to go to callforward it to the voicemail when night-service is active.  This doesn't seem to be possible.


"With a PRI, this is not a problem with SNR.  This configuration is only  happening with FXO's."

Are you saying that when an ephone-dn is configured for night-service and SNR and if the call comes in a PRI the CME places a call out to the SNR number?


We don't have the "night-service call forward" configured for the ephone-dn with a PRI.

antyeung Sun, 09/12/2010 - 23:19
User Badges:
  • Bronze, 100 points or more

"This would defeat the  purpose if the user always wanted to receive calls  with SNR regardless  of the business hours or night service."

The only way to get around this is to not  configure night service for the ephone-dn that has SNR configured.


The problem  we have run into is when SNR is configured with an FXO and night  service is active, there is an endless ring and the voicemail never  picks up.

With UC's configured with a PRI, this problem has not  come up.


[anthony] night-service and snr is configured per extension. When you mention that "SNR is configured with an FXO" are you configuring SNR with an extension on an IP phone that is a CO line, or are you just referencing that the inbound call comes in a FXO port? In either case when you configure "night service bell" or "call forward night service" along with SNR for an extension call forwarding is disabled for that extension. The symptom that you describe is working as designed.


So the answer above is to add "night service call forward" for the ephone-dn to go to the voicemail.  But, what if we  don't want it to go to callforward it to the voicemail when  night-service is active.  This doesn't seem to be possible.


[anthony] If you want the SNR configurations to be active regardless of the time of day just don't configure "night service bell" or "call forward night service" for the extension you configure SNR for.

"With a PRI, this is not a problem with SNR.   This configuration is only  happening with FXO's."

Are you saying that when an  ephone-dn is configured for night-service and SNR and if the call comes  in a PRI the CME places a call out to the SNR number?


We don't  have the "night-service call forward" configured for the ephone-dn with a  PRI.


[anthony] Do you have "night service bell" configured for the extension with SNR?

Actions

This Discussion

Related Content