SPA-942 Failed Authentication (orange LED)

Unanswered Question
May 3rd, 2010


My internet connection is plugged into a Apple Airport Extreme. The SPA-942 phone is plugged into an ethernet jack in my wall. That ethernet jack is connected to one of the ethernet ports in the back of the Apple Airport Extreme. Also, I have a Static IP internet connection.

I recently setup a SPA-942 phone to a RingCentral number.  The phone has worked fine for the past 2 weeks. It has received calls  and dialed calls without an issue. The phone is running the latest firmware, 6.1.5(a).  However, the other day the phone's LED light changed from green to orange. I have not touched anything in the phone's settings since the first day I setup the phone. I checked the admin panel for the phone and the "Registration State" says "FailedAuthentication". I have searched the internet for a resolution and I keep coming up empty.

I'm very confused on why the phone is not working anymore and would appreciate help on resolving this matter.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
icastrov Tue, 05/04/2010 - 00:43


There could be several reasons which prevents the phone to successful register into the RingCentral's proxy. If you haven't changed anything neither in the phone nor in the router, I'd first suggest you then to give a ring to your SP (RingCentral) to verify that your account is still properly set and no changes have been performed on it. Please ask them to re-send to you your account settings so you can double check the auth values like auth id (if any) and user/password.



donnalasorda Tue, 05/04/2010 - 07:03


I verified with RingCentral that my account information is the same that it has been since the phone has been working.

I've turned off the router and phone for over 1 minute and the phone still lights up orange.

If you have any other possible solutions, that would be much appreciated.


frostbite25 Tue, 04/30/2013 - 10:09

I know this thread is crazy outdated but I couldn't find the answer readily so I though so I thought I'd share a fix I found.

Not only was this with RingCentral but with a SPA-942 Phone.

Here's what I did:

  • Log into router (we are using a d-link)
  • Look at firewall settings
  • Under "Application Level Gateway Configuration"
  • Uncheck SIP

That should fix the problem. Don't know if that poses a security risk, but I do know it fixed our phone.

ringcentral Wed, 05/01/2013 - 12:08

Hi Eric,

We're pretty late to the party too.

Glad to see this fixed the problem! Did our support provide that to you, or did you figure it out on your own?


Desiree @ RingCentral


This Discussion

Related Content