2960 <-> 3560 port-channel Output drops

Unanswered Question
May 4th, 2010

Hi,


I've connected several 2960G switches to a 3560 "core" switches. They have been connected using a port-channel consiting of two gigabit ports, like this:


2960G Config:

interface GigabitEthernet0/21 + 22

description TO_3560

switchport trunk allowed vlan 2-4094
switchport mode trunk
media-type rj45
udld port aggressive
mls qos trust dscp
channel-protocol lacp
channel-group 1 mode active


interface Port-channel1
description TO_3560
switchport trunk allowed vlan 2-4094
switchport mode trunk
spanning-tree link-type point-to-point


3560G Config:

interface GigabitEthernet0/5 + 6
description TO_2960G      
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4094
switchport mode trunk
udld port aggressive
mls qos trust dscp
channel-protocol lacp
channel-group 3 mode active


interface Port-channel3
description TO_2960G

switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4094
switchport mode trunk
spanning-tree link-type point-to-point


All interfaces mentioned above, and also other interfaces but the config is the same, are showing a lot of OutDiscards / Output Drops. The 2960G switches have several servers connected (gigabit) and the 3560 is a coreswitch connecting al the 2960G's together.


Anyone knows why there are output dops? Switches should be fast enough.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sat, 05/08/2010 - 11:34

Hello,


It may be possible that your uplinks from 2960G switches to the 3560G switches are overutilized. If a traffic from multiple servers on your 2960G aggregates, the total amount of frames sent through a particular physical link in your Etherchannel may be significantly more than the interface and its controller can handle - therefore, output drops may arise.


Personally, I would suggest monitoring the load on the individual physical links to see whether there are indeed periods of high traffic. Also, try to modify the Etherchannel load balancing algorithm on individual switches according to the traffic properties to achieve maximum dispersion over the physical links.


One more question: why do you have the spanning-tree link-type point-to-point command on your Port-channel interfaces? The STP should treat them as P2P links by default.


Best regards,

Peter

Actions

This Discussion

Related Content