Access FTP Sever in inside interface with Public IP

Answered Question
May 4th, 2010
User Badges:

Hi,


I have a ftp server in my inside zone of ASA, One of my application team needed to access that ftp server in the inside interface with the Public IP. If they were using a url for that I could have used "dns doctoring". I tried with the following NAT


static (inside, inside) <localip> <publicip>


but ASA thinking that it is an attack



Note: Both Client and FTP server are in the same network hence the zone which is inside.

Correct Answer by Jennifer Halim about 7 years 1 month ago

Correct, if you already have NAT statement on that interface, then you would need the global (inside) command. Otherwise, if there is no NAT statement at all on that interface, you can disable nat-control, and the connection would work.


Also, if you have ACL assigned to the inside interface, you would need to allow the traffic:

access-list permit tcp host eq 21

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jennifer Halim Tue, 05/04/2010 - 03:05
User Badges:
  • Cisco Employee,

It should be as follows:

static (inside, inside) netmask 255.255.255.255

global (inside) 1 interface

same-security-traffic permit intra-interface

manuadoor Tue, 05/04/2010 - 03:14
User Badges:

halijenn,


Nat syntax is ilike


nat (real int, mapped int) mapped ip  real ip netmask ??/


in my case I want to replace my public ip with my local ip, what is the logic behind  static (inside, inside) netmask  255.255.255.255


Also pls let me know why we require the following??


global (inside) 1 interface


This is just to clear my understanding!!!

Jennifer Halim Tue, 05/04/2010 - 03:21
User Badges:
  • Cisco Employee,

For normal static (inside,outside) statement, you would configure the following: static (inside,outside) , so the concept is the same for static (inside,inside).


You are trying to reach the public ip, so the first ip address in the static statement should be the public-ip, and the second ip is the local-ip.


The reason why you need "global (inside) 1 interface" is you still need translation for the source address which is your internal host. The static statement above is for destination translation.

manuadoor Tue, 05/04/2010 - 03:28
User Badges:
The first part is clear now ,,

Since the host and the server is in the same zone (inside), why we need source translaion??? You meant for nat-control??

Correct Answer
Jennifer Halim Tue, 05/04/2010 - 03:32
User Badges:
  • Cisco Employee,

Correct, if you already have NAT statement on that interface, then you would need the global (inside) command. Otherwise, if there is no NAT statement at all on that interface, you can disable nat-control, and the connection would work.


Also, if you have ACL assigned to the inside interface, you would need to allow the traffic:

access-list permit tcp host eq 21

Actions

This Discussion