Portfast won't go away!

Unanswered Question
May 4th, 2010
User Badges:

I have a 2950 switch in a remote site that has 2 3Com 8 port switches connected to it to secondary rooms.  I keep getting notified that these switches stop working.  I checked the 2950 and portfast was enabled, I issued "no spanning-tree portfast" on both ports, saved the config.


A couple of days later (after a power outage) the same thing happened.  I logged in, and "spanning-tree portfast" was back on both interfaces!


I've repeatedly removed this from the config and it keeps coming back.  I don't understand why.


Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rajeev Sharma Tue, 05/04/2010 - 11:56
User Badges:
  • Silver, 250 points or more

Hi Rob,


Seems weired to me.


However:


Do you have port fast globally enabled?

What is the runnnign IOS on the box?


Raj.

Jon Marshall Tue, 05/04/2010 - 11:58
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Rob


Do you have "spanning-tree portfast default" configured in global configuration mode ?


If so then you need to use this command under the interface -


int

spanning-tree portfast disable


Jon

rcoote5902_2 Tue, 05/04/2010 - 12:04
User Badges:

That's the funny thing...I don't have it enabled globally.


I added "spanning-tree portfast disable" to those two ports and it looks like it stuck after a reload.


Time will tell I suppose...

Actions

This Discussion