Picking a CE Router

Answered Question
May 5th, 2010

Hi,

I need help choosing a MPLS Customer Edge Router. I was thinking about the cisco 800 series, but using the feature navigator I could not find out if the ios has mpls capabilities. ¿Which is the smallest and cheapest Cisco Router with MPLS Capabilities?

Thanks in advance,

Daniel Rojas

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 8 months ago

Hello Drojasug33,

unless you are trying to setup a Carrier supporting Carrier scenario you don't need to run MPLS on the CE router

so the commands

>>#

mpls ldp router-id Loopback0 force
#
mpls label protocol ldp

#

They Are not needed and they can be skipped

Be also aware that if you are going to run OSPF as PE-CE protocol you need to configure the PE nodes appropriately.

The OSPF process-id has to match on local VRF site and remote VRF siteto see remote site OSPF routes as O IA (inter area) otherwise they will be seen as O E2 or O E1 (external routes)

Also, you are expected to use area 0 with PE router (the so called superbackbone area) in order to be able to use multiple OSPF areas on CE router

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Reza Sharifi Wed, 05/05/2010 - 17:17

Hi Daniel,

I an MPLS environment usually a CE router does not run MPLS.  It utilizes static routes or dynamic routing protocols ie BGP with the service provider router (PE). If you need MPLS, you can use small 2800 router.

HTH

Reza

drojasug33 Thu, 05/06/2010 - 06:01

Thanks a lot for your help. I was thinking about using this config in the CE.

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
 ip address 34.0.0.1 255.0.0.0
 no cdp enable
!
router ospf 1000
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network 34.0.0.0 0.255.255.255 area 1000
network 10.0.0.0 0.0.0.0 area 1000


Are the three first commands necessary?

Thanks again.

Correct Answer
Giuseppe Larosa Thu, 05/06/2010 - 07:51

Hello Drojasug33,

unless you are trying to setup a Carrier supporting Carrier scenario you don't need to run MPLS on the CE router

so the commands

>>#

mpls ldp router-id Loopback0 force
#
mpls label protocol ldp

#

They Are not needed and they can be skipped

Be also aware that if you are going to run OSPF as PE-CE protocol you need to configure the PE nodes appropriately.

The OSPF process-id has to match on local VRF site and remote VRF siteto see remote site OSPF routes as O IA (inter area) otherwise they will be seen as O E2 or O E1 (external routes)

Also, you are expected to use area 0 with PE router (the so called superbackbone area) in order to be able to use multiple OSPF areas on CE router

Hope to help

Giuseppe

drojasug33 Thu, 05/06/2010 - 08:06

Thanks a lot for all your answers.

All were very helpful.

Regards,
Daniel

Ganesh Hariharan Thu, 05/06/2010 - 03:28

Hi,

I need help choosing a MPLS Customer Edge Router. I was thinking about the cisco 800 series, but using the feature navigator I could not find out if the ios has mpls capabilities. ¿Which is the smallest and cheapest Cisco Router with MPLS Capabilities?

Thanks in advance,

Daniel Rojas

Hi Daniel Rojas,

Reza is right CE router only routes IPV4 packets to PE,they do not participate in label switching as PE and P's used to.So you can go with 2800/2900/1800 series at CE end.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Actions

This Discussion