BGP community

Unanswered Question
May 6th, 2010
User Badges:

   Hello all,


   I need a solution for the following situation :


  The topology


       A transit AS with  a single internet router.


      The router has 2 BGP sessions with international providers and 2 BGP sessions with metropolitan providers. The connections are made without Vlans,on physical Gigabit interfaces.


      A client established 2 BGP sessions with the router.One is for international traffic, the second is for metropolitan traffic(to acomplish that used as-path acl). On both connections it advertises the same prefix x.x.x.x /21


        The problem:


   The problem is that all the traffic(international and metropolitan) coming into the router(inbound)   prefers the Client BGP session for international traffic.


    Metropolitan traffic should prefer the metropolitan session. In fact all inbound metropolitan traffic should take the path through the client metropolitan BGP session.


     The solution with a second machine for one of the 2 client BGP session is out of the question.


    How could this issue be resolved ?


   I am waiting for your answers.


    Thank you


   Bye


   A friend told me that with the community attirbute can be done but i dont know how .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Laurent Aubert Thu, 05/06/2010 - 07:14
User Badges:
  • Cisco Employee,

Hi,


If you want to prefer the metropolitan session with your customer for all the returning traffic, you have several solution:


- Configure AS-Prepend on customer router so the AS-PATH via the international session is longer.

- Configure higher Local-preference on the transit router for the prefix received on the metropolitan session

- Configure different MED on the customer router, so the prefix received on metropolitan session is preferred.


http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#sec2


HTH


Laurent.

adi822001 Tue, 05/25/2010 - 10:16
User Badges:

  Thank you for the answer.


But did not resolved my problem, because with those techniques all traffic will follow or metropolitan session or the international  BGP session.


   I need something  , that only  the metropolitan traffic  goes to the BGP metropolitan session.The other traffic should use the other  connection.

Mohamed Sobair Tue, 05/25/2010 - 11:02
User Badges:
  • Gold, 750 points or more

Hi Adrian,


Now I got your message clearly !!


here is the solution for your problem, you will need to set the local preference or weight to accomplish this, (I am assuming here you have your own public Network) :-


router bgp xxxx


neighbor x.x.x.x. route-map metropiliton in

neigbor y.y.y.y weight 900



route-map metropiliton per 10

match ip address prefix-list metropiliton

set weight 1000


route-map metropiliton per 20


ip prefix-list metropiliton seq 5 permit x.x.x.x/x (metropiliton Networks)


-------------------------------------------------------------


with this setup, for any traffic destined to Metropiliton , bgp prefer this path,   while the rest of the traffic takes the International path.



HTH

Mohamed

adi822001 Tue, 05/25/2010 - 11:27
User Badges:

Thank you Mohamed .


But who is neighbor x.x.x.x and neighbor y.y.y.y. If i put this on the BGP sessions with the client it will have no effect.


  Put them on international providers BGP sessions ?


  thank you

Laurent Aubert Tue, 05/25/2010 - 18:20
User Badges:
  • Cisco Employee,

Hi Adrian,


Ok, I see your problem now. The issue is your customer is announcing the same subnet from both session so BGP on your router has to select a best path. We can manipulate BGP attribute to influence the decision but it can be only one path (you can still install both in the routing table if you want to do load-balancing).


What you want to do is to select a path based on the source interface on which you received the traffic (international or metropolitan providers). To do that, you have to configure PBR on those interfaces to bypass the routing table.


Routing the customer traffic is easy ans natural if the metropolitan subnets are different from the international ones.


HTH


Laurent.

adi822001 Tue, 05/25/2010 - 23:18
User Badges:

  Hi Laurent,


Thank you for the answer, that is the issue.


Can you give me an example of a route-map to put on the metro and international  traffic enabled interfaces.


But, there are 13.000 metropolitan prefixes. I have filtered them with as-path acl .


  And other thing, unfortunately the router doesn,t support PBR  

Laurent Aubert Wed, 05/26/2010 - 06:12
User Badges:
  • Cisco Employee,

Which platform is it ? running which version? PBR is widely supported on our routers portfolio.


Thanks


Laurent.

adi822001 Thu, 05/27/2010 - 02:17
User Badges:

  It is not a Cisco router. It,s Huawei Ne40. But we will changer it with a Cisco 7606.


  Can you write a route-map to put on the metro and interantional traffic enabled interfaces?


   Thank you 

Laurent Aubert Thu, 05/27/2010 - 05:43
User Badges:
  • Cisco Employee,

Hi Adrian,


Thanks for the update. Here is configuration template you could use:


route-map METRO permit 10

  set ip next-hop

!


route-map INTER permit 10

  set ip next-hop

!

interface eth a/b

descr peering with Metropolitan SP

ip  policy route-map METRO

!


interface eth x/y

descr peering with International SP

ip  policy route-map INTER

!


The config above assume you have a single customer connected to your transit router so 100% of the traffic received from International or Metropolitan backbone will be send to this customer. If you have other customers connected to the router, we need to restrict the traffic as the following:


access-list 101 permit ip any 0.0.7.255

!


route-map METRO permit 10

    match ip address 101

  set ip next-hop

!


route-map INTER permit 10

    match ip address 101

  set ip next-hop

!



HTH


Laurent.

adi822001 Thu, 05/27/2010 - 09:49
User Badges:

Thank you very much Laurent .


Helpful template .


If any other issues can i mail you ?


Still i,m curios if could resolve this without PBR. With the community attribute ..



Actions

This Discussion