WAAS OPTIMIZATION PROBLEM

Unanswered Question
May 6th, 2010
User Badges:

Hi,

 

I have a waas deployment.  I have a WAE512 as Manager, and other as accelerator (working in in-line mode) in the central site.In the remote office, i have a 2811 ISR with a NME-WAE-502 (with wccp mode).

 

From the Manager, i can see the 2 WAE's (WAE512 and NME502), and it's ok!

When i tried to do a FTP file transfer with WAAS turn on, on the Manager i can see the connection and the applied policies (TFO, DRE, LZ). And i can see the graphics, the real traffic versus the optimized traffic, and the optimized traffic percentage. and it's ok!!!

 

But when you see the real time that spent the file (size file = 7MB) to transfer from de central site to the remote site, you see that the transfer latest 5 minutes. it's not ok!!

If i turned off the waas, and do the same transfer, the transfer latest just 20 seconds.

 

So My question is: Why do i get this result? , what is wrong?

 

The versión of waas is 4.1.1.c in all the WAE's.

 

The config of the central WAE accelerator (in-line mode)is:

 

WAAS version 4.1.1c (build b16 Nov  5 2008)
!
device mode application-accelerator
!
!
hostname WAE-CORE
!
clock timezone CST -6 0

 

!
primary-interface GigabitEthernet 1/0
!
interface GigabitEthernet 1/0
ip address 132.247.196.100 255.255.255.0
no autosense
bandwidth 100
full-duplex
exit
interface GigabitEthernet 2/0
shutdown
exit
!
interface InlineGroup 1/0
inline vlan all
no autosense
bandwidth 100
full-duplex
exit
interface InlineGroup 1/1
inline vlan all
shutdown
exit
!
!
ip default-gateway 132.247.196.254
!
no auto-register enable
!
! ip path-mtu-discovery is disabled in WAAS by default
!
ntp server 132.247.251.245
!
central-manager address 132.247.197.1
cms enable

 

The config of the NME-WAE502 AND ROUTER 2811:


ip wccp 61
ip wccp 62
!
!
ip cef
!

interface Loopback0
ip address 111.111.111.111 255.255.255.0
!
interface FastEthernet0/0
description LAN
ip address 132.247.195.1 255.255.255.0

ip wccp 61 redirect in
duplex full
speed 100
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0
description Enlace WAN
bandwidth 2000000
ip address 132.247.194.1 255.255.255.0

ip wccp 62 redirect in
fair-queue
clock rate 2000000
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
interface Integrated-Service-Engine1/0
ip address 10.0.0.1 255.255.255.0
ip wccp redirect exclude in
service-module ip address 10.0.0.100 255.255.255.0
!Application: Restarted at Thu Apr 29 15:56:29 2010
service-module ip default-gateway 10.0.0.1
no keepalive
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 132.247.194.2

--------------------------------------

hostname NM-WAE-502

 

primary-interface GigabitEthernet 1/0

 

interface GigabitEthernet 1/0
ip address 10.0.0.100 255.255.255.0
no autosense
bandwidth 1000
full-duplex
exit
interface GigabitEthernet 2/0
shutdown
exit
!
ip default-gateway 10.0.0.1
!
no auto-register enable
!
! ip path-mtu-discovery is disabled in WAAS by default
!
ntp server 132.247.251.245
!
!
wccp router-list 1 10.0.0.1
wccp tcp-promiscuous router-list-num 1
wccp version 2
!
egress-method negotiated-return intercept-method wccp

!

central-manager address 132.247.197.1
cms enable

 

 

i'm not sure, if the wccp config that i applied on the NME-WAE502 is correct. and could be the source of my problem.

 

Someone can help me?

 

thanks a lot!!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aravind Vincent Thu, 05/06/2010 - 18:05
User Badges:
  • Cisco Employee,

I see the inline interface bandwidth configured for 100 Mbps. Can you configure 1000 Mbps ?


interface InlineGroup 1/0
inline vlan all
no autosense
bandwidth 100
full-duplex

tona_2008 Fri, 05/07/2010 - 08:29
User Badges:

I have 100 Mbps in the inline group, because  the interface switch and interface router atached to these inline group, are in: 100Mbps full duplex.


Something else?

Zach Seils Fri, 05/07/2010 - 12:38
User Badges:
  • Cisco Employee,

Can you provide the output from show interface on each one of the WAE interfaces?


Thanks,

Zach

tona_2008 Mon, 05/10/2010 - 09:19
User Badges:

Sure, the interfaces output:


WAE-512 INLINE MODE (CENTRAL WAE):


WAE-CORE#sh interface inlinegroup 1/0
Interface is in intercept operating mode.
Standard NIC mode is off.
Disable bypass mode is off.
VLAN IDs configured for inline interception: All
Watchdog timer is enabled.
Timer frequency: 1600 ms.
Autoreset frequency 500 ms.
The watchdog timer will expire in 1554 ms.


Inline Port Statistics Of The Group:
------------------------------------

WAN Port :
===========
Device name        : eth4. Bypass master interface.
Packets Received   : 3158324
Packets Intercepted: 1261139
Packets Bridged    : 1898640
Packets Forwarded  : 1812238
Packets Dropped    : 4
Packets Received on native      : 0
Active flows for this interface : 0

Ethernet Driver Status
-------------------------
Type:Ethernet
Ethernet address:00:E0:ED:09:5B:56
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 3158319
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 13177347
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:100
Collisions: 0
Base address:0x4080
Flags:UP BROADCAST RUNNING MULTICAST

LAN Port :
===========
Device name        : eth5. Bypass slave interface.
Packets Received   : 13148433
Packets Intercepted: 9015886
Packets Bridged    : 11365120
Packets Forwarded  : 1242732
Packets Dropped    : 0
Packets Received on native      : 0
Active flows for this interface : 0

Ethernet Driver Status
-------------------------
Type:Ethernet
Ethernet address:00:E0:ED:09:5B:57
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 13148431
Input Errors: 49093
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 49093
Packet Sent: 3141371
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:100
Collisions: 0
Base address:0x40c0
Flags:UP BROADCAST RUNNING MULTICAST
WAE-CORE#sh interface inlineport 1/0/lan
Device name        : eth5. Bypass slave interface.
Packets Received   : 13148913
Packets Intercepted: 9016141
Packets Bridged    : 11365589
Packets Forwarded  : 1242739
Packets Dropped    : 0
Packets Received on native      : 0
Active flows for this interface : 0

Ethernet Driver Status
-------------------------
Type:Ethernet
Ethernet address:00:E0:ED:09:5B:57
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 13148874
Input Errors: 49093
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 49093
Packet Sent: 3141439
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:100
Collisions: 0
Base address:0x40c0
Flags:UP BROADCAST RUNNING MULTICAST
Mode: full-duplex, 100baseTX
WAE-CORE#sh interface inlineport 1/0/wan
Device name        : eth4. Bypass master interface.
Packets Received   : 3158419
Packets Intercepted: 1261154
Packets Bridged    : 1898720
Packets Forwarded  : 1812276
Packets Dropped    : 4
Packets Received on native      : 0
Active flows for this interface : 0

Ethernet Driver Status
-------------------------
Type:Ethernet
Ethernet address:00:E0:ED:09:5B:56
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 3158416
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 13177990
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:100
Collisions: 0
Base address:0x4080
Flags:UP BROADCAST RUNNING MULTICAST
Mode: full-duplex, 100baseTX

NM-WAE-502, (WCCP MODE):


NM-WAE-502#SH INTErface GIgabitEthernet 1/0
Type:Ethernet
Ethernet address:00:16:9D:39:52:29
Internet address:10.0.0.100
Broadcast address:10.0.0.255
Netmask:255.255.255.0
Maximum Transfer Unit Size:1500
Metric:1
Packets Received: 230
Input Errors: 0
Input Packets Dropped: 0
Input Packets Overruns: 0
Input Packets Frames: 0
Packet Sent: 92
Output Errors: 0
Output Packets Dropped: 0
Output Packets Overruns: 0
Output Packets Carrier: 0
Output Queue Length:1000
Collisions: 0
Base address:0xcc00
Flags:UP BROADCAST RUNNING MULTICAST
Mode: full-duplex, 1000baseTX

Best regards,

Zach Seils Mon, 05/10/2010 - 11:35
User Badges:
  • Cisco Employee,

The interface outputs seem fine, although the packet counters on the NME seem kind of low.


What do you see in the output of sh stat conn on both devices?


Zach

finn.poulsen Thu, 05/20/2010 - 04:14
User Badges:
  • Silver, 250 points or more

Hi,


The 2811 router config in the attached ZIP file does not match the one shown in the body.

The attached config does not have any ip wccp xx redirect statement configured.

This would lead to the NME only registrering to the Router (through WCCP) but not receiving any redirected packets from the router.

This could explain the low packet counts on the NMEs GigabitEthernet 1/0.


Please attach output of "show wccp routers" from the NME module to verify WCCP registration.


This can't explain the real time delay though.


Ups : Sorry : missed it in the zip file from the NME



Best Regards


Finn Poulsen

tona_2008 Wed, 09/08/2010 - 10:59
User Badges:

Hi, the problem was an mismatch duplex interface on a foundry switch. The problem wasn't with cisco, Now all is fine!!!


thanks!

Actions

This Discussion