CUP not updating OCS status when user ends call

Unanswered Question
May 6th, 2010

Hi All,

I have an issue where, when a user places/receives a call their MOC status shows them as "on a call", 99% of the time when they end the call the MOC status changes back to what ever is was set to, i.e. Available.

The 1% of the time is will stay "in a call".

Now I have managed to trace a call from the CUP server and when the status updated correctly I can see a SIP message "ConnectionClearedEvent", however when the status does NOT change back there is no "ConnectionClearedEvent" in the SIPProxy trace file.

So I am assuimg that some thing between CUCM and CUP is failing everynow and again.

I am having a mental black and need to be pointed to the CUCM process that would pass the information to the CUP server.

CUCM 6.1.5.10000-10

CUP 7.0.3.10000-63

Any other help would be appreciated too..

Cheers

Jason

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
htluo Fri, 05/07/2010 - 06:24

I would recommend you upgrade to CUPS 7.0.8 before troubleshooting.

In each relase between 7.0.3 and 7.0.8 there are some OCS bugs fixed.  Not saying that upgrade would fix your problem.  But at least it would rule out the known defects.

If there's no CSTA (INFO) message sent to OCS, the problem would be on CUPS side.  It could be the CUPS lost its connection with CTIManager thus not able to get CTI event updates.

Michael

http://htluo.blogspot.com

Actions

This Discussion