SipDroid Client on CUCM 7

Answered Question
May 7th, 2010
User Badges:

Hey,



Prevoisly i've managed to get Nokia phones running on SIP (and SCCP) but i'm struggling to get my Android phone registered using SipDroid client. Has anyone managed to get their Android phone registered to the call manager using any 3rd part Android SIP client.



TIA,

Eoin.

Correct Answer by William Bell about 7 years 1 month ago

Well, I don't have information on Droid (but want to go get the phone to test now!).  Here is a write up on registering SIP clients using X-Lite as an example (should be very similar):


http://www.netcraftsmen.net/resources/blogs/sip-endpoints-in-cisco-cucm-x-lite-as-an-example.html



and one using iPhone as an example:


http://www.netcraftsmen.net/resources/blogs/sip-endpoints-in-cisco-cucm-acrobits-softphone-and-weephone-for-iphone.html



HTH.


Regards,
Bill

Please remember to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
David Hailey Fri, 05/07/2010 - 04:44
User Badges:
  • Purple, 4500 points or more

I think your previous thread was fine...lots of peope ask related questions within another thread.  Nonetheless, take a look at the following blog I wrote:


http://www.netcraftsmen.net/resources/blogs/sip-endpoints-in-cisco-cucm-acrobits-softphone-and-weephone-for-iphone.html?blogger=David+Hailey


This focuses on 2 iPhone SIP clients, but that doesn't matter.  Just follow the setup and if you need further assistance - let me know.


Hailey


Please rate helpful posts!

Correct Answer
William Bell Fri, 05/07/2010 - 04:45
User Badges:
  • Purple, 4500 points or more

Well, I don't have information on Droid (but want to go get the phone to test now!).  Here is a write up on registering SIP clients using X-Lite as an example (should be very similar):


http://www.netcraftsmen.net/resources/blogs/sip-endpoints-in-cisco-cucm-x-lite-as-an-example.html



and one using iPhone as an example:


http://www.netcraftsmen.net/resources/blogs/sip-endpoints-in-cisco-cucm-acrobits-softphone-and-weephone-for-iphone.html



HTH.


Regards,
Bill

Please remember to rate helpful posts.

paolo bevilacqua Fri, 05/07/2010 - 05:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I think your previous thread was fine...lots of peope ask related  questions within another thread


Previous thread was about sharing DN's on CME, that one is about registering Droid to CM.


Seem proper and correct to me, the fact that things often are not done right is not a reason to have them done wrong again.

eoinwhite Fri, 05/07/2010 - 06:24
User Badges:

Made a bit of progress but i still can't get it to succesfully register. The client returns a "Registration failed (400 Bad Request)".


Is there a way to packet capture directly on the call manager to get more info ... I think i did something simluar before not to sure.

eoinwhite Fri, 05/07/2010 - 07:02
User Badges:

Got it working ... sort of. Its registered ... I wasn't putting in the correct username (extension) our extensions have are 4 digits as follows \+xxxx once i dropped the \ it worked.


However there is no audio on calls ... must be a codec issue, i'll play around and see if I can get it working.

David Hailey Fri, 05/07/2010 - 07:07
User Badges:
  • Purple, 4500 points or more

Your extensions include a "\" ?

eoinwhite Fri, 05/07/2010 - 07:16
User Badges:

Not really ... long story, the \ was used to integrate UCM with very early versions of Microsoft OCS.

eoinwhite Fri, 05/07/2010 - 08:07
User Badges:

Weird .. when I make a call I have two way audio ... when I receive the call I have no audio.

mrojasgue Tue, 07/27/2010 - 08:05
User Badges:

I did it this way:


I added an user with the number of the phone to use (i.e. 682). To simplify, the password and pin was 682 too. I also added this user to the Standard CCM End Users and Standard CTI groups. Very important: the digest credentials have to be the same as password (I think SIP clients use the Digest Credentials as the validation).


Then I registered the Android device (HTC Desire) to CUCM using the MAC, as an Advanced Third Party SIP Phone, I added the name of the SIP user as the "Owner User ID" in the device configuration and checked the Media Termination Point Required box.

Then in Line Configuration I added the same user to "Users Associated with Line".


In the phone, the server was the IP address of the CUCM and user/ pass registered in the CUCM.


Hope it works for you!


Using CUCM 6.1, HTC Desire and the latest version of Sip Droid

Tracy Larson Tue, 07/27/2010 - 14:45
User Badges:
  • Silver, 250 points or more

This has been very helpful. I have my droid registered when i call the droid from my desk phone we can talk and everything works great. When i place a call from the droid it fails, any clue why?

mrojasgue Tue, 07/27/2010 - 14:50
User Badges:

Have you checked the Media Termination Point Required box in the SIP Phone registered in the CUCM? try checking it for both phones, restart them, maybe restarting the Droid would help. Could be a codec problem; when I make a call I see it coming out as G.722.

Tracy Larson Tue, 07/27/2010 - 14:59
User Badges:
  • Silver, 250 points or more

Yes I have done that, the phone wont work without the MTP checked. We are forcing PCMulaw on the droid so that seems to work fine as well. I have rebooted the Droid as well. I dont have an MTP checkbox for my 7970 to check.

mrojasgue Tue, 07/27/2010 - 15:05
User Badges:

Hmmm it could be the codec. In MTP Preferred Originating  Codec; I've got 711 ulaw. Maybe assigning a hardware transcoding resource will do the trick? When I stablish a call on my Desire, the call says "G.722 HD".

Tracy Larson Tue, 07/27/2010 - 15:14
User Badges:
  • Silver, 250 points or more

I have never messed with SIP until now, but would i need a SIP route pattern? I thought that was only for pointing to specific SIP trunks.

mrojasgue Tue, 07/27/2010 - 15:17
User Badges:

Nope, route patterns are to point to trunks or gateways. For SIP you just register the phone like a normal one; but since SIP uses authentication, a End User is needed to be configured and assigned. Try using the X-Lite softphones to validate your parameters?

Tracy Larson Tue, 07/27/2010 - 15:20
User Badges:
  • Silver, 250 points or more

I will give that a try, thanks a ton! I will report back what I found. Have to run to soccer practice now.

Tracy Larson Wed, 07/28/2010 - 06:51
User Badges:
  • Silver, 250 points or more

OK, got mine to work. I tried three different clients and all of them acted the same. ASIP, CMVOIP, and SIP Droid. So I tried one more 3CXPhone and it worked like a champ first go! Thanks for the help here, this is cool!

Neil Broadley Tue, 08/03/2010 - 06:26
User Badges:

SipDroid works perfectly here : Android 2.1 or 2.2, with CUCM 7.1.3.


Our users are LDAP integrated, so here's what I did :


In Call Manager :

1. Create a new SIP phone using the X-Lite instructions up top of this thread.  I had one-way audio until I enabled a Media Resource Group.

2. In that phone put the "Owner ID" and "Digest User" to my LDAP username.

3. Edit my user's digest credential to a password of my choice.  I went for something like "TestingNow".

4. Give my phone an extension.  In my case, I gave it the same number as my desk phone so that whenever someone calls me on my extension, my Android will ring too.

5. Give it a SIP profile which requires Digest authentication.  I copied the non-secure SIP device, then ticked the digest box and called it "Android SIP devices".


Then in SIPDroid itself, go to SIP account settings and put :

1. Authorization username = LDAP username (without any domain prefix - just the username).  THIS IS CASE-SENSITIVE!!!  Crazy, eh?

2. Password = Digest Credential

3. Server or Proxy = Call Manager (publisher or subscriber - up to you).

4. Domain = leave it empty

5. Username or CallerID = extension associated with your user

6. Port = 5060, I didn't touch this.

7. Protocol = UDP, I didn't touch this.  Both UDP and TCP work in my environment.


If it works, SipDroid will go green.  Once it's green, you should be able to see a registered status in CUCM phone status, although I've never managed (or bothered) to get it to be anything other than "untrusted".


Now, in Sipdoird if you leave "Preferred Call Type" as "SipDroid when available", you just leave SipDroid running as a background service and use your phone dialer as normal.  If you place a call while SipDroid can "see" the Call Manager, when you press the dial button, it will transparently kick in SipDroid to place the call.  When your desk phone rings, so will your Android.

mdress Thu, 11/11/2010 - 09:02
User Badges:

I have the basics up and running.  Seem to be able to make and take calls, np.  What I haven't been able to do yet is

place on hold and transfer callers.  Wonder why.  Any thoughts?

marcgq777 Wed, 11/10/2010 - 09:57
User Badges:

I can successfully register. I can make calls and take calls to only cisco DN's. We use a 9 before dialing an outside number and I think this is interfeering with my ability to do this. Any suggestions?

William Bell Mon, 02/28/2011 - 13:12
User Badges:
  • Purple, 4500 points or more

It is likely you have resolved this already. In my testing the SIP device should honor the CSS/Partition/Pattern configurations in a route plan just like other devices. The difference is that the 3rd party SIP device will typically want to use en bloc dialing instead of a digit-by-digit analysis. On CUCM, you can leverage KPML if the client software supports it. CUCM does have a concept of a SIP Dial Plan rules base. However, IIRC it doesn't apply to 3rd party SIP devices. So, given that not many clients support KPML you are left with en bloc dialing alone unless your client allows you to program a set of dial plan rules locally (e.g. X-Lite does this).


Anyway, just some thoughts. I am sure you have resolved this already.


HTH.


Regards,
Bill

ronniekendrick Mon, 02/28/2011 - 12:50
User Badges:

I used the information in this post to connect get SIP working on the built in SIP client with Android 2.3. Works great, except incoming calls do not work. There's probably a setting I'm missing and I'll post if I find it.

William Bell Mon, 02/28/2011 - 13:14
User Badges:
  • Purple, 4500 points or more

What isn't working with incoming calls? Is the station ringing at all? If so, check the region and codec configs on CUCM. If it is not ringing, check your dial plan.


You may also want to take a look at this article:


http://www.netcraftsmen.net/resources/blogs/sipdroid-cisco-cucm.html


I recently tested Sipdroid on my HTC Incredible. Works well. Though I have not tested on 2.3 (my tests and the blog were based on 2.2).



HTH.


Regards,
Bill

shepherdr Mon, 03/21/2011 - 12:17
User Badges:

I have this issue with CUCM at my workplace (an NHS hospital). The new Android 2.3 SIP stack authenticates okay and I can make calls no problem but cannot receive them. The phone doesn't ring at all. Other clients including csipsimple on Android, media5-fone on iOS 4 and the inbuilt SIP stack on a Nokia E71 work okay for making and receiving calls with the same account.


The native 2.3 client has very basic configuration options username (extension), server address and proxy settings but cannot set Authentication Digest username (just assumes it is the same as the extension - which in my case it is) nor can you set the realm. However since the phone can register and make calls I wouldn't think this would be the issue.


It works fine both ways with sipgate.co.uk


Any ideas?

Actions

This Discussion