Basic router config

Answered Question
May 7th, 2010
User Badges:

Hi,


I must be losing it. I'm setting up a 1721 router internally on my nework. I've configured both interfaces and both are up up. I've configured a default route and a name server but I can't seem to get it to route. can anyone see anything obvious?



Router#sho run
Building configuration...

Current configuration : 706 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jynz$4oGBbyDEp2dk17MPN3i3t/
enable password *******

!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
ip name-server 192.168.200.200
!
ip cef
!
!
!
!
interface Ethernet0
ip address 192.168.200.236 255.255.255.0
half-duplex
!
interface FastEthernet0
ip address 172.16.0.254 255.255.0.0
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.200.1
no ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Router#

Correct Answer by Jon Marshall about 6 years 10 months ago

Eggzter100 wrote:


The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.


What is the default-gateway set to on all devices on the 192.168.200.x network ?


If you can't ping the 192.168.200.1 address then check that device to see if it has a route for the 172.16.0.0 pointing back to 192.168.200.236.


It sounds like all the 192.168.200.x devices are using a default-gateway that is not your router ie. probably the 192.168.200.1 device and this is missing a route.


Note that if you have no control over the 192.168.200.1 device then you can NAT your 172.16.x.x addresses to 192.168.200.236 so that the 192.168.200.1 device would know where to send return packets but it would be easier to configure a route on the 192.168.200.1 device if you have access eg.


ip route 172.16.0.0 255.255.0.0 192.168.200.236


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Reza Sharifi Fri, 05/07/2010 - 06:12
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


Can you ping the opposite site of each interface ie 192.168.200.1?


Reza

Eggzter100 Fri, 05/07/2010 - 06:20
User Badges:

From inside the 172.16.0.0 network I can't ping 192.168.200.1. From the router I can ping both sides. The default gateway from the 172.16.0.0 network is 172.16.0.254.

burleyman Fri, 05/07/2010 - 06:24
User Badges:
  • Blue, 1500 points or more

I don't see a route to the 172 network?


Mike

Reza Sharifi Fri, 05/07/2010 - 06:25
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

From inside the 172.16.0.0 network can you ping 192.168.200.236?

Do you have the correct default on the device your pinging from?

burleyman Fri, 05/07/2010 - 06:28
User Badges:
  • Blue, 1500 points or more

I think you could add this and it would work


ip route 172.16.0.0 255.255.0.0 FastEthernet0



Mike

Eggzter100 Fri, 05/07/2010 - 06:49
User Badges:

The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.

Correct Answer
Jon Marshall Fri, 05/07/2010 - 07:50
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Eggzter100 wrote:


The IP Route 172.16.0.0 255.255.0.0 fastethernet0

And IP Route 192.168.200.0 255.255.255.0 ethernet0

commands didn't work. I still can't ping anything on the 192 network except 192.168.200.236.


What is the default-gateway set to on all devices on the 192.168.200.x network ?


If you can't ping the 192.168.200.1 address then check that device to see if it has a route for the 172.16.0.0 pointing back to 192.168.200.236.


It sounds like all the 192.168.200.x devices are using a default-gateway that is not your router ie. probably the 192.168.200.1 device and this is missing a route.


Note that if you have no control over the 192.168.200.1 device then you can NAT your 172.16.x.x addresses to 192.168.200.236 so that the 192.168.200.1 device would know where to send return packets but it would be easier to configure a route on the 192.168.200.1 device if you have access eg.


ip route 172.16.0.0 255.255.0.0 192.168.200.236


Jon

Eggzter100 Sat, 05/08/2010 - 02:57
User Badges:

Hi Jon,


Yeah, I got there in the end. Thanks for your input though.


Regards


Egg

Eggzter100 Fri, 05/07/2010 - 06:32
User Badges:

I can ping the 192.168.200.236 address from the 172 network which has got the correct gatway configured, but I can't pin anything else on the 192 network.

Reza Sharifi Fri, 05/07/2010 - 06:35
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

can you check to see if 192.168.200.1 is actually configure on that device. Is it another router?

Eggzter100 Fri, 05/07/2010 - 06:41
User Badges:

Yes it's another router out to the internet and the default gateway from the 192 network.

Cisco Contracts Fri, 05/07/2010 - 12:36
User Badges:

Are you using a routing protocol?  I don't see one in the config.

do a "show ip route" and see what you get.

you'll probably just see two connected interfaces only.

If you use eigrp or ospf, they'll automatically grab the connected interfaces.


try this:


config t

router eigrp

network 192.168.0.0

network 172.16.0.0

!

end



That should get you moving right along.

Actions

This Discussion