Help with 2620xm home network with cable modem SB4100

Unanswered Question
May 7th, 2010
User Badges:

Hi everyone,


I'm trying to set up a home network with Cisco 2620xm (1fa) with cable modem SB4100 through a 2950 switch, but can't get it to work.


I set up 2 Vlans..  Vlan 10 fa port 2 for cable modem, Vlan 20 as access ports for the rest. Port 1 is set as trunk which connects to router.


Router has two sub interfaces fa0/0.10 172.16.1.0 as IP NAT outside network for Vlan 10 and fa0/0.20 192.168.1.0 as IP NAT INSIDE network for Vlan 20.


IP route 0.0.0.0 0.0.0.0 172.16.1.1
ACL was set as standard to permitting the networks and Nat is linked with ACL and set to overload.


There is a catch in which my ISP uses DHCP assigned ip, however, it hasn't changed for a very long time.


There are definite faults in my setup but I don't know exactly what it is or if it's even workable because I read on other forums that a 'NAT on a stick' is needed with a loopback address.


Also there is the problem with the cable modem with one max mac, so I switched CDP, Keepalives, STP off on port 2.


Can someone please point me to the right direction?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 05/08/2010 - 02:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matthew,

it is not clear if you have already done this.

However, you can make the router to get an ip address by DHCP service on cable modem like a PC by using


int f0/0.20

enc dot1q 20

ip address dhcp

no shut


on C2950 the only ports in vlan20 have to be port to cable modem and trunk port to router fas0/0


you can also use the DHCP option in a static route like


ip route 0.0.0.0 0.0.0.0 dhcp


in order to be able to deal with possible changes over time


on switch port to cable modem:


no cdp enable

spanning-tree bpdufilter enable


switchport nonegotiate

! to switch off DTP


you don't need a loopback in your setup.


Hope to help

Giuseppe

Paktol1088 Sat, 05/08/2010 - 13:04
User Badges:

Hi Giuslar,


Thanks for your reply, I've tried a number of diferrent config based on your reply but it's still not working.


Fristly, what do I do with the other vlans? move all access ports to vlan 1?


second, 0.0.0.0 0.0.0.0 'DHCP' isn't an option with my router.Is this normal?


Port fa0/1 is set as trunk and fa0/2 (cable modem) is on it's own vlan

Giuseppe Larosa Mon, 05/10/2010 - 02:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Matthew,

sorry I did an error the syntax to use the DHCP option in a static route is:

! checked on a C2811 with 12.4(15)T


ip route 1.1.1.1 255.255.255.255 f0/0 dhcp ?


so in your case becomes


ip route 0.0.0.0 0.0.0.0 f0/1.10 dhcp


>> Fristly, what do I do with the other vlans?


if you have other vlans / IP subnets and you want them to access the internet you need to add ip nat inside under the Layer3 subinterface


all LAN switch ports should be in a vlan different then vlan 10 or some user can access directly the cable modem.

in vlan 10 you should have only the trunk port to router and the port to cable modem



Hope to help

Giuseppe

Actions

This Discussion

Related Content