cucm 8 on vmware

Unanswered Question
May 8th, 2010

Hi all,

M trying to install CUCM 8.0 (1) on VMWare Workstation 5.0, tried following settings:

OS: Redhat linux 2 and with Redhad linux 4

SCSI HDD 1 (0:0) 72GB

OS: Redhat linux 2 and with Redhad linux 4

SCSI HDD 1 (0:0) 80GB

OS: Redhat linux 2 and with Redhad linux 4

SCSI HDD 1 (0:0) 72GB

SCSI HDD 2 (0:1) 72GB

OS: Redhat linux 2 and with Redhad linux 4

SCSI HDD 1 (0:0) 80GB

SCSI HDD 2 (0:1) 80GB

Every time I am getting the error during hardware check :

                 Critical Error

Validation error on HSSI mode:

VMWare Validation Failure:

Unable to validate VMWare based server disk settings.

Please check SCSI disks are at least 72GB in size and are located at 0:0 (and 0:1 in a two disk config) in machine settings.

My hardware is AMD Quad-Core with 4GB Ram. Attaching the screen-shot of the error also. Has anyone seen this error and knows any workaround?

Thanks in advance,

inner_silence

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (4 ratings)
Jonathan Schulenberg Sat, 05/08/2010 - 14:17

On top of only working with ESXi  (ESX works but isn't supported by the BU), you will likely only get this to work on Intel processors. Also note that VMware support technically wasn't added until 8.0(2).

techguy73 Mon, 05/10/2010 - 21:16

Trying to get CUCM to work on AMD system is a nightmare, which I haven't realized until I was faced with one.

I can't say much about CUCM 8, however in case of CUCM 7.x, I did a workaround this to get it to work on a quad-core AMD system by building the server on Intel machine and then transfering the vm-ware image to the AMD system. This should work for most of the functionality, however there are still some items you'll have problems with, such as you won't be able to play with MOH, as the server won't register on AMD machine for some reason.

William Bell Tue, 05/11/2010 - 20:52

Not that this is hugely relevant but I was able to get 8.0 loaded on vmware server 2.0.  Intel - not AMD.  I just completed the build so I have not fully tested the functionality.

Aaron Harrison Wed, 05/12/2010 - 01:27

Hi

I got 8.0(1) to run in Workstation fine, but then tried to upgrade to 8.0(2), and it failed.

I then resorted to building myself a little ESXi setup, and migrating the VM using a converter. Still had some problems, so then went to a Cisco-UCS spec VM (6GB, 2CPU, SCSI HDD at 0:0) and all was well. At this stage I'm wondering whether it was the switch to ESXi, the VM spec changes, or both that were required.

Aaron

mmendonca Fri, 06/25/2010 - 07:09

I'm getting the same error from system install CD CUCM 8.0(1) on: ESXi 4.0 Update 1 with Intel duo core's 2 GB ... and only an 80 G HD.

Unable to validate VMWare based server disk settings.

Please check SCSI disks are at least 72GB in size and are located at 0:0 (and 0:1 in a two disk config) in machine settings.

The virtual host is formatting the HD into several different partitions leaving only 60G of usable space.  I realize that this is a Cisco related forum I will also ask this on vmware.com forum but does anyone know of a way to get the datastore to format differently?

htluo Fri, 06/25/2010 - 07:15

Might not be the answer you want to hear, but you'd better upgrade the HDD.  With only 80G HDD, you'd run into problem either with ESX or with CUCM.

1TB (1000GB) HDD is around $50 nowadays.  It'll save you lots of trouble.

Michael

http://htluo.blogspot.com

mmendonca Fri, 06/25/2010 - 07:18

Yep already in processg I'm just impatient and would like work out any other problems prior to it.  Thanks.

Aaron Harrison Fri, 06/25/2010 - 10:26

Hi


I install my ESXi hypervisor onto a USB key; that way the disks are independant and can be bungled in to one big array to maximise space. I find a 2GB key is plenty.

Secondly, you can use 'thin' provisioned disks rather than provisioning all space; I've not run out of space with a CCM even after upgades and on my smallest server with only 60GB storage.

Regards

Aaron

mmendonca Fri, 06/25/2010 - 14:58

That got me by that error.  Thanks Aaron.  Now I'm getting all the way to the end of the install it reboots then it comes back with "Installation failed you must restart the install to recover". 

mmendonca Tue, 07/06/2010 - 11:59

Still stuck with this error:

I've tried everything I could think of and researched... not production but I'd like to get it working!

mmendonca Fri, 07/16/2010 - 11:29

I have a similar problem see my previous post to this discussion.  I really beleive that my problem is relative to this error message that I get prior to the failure:

error opening /common/log/install/initial_hardware_info.dat

Then it goes and eventually fails at the point I have illustrated.  It seems that UC installed but it won't boot and I can't figure out how to edit the file system without it being up and running.

mmendonca Thu, 07/22/2010 - 06:16

Found a sobering post today on another forum.  User complained about another user 'hijacking' his thread.  He said it wasn't proper ettiquette.  Guess that's what I've done here and several other times I won't do that anymore my apologies to anyone I may have offended.

Mark

l.checkon Mon, 07/26/2010 - 07:00

I was able to load CCM 8 on VM workstation 6.5 with 2gb of memory and 80gb HD.

mmendonca Sat, 07/31/2010 - 05:49

I know I said I wouldn't hijack posts anymore.  I feel this is relevant and may help someone who is searching and may be having the same problems I was.

I searched this forum for CUCM_7500_user_v1.0_vmv7.ova with no results. I was finally was able to create a VM CUCM 8.0(1) using this template. From the Vshpere Client under the file options menu is the option to 'Deploy OVF template'.  Choose it it's intuitive from there.  Then you can install CUCM on the VM.  Make sure to check the box 'connect DVD at startup' and check the box under options to 'boot from BIOS'  then boot off the install disk.

You can find the template on cisco.com on the download software pages for CUCM.

I will also go back and try to create one using the spec's that are in this thread.

marcobrugge@cap... Fri, 08/20/2010 - 02:52

I did the same as you mentioned created a  VM CUCM 8.0(1) using this template but still have the same error that the installation has failed. It doesn't matter if I am doing it manual or via the template and I do have a ESXI server.

I still see the

Error not sure if this is related but did anyone got it to work with this error?

Hope to here from you guys soon.

Regards,

Marco

captin1979 Wed, 08/04/2010 - 12:03

To Fix this error in the ESX 4,

Set the Drive to 73GB, will let you install the CCM8 on it.

mmendonca Fri, 08/20/2010 - 06:31

Marco,

Sounds like you did you the .ova template to create your vm machine correct?  It's difficult to see the screen shot (maybe you should attach it) that you posted but it doesn't appear to show the failure only that it's in the hardware detection phase of the install.  Is that correct?

Also I would post more specifics about your platform for everyone to see.

Thanks,

Mark

kinwai Fri, 08/20/2010 - 06:42

Hey guys,

I have included a link which consists of screenshot of the configuration for cucm802c which is working for me on workstation 7.1.0 and esxi 4.1.0

http://img34.imageshack.us/img34/826/cucm802.png

Basically i used 80gb x 2 hdd (ignore the non presistent part) , 2gb ram , 2 x CPU

Cheers,

Kin Wai

captin1979 Fri, 08/20/2010 - 06:50

Here is the link where  you can download the OVA,

if you still have issue let me know the exact error.  let me see what i can do.    

Downloading Virtual Machine Templates (OVA Templates)

The configuration of a Cisco Unified Communications Manager virtual machine must match a supported virtual machine template.

Perform the following procedure to obtain the virtual machine template for Cisco Unified Communications Manager on the Cisco UCS C210 Rack-Mount Server:

Procedure

Step 1 Select this URL in your browser:

http://tools.cisco.com/support/downloads/go/Redirect.x?mdfid=278875240

Step 2 If your browser prompts you to do so, type your Cisco.com User Name: and Password: in the text boxes, then click the Log In button.

Step 3 Choose IP Telephony > Call Control > Cisco Unified Communications Manager (CallManager) > Cisco Unified Communications Manager Version 8.0.

Step 4 Click the Unified Communications Manager Virtual Machine Templates link.

Step 5 In the Latest Releases folder, click the 1.0(1) link.

Step 6 Click the Download Now button. Follow the prompts and provide the required information to download the software.

Step 7 When the Download Cart window displays, click the "Readme" link to view the virtual machine template's release information.

marcuswentrcek Fri, 09/10/2010 - 18:40

Here is what I did with the Cisco Unity Connection 8.02 using VMWare 7.X

When you get the error that it wants it on scsi 0:1 and 0:2 - try using scsi 0:0 and 0:1 instead.  Naturally I installed VMWare on a seperate drive from my OS.

It was successfully install without ESXi.  I would stay far away from VMWare Server.

Hope this helps.

Marcus Wentrcek

alf@de.ibm.com Thu, 09/16/2010 - 13:35

Hi Team,

I have a quite old MCS 7835I (2GB RAM, 2 x 72 GB Disk and Intel Xeon CPU 3.4 Mhz), which I use for Lab purposes.

Up to CUCM V7.1 this one worked fine. CUCM V8 does not support this Hardware natively (I assume because of the Disks), therefore I am trying to make it working as guest system under ESXi 4.1 and the OVF Template from CCO.

I splitted up the RAID which brings 135 GB Disk space in the datastore of VMWare and I´ve selected "Thin Provisioning" due to limited disk space.

The installation of CUCM 8.0(3) starts fine (Formatting, Install OS, Copy Backup Archive) but during

Application Pre-Install it ends up in a unrecoverable Error. The Installation halts and the system offers

to write a dump.

Any ideas or suggestions are welcome.

regards

Alfred

marcuswentrcek Thu, 09/16/2010 - 13:45

Can you post the error?

My initial thought would be the RAID settings.

Disk and RAM are correct.

When it offers a dump use your USB device to grab it and submit it.

Regards,

Marcus Wentrcek

alf@de.ibm.com Sat, 09/18/2010 - 10:50

@Marcus, thx for your answer.

I think its to late in the installation process for a RAID issue.

Here is the error message:

Application-Pre Install
Package: # 35 of 76

Critical Error
The installation has encountered a unrecoverable internal error.
For further assistance report the following information to your support
provider.

Command
"/usr/local/bin/base_scripts/pmNormalizeGeneric/tmp/ipmWorkfile"
has exceeded timed threshold of 90 seconds

The system will now halt.

Continuing will allow you to collect diagnostic
information before halting.

I am still looking how to get a more detailed installation-log or even to analyze the

dump information.

alf@de.ibm.com Sat, 09/18/2010 - 11:01

I took a look into CSCsg78450:

Install fails when pmNormalizeGeneric exceeds 90 second threshold

Symptom:
Install fails with an error about /usr/local/bin/base_scripts/pmNormalizeGeneric has exceeded timed threshold


Conditions:
This  happens when there is a media error on the DVD that prevents reading  the DVD.  We have also seen it happen during an network outage when  installing over then network.


Workaround:
Please  try a different DVD or CD drive.  Or, if installing over the network  please review all firewall, MTU, NAT or other applicable settings.

I use an ISO-Image File from my Client Workstation and the media check was successful. Direct LAN connection between Workstation and ESXi Server. However, I will also try to install directly from DVD.

alf@de.ibm.com Sat, 09/18/2010 - 14:02

Tested with direct installation from DVD within ESXi-Server. Same Result as above.

I cannot see the dependency on the data transfer of the install media (described in CSCsg7845),

as the copy of the files on the DVD is already completed at this point.

Aaron Dhiman Sat, 10/16/2010 - 05:33

5* for you Marcus.  Thanks for the screenshot.  I was able to get this working on VMWare Server.  The keys to getting it to work were using RHEL 4 and 80GB Dual HDD.  Got errors when either of those wasn't configured.

cvoisin Sat, 09/18/2010 - 21:42

The solution to fix your issue is simple as I was just experiencing the same problem.  The problem you are having is with the SCSI controller that VMware defaults to use when creating new VMs.  You need to change your SCSI controller over to an LSI Logic SAS controller under the CUCM 8.x VM.  I quickly made a scratch VM to show you, but the default controller type is paravirtualize.  Once I changed my controller over it worked like cake.

cisco steps Sat, 10/02/2010 - 19:51

I am still in the installation process of vmware 7 w/ cucm 8. my cisco router is configured w/ an Ip 192.168.1.2 and its gtwy is .1 . when I give the CM an ip of 192.168.1.100/24 gtwy .1 and the NTP 192.168.1.2/24 still get the same message of the network is unreachable so I hit ignore then was presented w/ NTP config I put in Ip address 192.168.1.2 and I hit test I get an error Inaccessible..I could not pass beyond this point.. so I am thinking that my virtual nic is not communication w/ router. anyone that help I appreciated.

ty

Anas Hazeen Sun, 10/03/2010 - 00:22

I installed CUCM 8 on VMware 7 successfully with these sepcification :

Mem     2048MB

Proc     1

Hard     100G SCSI

Net       Bridged

and regarding to NTP, it should ask you at the beginning that if you will use NTP or not

but if this option not appear for you , put the public IP for NTP 127.127.1.0  and after complete the installation remove NTP

cisco steps Sun, 10/03/2010 - 12:37

Thanks Anas ... the problem here is that I have no visibility to the Internet for me to put a public ip. I tried and still no go . I need to get VMWARE to see my router for me to get out to the Net . still struggling w/ it. I also attached some of screen shot on the same forum. " cucm 8 on vm 7.1".

Thanks

Karim

Justin Brenton Sun, 01/23/2011 - 10:15

Hi There,

I have gotten this to work on a AMD Processor by first loading it on a Intel based PC in VMware Server 2,  once completed I used the VMware Standalone Converter to convert the machine.  I then copied to my AMD based ESXi 4.1 Server.

HTH, Please rate if so

Thanks,

Justin

www.ucintegrations.com

ahzgid Thu, 11/22/2012 - 00:22

I wouldn't install any CU on non supported hardware for productive systems but it's just fine for lab purposes. 

There is a way to install directly to AMD ESXi which involve editing a file in the ISO image of the installation disk (to remove the hardware checks).

See http://htluo.blogspot.ch/2011/08/wheres-my-unity-connection-option.html for the details.

This can actually be used also for installations on smaller disks.

I can report that CM, Presence and Unity-Connection (8.x series) can be installed that way.


The MOH problem on AMD systems is caused by mismatched module architecture but this can be fixed too.

Once your system is installed look for the kernel version in /lib/modules/cm_ipvms and replace it.

The original directory ends with .i686 and you need to create one ending with .athlon

Copy all contents to a newly created directory ending with .athlon:

- mkdir /lib/modules/cm_ipvms/2.6.18-194.26.1.el5PAE.athlon

- cp -a /lib/modules/cm_ipvms/2.6.18-194.26.1.el5PAE.i686/* /lib/modules/cm_ipvms/2.6.18-194.26.1.el5PAE.athlon/

Restart your system and MOH will work.

Actions

Login or Register to take actions

This Discussion

Posted May 8, 2010 at 12:32 AM
Stats:
Replies:40 Avg. Rating:5
Views:36756 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 5,903
2 2,958
3 2,203
4 1,882
5 1,756