UC520 crashes/stops responding

Unanswered Question
May 8th, 2010

Hi All

I have a very weird problem. At a site we have a UC520 up and configured which runs just as supposed for a few hours (sometimes up to 9-10 hours), and then stops responding.


Traffic goes trough fine, but telephony stops working, no longer responds to DHCP requests, SSL VPN, SSH or CCA etc.- so basically all services stops working.

We then tried to copy the configuration to another UC520 (to make sure it is not hardware-related), but the problem still exists - which rules out hardware problems (at least with the UC520)

Anyone who has an idea about where to start?

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Darren DeCroock Sat, 05/08/2010 - 06:47

I would first suggest trying to narrow down the issue by connecting a phone directly to one of the ports on the UC520. (If you don't have any connected already.)  This would help to eliminate any other network hardware in your topology.  If a phone connected directly to your UC520 works, then look into you other network hardware.  If that phone does not work, then you will need to look into the settings on that UC520.

Thank you,

Darren

Simon Guldager ... Sat, 05/08/2010 - 06:49

We have a phone (7945) connected directly to the UC520, which works fine untill the UC520 stops responding. After a reboot of the UC520 it works fine again.

Darren DeCroock Sat, 05/08/2010 - 06:56

Then I would say that the network hardware is not the issue in this case.

What version of IOS and CUE are you running on this unit?

Have you run any debugs, or looked at the status of any of the interfaces to see if they are shutdown?

If data packets are still going though, is there any communication at all on VLAN 100?  (Your voice VLAN.)

What is the status of the CUE module when this happens?

Thank you,

Darren

Simon Guldager ... Sat, 05/08/2010 - 07:04

boot system flash uc500-advipservicesk9-mz.150-1.XA2

CUE is running UC500 series 7.1 (they dont use it as of right now)

Did not run any debugs, since i dont know what to look for. None of the interfaces are shutdown.

I have no clue whether or not there is any communication on the voice VLAN, since im unable to access the UC520 after it stops responding.

The CUE module seems to run fine, i can at least access it from 10.1.10.1/voiceview - if i do a reload trough web it comes up again (even though the UC520 is still not responding)

Darren DeCroock Sat, 05/08/2010 - 07:24

You said that the UC520 still passes traffic.  Is the UC520 the "gateway" for your internet connection?  And if so, can your computers still access the internet?

Can you get into the UC520 though telnet, or a console cable when it is down?

Also a few other questions I should have asked previously.  Did this just start happening, and do you know of any changes that were made just before this started to occur?

If you can, if may help if you could attach your running config.

Thank you,

Darren

Simon Guldager ... Sat, 05/08/2010 - 07:40

Yes, the UC520 is gateway for the internet.

Yes, they can still access the internet through the UC520. (For those clients that are on a static IP - DHCP server on UC520 stops, so those clients do not get an IP-address)

Can't get into the UC520 through telnet or SSH, haven't tried trough console - however that would be something i would definately try soon.

Yes, but i can't remember what changes were made that triggered this. It has been used in another site, so alot of the configuration has been changed to fit the new site.

I have attached the running-config.

Attachment: 
Simon Guldager ... Sat, 05/08/2010 - 15:19

There is actually a D-Link (i know....) switch connected for extra devices like printers and such. I'm starting to think this could be the device causing all this mess.

Anyway, this will however be changed very soon, since i ordered a ESW-520-24P-K9.

All clients are running antivirus, and there is no bad messages logged from the antivirus clients, nor any endusers reporting problems with their PC's. (at least not untill the UC520 stops responding)

David Trad Sat, 05/08/2010 - 14:46

Hi Simon,

Certainly sounds like the DHCP is bombing out, almost like as if the leases are not working. Are you aware of any other DHCP server on the network? Can you check for that ?

Can I suggest you have a quick once over the access-list, I don't have the time to do it for you right now due to it being Mothers Day and all here in Australia (The wife will shoot me for spending time on the computer), but at a quick glance at it seemed like it needs to be visited and checked to make sure that your flow of traffic is not being blocked as well.

I don't suppose as a test you can remove it entirely, run the system for a little while and see if it works and then just reinstate it? If I hit issues like this that is usually one of the first things I do as part of the fault finding process, I have a bad habit of breaking the access-list.

Just a thought anyway :)

Cheers,

David.

Simon Guldager ... Sat, 05/08/2010 - 15:16

The only DHCP server that is running is that on the UC520. The network is rather simple (a few clients and a server for file and mail, not running any DHCP server)

Could it be any clients requesting DHCP-addresses like "crazy"? And if so, would that end up in the UC520 becoming unresponsive?

The access-list is rather simple, since it's based on the basic access-list generated by the CCA firewall-settings. I don't think it's access-list related since everything works fine for a couple of hours (up to maybe 8-9 hours), however it is no problem turning it off if you think that would help (at least for testing purpose)?

Actions

This Discussion

Related Content