SSL VPN Policy for Group does not work

Unanswered Question
May 9th, 2010

Hi.

I've recently configured SSL VPN, and I've played around with some different policy settings. Right now I'm experiencing that a policy set for a user group fails to come into effect. I'll try and describe the scenario:

I have the default Domain SSLVPN, linked to the portal SSLVPN.

I have the default user group SSLVPN, and an additional user group called "SSL VPN User", both in the SSLVPN domain.

I have a user "admin" member of the SSLVPN group, and a user "am" member og the "SSL VPN User" group.

I have defined an SSL VPN Resource called "Web Resources" - this resource includes access to port 80 and some other ports I use for WebGUI access.

Furthermore I have imposed a global "Deny All" policy, denying access on all ports for all IP addresses.

Now the problem arise when I'm trying to apply the Web Resources policy to the different user groups.

I have permitted the "Web Resources" to the user group SSLVPN. This works, and when I log in with SSL VPN as "admin", I have access to the web resources.

Then I have permitted the "Web Resources" to the user group "SSL VPN User". This DOES NOT work, and when I log in with SSL VPN as the user "am" I DO NOT have access to the web resources, even though I should have this access. I have also tried to just give access to port 80 on my webserver (not using the Web Resource), this also doesn't work. It simply seems like the policies set for the "SSL VPN User" group do not apply at all.

Finally I assign permission to "Web Resources" for the user "am" specifically. This DOES work, and now I have SSL VPN access to the web resources again.

So the only thing not working is when I try to assign the resources to the user group I have created myself called "SSL VPN User". The problem is that I might well create more users in this group, and it would be nice to define a set of policies for this group only.

Can you please comment on this issue?

UPDATE:

I just tried deleting the "Web Resources" rule from both the user "am" and the group "SSL VPN User", along with all other allowed resources for this group and user, so now the user "am" should not have access to anything on the network. But now it seems like the user rule for "am" (the Web Resources") is still in effect, because I can still access the webserver and the different WebGUI's. I know the global deny all is in effect, because I can't access FTP and SSH.

Thanks, Artur

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hyeh Sun, 05/09/2010 - 15:10

Hi Artur,

Can you provide us your config so that we can verify it on our rig?

Thanks

Henry

arturmeinild Mon, 05/10/2010 - 00:55

Hi. Sure, but I guess this means that I have to change my passwords back to standard or can you import my config and keep the standard admin password so you can log in?

regards, Artur

hyeh Mon, 05/10/2010 - 10:15

Hi Artur,

Either way will be fine. However, If you think it is better to keep your

password confidential, you can change it back to default.

You can PM your config to me so that we can keep it private.

Thanks

Henry

arturmeinild Thu, 05/27/2010 - 07:50

Hi. Have you tested if you experience the same problems as I did with user permissions not being applied AND/OR still being applied after they have been removed again?

Thanks...