RV042 Access Rules not working

Unanswered Question
May 9th, 2010
User Badges:

Hi,


I Have a RV042 configured and working but it  appears the firewall rules don't work. Running latest firmware.


Example,

Internal  IP 1.1.1.1

External IP 2.2.2.2


If i want to enable  say port 5555 only from my ip to the internal address I have done the  following.


Allow Test [5555]  WAN1 2.2.2.2 ~2.2.2.2 Any Always


Allow All Traffic [1] LAN Any Any Always 

Deny All Traffic [1] WAN1 Any Any Always

Deny All Traffic [1] WAN2 Any Any Always



Now it is  simply not working, the rule below is for ping only from my external ip I  have tested it and it works, the rules above have been done the same  way. I have also added the new port in as a service in the port menu.



Allow Ping [0] WAN1 2.2.2.2 ~ 2.2.2.2 Any Always



If  i allow the port forward it simply opens up for anyone.


How  do I get this thing going please?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hornstein Sun, 05/09/2010 - 20:26
User Badges:
  • Gold, 750 points or more

Hi nettech,


Did you have an existing access list before you upgraded the software ?



Dave

nettechqld Sun, 05/09/2010 - 20:32
User Badges:

Hi Dave,


Device was factory reset, then the new image was loaded.


Reconfigured from then on.


It seems strange that its just 3389 with the problem. I do recall reading about others having issues trying to get rdp working on this device.


I have got 2 devices different locations same thing.

Te-Kai Liu Sun, 05/09/2010 - 21:08
User Badges:
  • Gold, 750 points or more

Below are the steps to set this up.

First, forward port 5555 to an internal address. This will open up port 5555 to all external users.

Second, add a Deny rule blocking all external ip from accessing port 5555.

Last, add an Allow rule that permits the specific public ip to access port 5555. 

David Hornstein Mon, 05/10/2010 - 05:38
User Badges:
  • Gold, 750 points or more

Ah good man,


Of course the RV042 is still in the gateway mode, not router mode.  port forwarding will still have to be enabled to enable access from the WAN to the LAN port number.. darn good catch.


regards Dave

Actions

This Discussion