Route filtering doesnt work !!!

Unanswered Question
May 9th, 2010

Hello everyone ,

I want to filter some routes with OSPF protocol ,I know that with OSPF i should do that on ABR or ASBRs but the problem is that when i configure route filtering to filter LSA type 3 ,instead of filter just one or two routes it filters all type 3 summery routes ,here is the configuration :

I have two routers R1 and R2 ,R1 is ABR with two areas attached to it ,i want to filter 192.168.10.0/24 network from area 1, here the configs but it doesn't work ...

ip prefix-list filter seq 5 deny 192.168.10.0/24

ip prefix-list filter seq 10 permit 0.0.0.0/0 le 32

router ospf 1

area 1 filter-list prefix filter out

.

.

.

..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sun, 05/09/2010 - 22:54

Hello Omid,

Can you please double-check your configuration? I have just tried replicating the same problem using the same commands you have used, and for me, the filtering works as expected - the 192.168.10.0/24 network in area 1 is not visible in the backbone, another networks from area 1 are advertised correctly.

Perhaps you could also post the configuration of your ABR.

Best regards,

Peter

Omid Almasieh Mon, 05/10/2010 - 00:20

Hi peter

thanks for your quick reply ,the configuration that i wrote was the exact configs that i did on ABR router !!! would u plz let me know the version of IOS that u'v tested with ?

Warm regards ,

Omid

Peter Paluch Mon, 05/10/2010 - 00:24

Hi Omid,

IOS version: C2691-ADVIPSERVICESK9-M, Version 12.4(25c)

Let's have a look at your configuration, OK? Can you post the relevant sections here? And also, it would be helpful to see the output of the show ip ospf database summary output on the ABR.

Best regards,

Peter

Actions

This Discussion