giga interface in router 2851

Unanswered Question
May 10th, 2010

hi;

i am facing problem in the configuration for the gig ehternet interface in this model 2851.

IOS version:

Cisco IOS Software, 2800 Software (C2800NMADVIPSERVICESK9-

M), Version 12.4(3g), RELEASE

SOFTWARE (fc2)

my problem is when i connect this interface to the switch was always shoing me as below

i configured IP address 192.168.0.1

giginterface 0/0 also is shoing (line:up, protcol: down)

also the media type is T.

i try to shut and no shut.

also I configured the speed to 100 and fullduplex

any advice to solve this issue.

this interface is working fine

i configured IP address : 172.16.31.80

giginterface 0/1 also is showing (line:up, protcol: up)

also the media type is RJ45.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bgandhi Mon, 05/10/2010 - 03:00

Just check the LED status on the switch port even though the port is "NO Shut", if that does not glow then propably you are

using wrong cable. You should use straight cable or the cable is faulty.

Regards,

bhavesh

Paolo Bevilacqua Mon, 05/10/2010 - 04:39

Just check the LED status on the switch port

What is the point of checking lights when same and more information can be had by command line ?

Let's try to give PROFESSIONAL answers, as network devices are not pressing irons.

yazan7873 Mon, 05/10/2010 - 04:41

sorry for my mistake.

the gigehternet interface 0/1 is working fine i connected to the service provider modem .

the gigethernet inetrface 0/0 is not working .

when i connect to the swicth the LED in the interface is off ,also i tried to swap the cable between the two interface but still not working.

kindly see the attched picture .

Attachment: 
bgandhi Mon, 05/10/2010 - 04:48

Just need a small clarification. Does other interface come up when you swap the cable. if so then it is claerly interface hardware issue.Also, Interafce output shows unidirectional operation. TX is shown but Rx is not shown. I also suspect switch port but assume, you would have already changed it.

Regards,

Bhavesh

yazan7873 Mon, 05/10/2010 - 04:57

hi;

the giga 0/1 is connected to the wan with service provider

our custmer requests to connect the other interface to switch

i configured the interface and i connect the cable but still not working and as you saw the line is up but the line protcool is down.

what i did.

i removed the cable from the gigabit 0/1 and put its in the gigabit 0/0 but still the same is not working .

i read in the interent may be this port should be configure the speed to 10/halfduplex is it correct?

note i am facing this problem in 6 router with same model 2851 and same ios.

bgandhi Mon, 05/10/2010 - 05:02

There is no such limitation. If you are connecting your WAN cable and still the interface does not come up then it is clearly hardware issue.However, sugegst you to do a step by step testing before concluding

1.) Remove WAN cable from G0/1 and connect it on G0/0. Put configuration from G0/1. Shut and no shut the interface. If it works then hardware is fine else it is hardware issue.

2.) Just to cross check cable and switch port connect the cable to g0/1 and see if the LED glows and line protocol is up without any errors.

Regards,

bhavesh

bgandhi Mon, 05/10/2010 - 05:36

Hi,

I am sorry, I missed the six router part. this may be some IOS BUG. Suggest, you try loading the latest IOS in one router and check.

Regards,

Bhavesh

Paolo Bevilacqua Mon, 05/10/2010 - 05:42

I am sorry, I missed the six router part. this may be some IOS BUG.  Suggest, you try loading the latest IOS in one router and check.

There is no bug in this case. OP is using wrong cable, or the other device is not configured correctly.

Leo Laohoo Mon, 05/10/2010 - 16:09

I would like to muddle things up.  The 2800 is one of the generation of appliance which supports MDI/MDIX.  Make sure the port configurations are auto speed and auto duplex for MDI/MDIX to work automatically otherwise setting of either speed and/or duplex will cause this feature to be disabled.

You can try the following:  Make yourself a loopback plug to test the interface.  Another is to patch Gig0/0 to Gig0/1. 

Actions

This Discussion

Related Content