Speeding up BGP convergence?

Answered Question
May 10th, 2010

All,

I've attached a diagram for a new project that I'm going to be setting up. I've labbed this up in GNS and it works fine one way, but doesn't work so well in reverse.

What I need is when the DS3 goes down, the traffic still goes through the main router to the DR router for 5 minutes. After the 5 minutes is up, HSRP will switch states to the Backup router. The problem comes in where the Main router's interface that the DR router is peering doesn't go down, and I've got local-pref set up on the DR router to prefer that router (main) for all internal routes.

What I did originally is created an EEM script that would shut down the interface on the Main router that peers with the DR when it sees the HSRP state change. After configuring fall-over on the DR router for that peer, this works fairly fast. The problem is when I open the interface back up. I start to lose traffic for a few seconds while the DR is repeering with the Main router. Is there a way to make this seamless with BGP, or is this as good as it's going to get?

I've also tried this with the main and backup routers in different ASs.

Thanks,

John

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 6 months ago

Hello John,

compliments for your creativity I have to put my hands on this EEM to stay tuned ...

instead of shutting down the interface you could think of using BGP conditional advertising if it fits your needs: with BGP conditional advertisements you can start to advertise when some specific BGP routes disappear from BGP table and this allows for some flexibility.

The difference is that the BGP session is always active, but advertisements are not done always.

This could save the time to setup the BGP session (it is already up)

However, it should be tested the convergence time to see if it provides better performance or not


see

http://www.cisco.com/en/US/docs/ios/iproute_bgp/configuration/guide/irg_basic_net_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1055919

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Mon, 05/10/2010 - 07:04

Hello John,

compliments for your creativity I have to put my hands on this EEM to stay tuned ...

instead of shutting down the interface you could think of using BGP conditional advertising if it fits your needs: with BGP conditional advertisements you can start to advertise when some specific BGP routes disappear from BGP table and this allows for some flexibility.

The difference is that the BGP session is always active, but advertisements are not done always.

This could save the time to setup the BGP session (it is already up)

However, it should be tested the convergence time to see if it provides better performance or not


see

http://www.cisco.com/en/US/docs/ios/iproute_bgp/configuration/guide/irg_basic_net_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1055919

Hope to help

Giuseppe

John Blakley Mon, 05/10/2010 - 07:24

Thanks Giuseppe

I'm going to lab up the conditional advertisement scenario to see

if that's what I need....I'll post up soon

John Blakley Mon, 05/10/2010 - 13:06

Okay,

Conditional advertising doesn't work, and I'm not sure why. What I have is the following:

access-list 10 permit 172.30.100.0 0.0.0.3

access-list 20 permit 10.10.10.0 0.0.0.255

route-map TEST permit 20

match ip address 10

route-map TEST2 permit 20

match ip address 20

router bgp 100

network 10.10.10.0 mask 255.255.255.0

network 172.30.100.0 mask 255.255.255.252

neighbor 172.16.100.2 advertise-map TEST2 exist-map TEST

The neighbor at 172.16.100.2 still shows the 10.10.10.0 network when I shut the interface (172.30.100.1) down that peers with the ISP. I don't want the 10.10.10.0/24 subnet on the router because I need it to failover to the other router without shutting the interface that peers with it.

Thanks,

John

John Blakley Mon, 05/10/2010 - 13:51

Okay, got it working by appending the AS to the route map, and it works a lot better than shutting the interface

Actions

This Discussion